Subject: Re: [dispatch] Lossless Recording in SIPREC

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 6 Feb 2014 14:45:29 +0000

Hi,

Is there a reason why you want to have this discussion in dispatch and not
in SIPREC WG which is meant to discuss the issues around SIP recording ?
If you don¹t have any specific reason to do it here you may want to start
this discussion in SIPREC WG.

I do have some comments on this topic but I think SIPREC WG is the right
place to have those discussions.

Regards,
Ram

From:  Gerben Stam <[email-masked]>
Date:  Thursday, 6 February 2014 3:58 pm
To:  Gerben Stam <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  [dispatch] Lossless Recording in SIPREC

Dear DISPATCH group,
 
SIPREC is a great initiative to standardize the interface for capturing
Communication Sessions.
Session Recording is becoming more and more critical due to Compliance and
regulatory changes over the last years.
 
The compliance market is requesting more than capture only these days
Confirmation is needed to acknowledge the entire Communication Session was
captured correctly.
RTCP Reports (rfc3611) will help to confirm complete handover of RTP
content.

New requirement is Œlossless¹ Session Capturing.
Lossless indicating handover of content (RTP) is acknowledged by the
receiver AND in case of receiving issues, the sender will resend.
Reasons for loss may be UDP packet loss or receiver failing(over) and
temporary not able to accept content.
Current approach to address this Œlossless¹ requirement is using 2
independent parallel receivers.

This requires the sender to send 2 individual streams, in fact 2
independent SIPREC sessions.

Not sure if this is covered currently as supported SIPREC deployment. We
do see implementations based on SIPREC supporting it.
Alternative is quick failover at receiver in case of failure but as sender
will send only once, this may lead to loss during failover.
 
I am not aware of any rfc covering lossless content handover, but there
may be standards covering this already.

Looking forward to discussion on the mailing list. I may be at the London
event.
 
Regards,
 
Gerben Stam,
NICE Systems

---

From: Gerben Stam <[email-masked]>
Date: Thu, 6 Feb 2014 15:10:12 +0000

Hey Ram,

I have had an off-line discussion with Andrew Hutton, chairman of the SIPREC group.
He suggested to post this on the IETF dispatch group as it is a good topic to discuss in the team.

What would I need to do to bend this to SIPREC WG instead of Dispatch?

Regards,

Gerben

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: donderdag 6 februari 2014 15:45
To: Gerben Stam
Cc: [email-masked]
Subject: Re: [dispatch] Lossless Recording in SIPREC

Hi,

Is there a reason why you want to have this discussion in dispatch and not in SIPREC WG which is meant to discuss the issues around SIP recording ?
If you don¹t have any specific reason to do it here you may want to start this discussion in SIPREC WG.

I do have some comments on this topic but I think SIPREC WG is the right place to have those discussions.

Regards,
Ram

Dear DISPATCH group,
 
SIPREC is a great initiative to standardize the interface for capturing Communication Sessions.
Session Recording is becoming more and more critical due to Compliance and regulatory changes over the last years.
 
The compliance market is requesting more than capture only these days Confirmation is needed to acknowledge the entire Communication Session was captured correctly.
RTCP Reports (rfc3611) will help to confirm complete handover of RTP content.

New requirement is Œlossless¹ Session Capturing.
Lossless indicating handover of content (RTP) is acknowledged by the receiver AND in case of receiving issues, the sender will resend.
Reasons for loss may be UDP packet loss or receiver failing(over) and temporary not able to accept content.
Current approach to address this Œlossless¹ requirement is using 2 independent parallel receivers.

This requires the sender to send 2 individual streams, in fact 2 independent SIPREC sessions.

Not sure if this is covered currently as supported SIPREC deployment. We do see implementations based on SIPREC supporting it.
Alternative is quick failover at receiver in case of failure but as sender will send only once, this may lead to loss during failover.
 
I am not aware of any rfc covering lossless content handover, but there may be standards covering this already.

Looking forward to discussion on the mailing list. I may be at the London event.
 
Regards,
 
Gerben Stam,
NICE Systems

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 6 Feb 2014 16:19:52 +0000

Hi,

Please see inline

-----Original Message-----
From: Gerben Stam <[email-masked]>
Date: Thursday, 6 February 2014 8:40 pm
To: Cisco Employee <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [dispatch] Lossless Recording in SIPREC

>topic to discuss in the team.

Ok. I was not aware of this.

>Is there a reason why you want to have this discussion in dispatch and
>not in SIPREC WG which is meant to discuss the issues around SIP
>recording ?
>Session Recording is becoming more and more critical due to Compliance
>and regulatory changes over the last years.
> 
>Confirmation is needed to acknowledge the entire Communication Session
>was captured correctly.

Why is this a new requirement ? RFC 6341 (SIPREC requirements) already has
a requirement for Lossless recording. See REQ 005.

>independent parallel receivers.

There may be other approaches well. For example an SRC may buffer for a
small duration to take care of the loss. Two parallel receivers still does
not guarantee that recording is loseless as you can have UDP packet loss
on both paths.

>Not sure if this is covered currently as supported SIPREC deployment.

Current SIPREC does not have any such constraints. Depending on your
implementation model you can have the same CS recorded by multiple SRC or
have same SRC do multiple recordings of same CS.

Regards,
Ram

> We do see implementations based on SIPREC supporting it.
>Alternative is quick failover at receiver in case of failure but as
>sender will send only once, this may lead to loss during failover.
>

---

From: "Parthasarathi R" <[email-masked]>
Date: Thu, 6 Feb 2014 22:21:06 +0530

Hi Gerben,

I agree with Ram that lossless recording is within SIPREC requirement as mentioned in RFC 6341. Apart from REQ-5 in RFC 6341, some of the text related to High availability is mentioned in the note of this mail.

Also, the lossless recording shall be achieved by multiple means. One of the mechanism is explained in draft-ietf-avtext-rtp-duplication-04. IMO, let us discuss in SIPREC about the specific technical issue in lossless recording which is not possible to be achieved through the existing mechanism 

Including SIPREC mailing alias in this mail thread.

Thanks
Partha

Note:

 Use Case 10: High availability and continuous recording.

      Specific deployment scenarios present different requirements for
      system availability, error handling, etc., including the
      following:

      o  An SRS must always be available at call setup time.

      o  No loss of media recording can occur, including during failure
         of an SRS.

      o  The Communication Session must be terminated (or suitable
         notification given to parties) in the event of a recording
         failure.

REQ-021: The mechanism MUST NOT prevent high-availability
      deployments. 

> From: dispatch [mailto:[email-masked]] On Behalf Of Ram
> Mohan R (rmohanr)
> Sent: Thursday, February 06, 2014 9:50 PM
> To: Gerben Stam
> Cc: [email-masked]
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Mary Barnes <[email-masked]>
Date: Thu, 6 Feb 2014 11:12:02 -0600

Please don't cross post as that makes it a nightmare for people who like to
put emails for various WGs in separate folders.  The IETF email system is
setup to avoid duplicates and also people are not subscribed always to both
lists and that results in messages in moderator queues.

It is a good idea however to post a note to the SIPREC mailing list that
this discussion is happening on the DISPATCH WG mailing list - including a
link to the discussion thread.

Thanks,
Mary.

On Thu, Feb 6, 2014 at 10:51 AM, Parthasarathi R <[email-masked]
> wrote:

> Hi Gerben,
>
> I agree with Ram that lossless recording is within SIPREC requirement as
> mentioned in RFC 6341. Apart from REQ-5 in RFC 6341, some of the text
> related to High availability is mentioned in the note of this mail.
>
> Also, the lossless recording shall be achieved by multiple means. One of
> the mechanism is explained in draft-ietf-avtext-rtp-duplication-04. IMO,
> let us discuss in SIPREC about the specific technical issue in lossless
> recording which is not possible to be achieved through the existing
> mechanism
>
> > >New requirement is OElossless¹ Session Capturing.
> >
> > >Current approach to address this OElossless¹ requirement is using 2
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 10 Feb 2014 14:05:36 +0000

Hi Gerben, 

Looking back at our off-list discussion I did actually say that you "should start a discussion on the SIPREC list".

Sorry if there was confusion.

Andy

> Sent: 06 February 2014 16:20
> To: Gerben Stam
> Cc: [email-masked]

---

From: Mary Barnes <[email-masked]>
Date: Mon, 10 Feb 2014 10:38:35 -0600

Yes, that is the appropriate action.  The ADs just met with the DISPATCH WG
chairs in preparation for IETF-89. We discussed this topic and agree that
discussion should move to SIPREC WG mailing list. But, it's important to
note that this dispatchment in no way implies that the community agrees
that work is needed. It's up to the SIPREC WG to make that decision.

Regards,
Mary
DISPATCH WG co-chair.

On Mon, Feb 10, 2014 at 8:05 AM, Hutton, Andrew <[email-masked]>wrote:

> Hi Gerben,
>
> Looking back at our off-list discussion I did actually say that you
> "should start a discussion on the SIPREC list".
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 10 Feb 2014 11:56:27 -0500

On 2/10/14 11:38 AM, Mary Barnes wrote:
> Yes, that is the appropriate action.  The ADs just met with the DISPATCH
> WG chairs in preparation for IETF-89. We discussed this topic and agree
> that discussion should move to SIPREC WG mailing list.

That's good. It will put the discussion with the people who care, and 
not bother others.

> But, it's
> important to note that this dispatchment in no way implies that the
> community agrees that work is needed. It's up to the SIPREC WG to make
> that decision.

Certainly!

	Thanks,
	Paul

> Regards,
> Mary
> DISPATCH WG co-chair.
>
>
> On Mon, Feb 10, 2014 at 8:05 AM, Hutton, Andrew <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi Gerben,
>
>      > From: dispatch [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Ram
>      > Mohan R (rmohanr)
>      > Cc: [email-masked] <mailto:[email-masked]>
>      > From: Gerben Stam <[email-masked]
>     <mailto:[email-masked]>>
>      > To: Cisco Employee <[email-masked] <mailto:[email-masked]>>
>      > Cc: "[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>      > >I have had an off-line discussion with Andrew Hutton, chairman
>     of the
>      > >SIPREC group.
>      > >From: Ram Mohan R (rmohanr) [mailto:[email-masked]
>     <mailto:[email-masked]>]
>      > >Cc: [email-masked] <mailto:[email-masked]>
>      > >From:  Gerben Stam <[email-masked]
>     <mailto:[email-masked]>>
>      > >To:  Gerben Stam <[email-masked]
>     <mailto:[email-masked]>>
>      > >Cc:  "[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>      > Why is this a new requirement ? RFC 6341 (SIPREC requirements)
>     already
>      > has
>      > implementation model you can have the same CS recorded by
>     multiple SRC
>      > or
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 10 Feb 2014 19:42:02 +0000

According to the charter:

The Dispatch working group is chartered to consider proposals for
new work in the RAI area and identify, or help create, an appropriate
venue for the work.

I would read this as a working group decision rather than a WG chairs decision.

Keith

________________________________
From: dispatch [mailto:[email-masked]] On Behalf Of Mary Barnes
Sent: 10 February 2014 16:39
To: Hutton, Andrew
Cc: Gerben Stam; [email-masked]
Subject: Re: [dispatch] Lossless Recording in SIPREC

Yes, that is the appropriate action.  The ADs just met with the DISPATCH WG chairs in preparation for IETF-89. We discussed this topic and agree that discussion should move to SIPREC WG mailing list. But, it's important to note that this dispatchment in no way implies that the community agrees that work is needed. It's up to the SIPREC WG to make that decision.

Regards,
Mary
DISPATCH WG co-chair.

On Mon, Feb 10, 2014 at 8:05 AM, Hutton, Andrew <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gerben,

Andy

> From: dispatch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ram
> Mohan R (rmohanr)
> Cc: [email-masked]<mailto:[email-masked]>
> From: Gerben Stam <[email-masked]<mailto:[email-masked]>>
> To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
> Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> >From: Ram Mohan R (rmohanr) [mailto:[email-masked]<mailto:[email-masked]>]
> >Cc: [email-masked]<mailto:[email-masked]>
> >From:  Gerben Stam <[email-masked]<mailto:[email-masked]>>
> >To:  Gerben Stam <[email-masked]<mailto:[email-masked]>>
> >Cc:  "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Mary Barnes <[email-masked]>
Date: Mon, 10 Feb 2014 14:04:01 -0600

Keith,

I'm not sure what your point is.  The DISPATCH WG chairs make
recommendations to the ADs based upon what they perceive as interest on the
DISPATCH WG mailing list.   If you concerns about an explicit action noted
below, please be specific.  It's not clear to me whether your concerned
about the decision for the discussion to move to SIPREC or the general
DISPATCH approach.

Mary.

On Mon, Feb 10, 2014 at 1:42 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

>   ------------------------------
> *From:* dispatch [mailto:[email-masked]] *On Behalf Of *Mary
> Barnes
> *Sent:* 10 February 2014 16:39
> *To:* Hutton, Andrew
> *Cc:* Gerben Stam; [email-masked]
>
> *Subject:* Re: [dispatch] Lossless Recording in SIPREC
>
> that discussion should move to SIPREC WG mailing list. But, it's important
> to note that this dispatchment in no way implies that the community agrees

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 10 Feb 2014 21:19:04 +0000

The ADs make decisions.

The DISPATCH WG chairs are there to represent the consensus of the WG. The charter does not create a special role for the DISPATCH WG chairs that goes beyond the role of any other WG chair.

While I do not necessarily regard this as contentious, the only discussion we have had on the list is whether it should go to dispatch first. The WG has had no mails that say: "Let's dispatch this to SIPREC."

So my concern is that the WG itself has been effectively ignored.

Let us see the question put to the WG.

regards

Keith

________________________________
From: Mary Barnes [mailto:[email-masked]]
Sent: 10 February 2014 20:04
To: DRAGE, Keith (Keith)
Cc: Hutton, Andrew; Gerben Stam; [email-masked]
Subject: Re: [dispatch] Lossless Recording in SIPREC

Keith,

I'm not sure what your point is.  The DISPATCH WG chairs make recommendations to the ADs based upon what they perceive as interest on the DISPATCH WG mailing list.   If you concerns about an explicit action noted below, please be specific.  It's not clear to me whether your concerned about the decision for the discussion to move to SIPREC or the general DISPATCH approach.

Mary.

On Mon, Feb 10, 2014 at 1:42 PM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
According to the charter:

Keith

________________________________
From: dispatch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mary Barnes
Sent: 10 February 2014 16:39
To: Hutton, Andrew
Cc: Gerben Stam; [email-masked]<mailto:[email-masked]>

Regards,
Mary
DISPATCH WG co-chair.

Andy

---

From: [email-masked] (Dale R. Worley)
Date: Mon, 10 Feb 2014 16:31:01 -0500 (EST)

> From: "DRAGE, Keith (Keith)" <[email-masked]>

> According to the [Dispatch] charter:
> 

It seems to me that "lossless recording" is well within the defined
responsibilities (charter) of Siprec.  Siprec may decide that they
ultimately need mechanisms that can only be defined by another WG,
though...

Dale

---

From: Mary Barnes <[email-masked]>
Date: Mon, 10 Feb 2014 15:36:30 -0600

On Mon, Feb 10, 2014 at 3:19 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

>  The ADs make decisions.
>
> The DISPATCH WG chairs are there to represent the consensus of the WG. The
> charter does not create a special role for the DISPATCH WG chairs that goes
> beyond the role of any other WG chair.
>
> While I do not necessarily regard this as contentious, the only discussion
> we have had on the list is whether it should go to dispatch first. The WG
> has had no mails that say: "Let's dispatch this to SIPREC."
>
[MB]
That was the point of the email that I sent earlier.  This is the proposal.
 If you have a compelling reason why we shouldn't do that, then post it.

There clearly were suggestions that this topic should just be discussed in
SIPREC and Partha had added them to the thread.  Another participant
actually responded to the thread only in SIPREC (one of the reasons I
discourage cross-posting).
[/MB]

[MB] Read my comment above. There is some common sense to be applied to the
process. [/MB]

> Let us see the question put to the WG.
[MB] The whole point of the DISPATCH process is that topics must be posted
to allow time for discussion and the WG to raise concerns. The DISPATCH
chairs then meet with the ADs (reviewing the relevant threads) and
determine whether there is enough interest in a topic and then propose the
best way to dispatch the topic.   There is nothing in IETF procedures that
require chairs to ask explicit questions.  Chairs make proposals and if you
disagree you can reply, in particular in cases that are clearly
non-controversial.

  Certainly, if there had been the slightest hint of controversy, we would
have kept the topic in DISPATCH until there was what the chairs deemed
clear consensus.   If you read the recording thread carefully, you can see
that one of the SIPREC chairs had previously told the individual that the
topic should be on SIPREC, so we are actually just clearly stating that
with this proposal/decision.  If you have concerns about the DISPATCH
process, please post a note to the RAI area mailing list. [/MB]

> *From:* Mary Barnes [mailto:[email-masked]]
> *Sent:* 10 February 2014 20:04
> *To:* DRAGE, Keith (Keith)
> *Cc:* Hutton, Andrew; Gerben Stam; [email-masked]
>
>>   Yes, that is the appropriate action.  The ADs just met with the
>> DISPATCH WG chairs in preparation for IETF-89. We discussed this topic and
>> agree that discussion should move to SIPREC WG mailing list. But, it's
>> community agrees that work is needed. It's up to the SIPREC WG to make that
>> decision.
>>
>>  Regards,
>> Mary
>> DISPATCH WG co-chair.
>>
>>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 11 Feb 2014 08:37:43 +0000

Hi,

As SIPREC co-chair I advised Gerben to discuss this topic on the SIPREC mailing list so that the SIPREC WG could assess whether it was in scope of SIPREC and if so whether the WG would want to work on it.  It was simply a mistake that the mail went to dispatch in the first place.

Of course if it turned out that it is not in the scope of SIPREC then we would ask for it to be taken to DISPATCH.

I don't see there is any issue here.

Regards
Andy

> From: Dale R. Worley [mailto:[email-masked]]
> Sent: 10 February 2014 21:31
> To: DRAGE, Keith (Keith)
> Cc: [email-masked]; Hutton, Andrew; [email-masked];
> [email-masked]