Subject: Re: [dispatch] Draft new: draft-holmberg-dispatch-iotl-00 - ABNF

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 May 2014 07:49:48 +0000

Hi,

>>  iotl-param    = iotl-tag "=" iotl-value
>>  iotl-tag      = "iotl"
>>  iotl-value    = "homeA-homeB" / "homeB-visitedB" / "visitedA-homeA"
>>                  / "homeA-visitedA" /" visitedA-homeB" / gen-value
>
>> Given the current set of values, it would seem reasonable that they 
>> would be mutually exclusive. But do you expect this to always be true? 
>> Would it be possible that if additional values are defined that they 
>> could compliment the currently set, i.e., should the syntax allow one 
>> or more values to be included?
>
> RFC 3261 specifies that there can be only one URI parameter of a single name attached to a URI. 

Correct. We would have to define a way to, for one URI parameter, provide a list of values.

> OTOH, given that <iotl-value> can produce <gen-value>, there's no reason that one cannot define values that mean "the effect of 'homeA-homeB' plus special feature XYZ".

Correct.

Jim, just to verify: did you talk about multiple values for a single URI? 

(If you have multiple URIs, you can naturally put a different value in each of them.)

> Perhaps the thing to do is to define a particular character to mean "separator of multiple values" in <iotl-value>s.  This allows people who want to have combined iotl values in the future a consistent way to do it.
>
> If we want to avoid the necessity of quoting <iotl-value>, we are restricted to <token>:
>
>      token       =  1*(alphanum / "-" / "." / "!" / "%" / "*"
>                     / "_" / "+" / "`" / "'" / "~" )
>
> Which allows . ! % * _ + ` ' ~ for delimiters.

Yes.

Regards,

Christer

---

From: "Calme, James A (Jim)" <[email-masked]>
Date: Thu, 8 May 2014 13:16:33 +0000

Hi Christer,

> Jim, just to verify: did you talk about multiple values for a single URI?
[jac] Yes, on a single URI.

> (If you have multiple URIs, you can naturally put a different value in each of them.)
[jac] Understood, but not my immediate concern.
...

> Christer

BR,
Jim

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 May 2014 14:31:18 +0000

Hi Jim,

Ok, so perhaps we could use e.g. dot as separator (and disallow dot in the value itself).

Regards,

Christer

Sent from my Sony Ericsson Xperia arc S

"Calme, James A (Jim)" <[email-masked]> wrote:

Hi Christer,

BR,
Jim

---

From: "Calme, James A (Jim)" <[email-masked]>
Date: Thu, 8 May 2014 18:18:36 +0000

Hi Christer,

I'm flexible on what to use as a separator, so long as multiple values are allowed.
Dot seems to be as good as any other value.

BR,
Jim

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Thursday, May 08, 2014 9:31 AM
To: Calme, James A (Jim); Dale R. Worley; [email-masked]
Subject: RE: [dispatch] Draft new: draft-holmberg-dispatch-iotl-00 - ABNF

Hi Jim,

Regards,

Christer

Hi Christer,

BR,
Jim