Subject: Re: [dispatch] New draft draft-jesske-dispatch-forking-answer-correlation-00

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Oct 2014 12:25:04 -0400

Roland,

I see there are extensive changes in the -01 version. I haven't had time 
to study them all. From a high level it looks like a better organization.

One comment on Figure 1:

 From a single INVITE sent by the UAC, the only *final* response(s) it 
will receive are:
- *one* response in range 3xx-6xx
- one *or more* 2xx responses.

The forking proxy is responsible for preventing any error responses once 
a 2xx response has been passed along. So in this flow the UAC should not 
receive either of the 487 responses. And it is only responsible for 
ACKing the 2xx responses it receives.

	Thanks,
	Paul

On 9/30/14 1:17 AM, [email-masked] wrote:
> Hi Mary,
>
> Thank you for your mail and clarification.
>
> Now I have a reworked version of the draft which is now available.
>
> A new version of I-D,
> draft-jesske-dispatch-forking-answer-correlation-01.txt
>
> has been successfully submitted by Roland Jesske and posted to the IETF
> repository.
>
> Name:       draft-jesske-dispatch-forking-answer-correlation
>
> Revision:   01
>
> Title:            Correlation of multiple responses of forked INVITES in
> Back to Back User Agents
>
> Document date:    2014-09-29
>
> Group:            Individual Submission
>
> Pages:            18
>
> URL:
> http://www.ietf.org/internet-drafts/draft-jesske-dispatch-forking-answer-correlation-01.txt
>
> Status:
> https://datatracker.ietf.org/doc/draft-jesske-dispatch-forking-answer-correlation/
>
> Htmlized:
> http://tools.ietf.org/html/draft-jesske-dispatch-forking-answer-correlation-01
>
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-jesske-dispatch-forking-answer-correlation-01
>
> Abstract:
>
>     This document describe how a correlation of multiple responses of a
>
>     forked INVITE in Back to Back User Agents can apply.
>
> Based on Paul’s comments I have restructured the draft. And changed the
> call flows.
>
> I would be happy to get comments and of course an indication that people
> would like to proceed with the work on the draft.
>
> Thank you and Best Regards
>
> Roland
>
> *Von:*dispatch [mailto:[email-masked]] *Im Auftrag von *Mary
> Barnes
> *Gesendet:* Freitag, 26. September 2014 19:25
> *An:* Christer Holmberg
> *Cc:* [email-masked]
> *Betreff:* Re: [dispatch] New draft
> draft-jesske-dispatch-forking-answer-correlation-00
>
> This discussion should continue in the DISPATCH WG until we get
> community consensus that people think this problem is worth solving and
> that there are people willing to do the work to complete a solution.  As
> Christer notes, this work is currently not within the scope of the
> current STRAW charter and so it's not clear it should be immediately
> dispatched there.
>
> Per the deadlines on the DISPATCH WG wiki, based on the DISPATCH WG
> chairs discussion with the ADs, we will post the list of topics and the
> handling thereof for the IETF-91 timeframe on October 13th.
>
> At this point, the only technical comments have been from Paul.
>
> Regards,
>
> Mary
>
> as DISPATCH WG co-chair
>
> On Fri, Sep 19, 2014 at 1:34 PM, Christer Holmberg
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>
> (As STRAW co-chair)
>
> Hi Paul,
>
>  >    This document will describe how a correlation for multiples early
>  >    dialogs and other received Responses can done within a B2BUA as
>  >    described in the taxonomy document RFC7029 [RFC7029] The role of the
>  >    B2BUA is a Signaling/Media Plane B2BUA Role.  Thus many possible use
>  >    cases which will be possible looking on the used features are
>  >    considered in this document
>  >
>  > If this is really about how B2BUAs do it, then perhaps this belongs
> in STRAW.
>
> I actually told Roland to submit the draft to DISPATCH, as it doesn't
> address any of the current STRAW deliveries.
>
> But, if there is no need to go via DISPATCH, we can ask Roland to submit
> to STRAW directly :)
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dispatch
>
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: <[email-masked]>
Date: Thu, 2 Oct 2014 08:34:11 +0200

Hi Paul,
Thank you for your comment. I have it changed for the next version.

Best Regards

Roland

> -----Ursprüngliche Nachricht-----
> Von: dispatch [mailto:[email-masked]] Im Auftrag von Paul
> Kyzivat
> Gesendet: Mittwoch, 1. Oktober 2014 18:25
> An: [email-masked]
> Betreff: Re: [dispatch] New draft draft-jesske-dispatch-forking-answer-
> correlation-00
> 
> Roland,
> 
> > has been successfully submitted by Roland Jesske and posted to the
> > IETF repository.
> >
> > Based on Paul's comments I have restructured the draft. And changed
> > the call flows.
> >
> > I would be happy to get comments and of course an indication that
> > people would like to proceed with the work on the draft.
> >
> > *Von:*dispatch [mailto:[email-masked]] *Im Auftrag von
> > *Mary Barnes
> > community consensus that people think this problem is worth solving
> > and that there are people willing to do the work to complete a
> > solution.  As Christer notes, this work is currently not within the
> > scope of the current STRAW charter and so it's not clear it should be
> > immediately dispatched there.
> >
> > chairs discussion with the ADs, we will post the list of topics and
> > the handling thereof for the IETF-91 timeframe on October 13th.
> >
> > But, if there is no need to go via DISPATCH, we can ask Roland to
> > submit to STRAW directly :)
> >
> > Regards,
> >
> > Christer
> >
> >
> >