Subject: Re: [dispatch] AD review of draft-holmberg-dispatch-iotl - ABNF

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Dec 2014 15:08:30 +0000

Hi,

>> I suggest to keep the text as it is. I am sure the wise men and women of the IESG will guide me in the right direction, to get it right.
>
> Note that the text, as-is, *revises* the abnf definition of uri-parameter, specifying that it can take on one of a set of values, including 
> your new one and some old ones. But if you examine the existing registry you will find that there are several additional values currently 
> defined that are *not* included in your new abnf. The result is that your text adds confusion.

I think any other values are covered by "other-param", aren't they?

Anyway, I have no problem using =/. So:

	"uri-parameter =/  iotl-param"

Regards,

Christer

> -----Original Message-----
> From: dispatch [mailto:[email-masked]] On Behalf Of DRAGE, 
> Keith (Keith)
> Sent: 14 December 2014 19:32
> To: Paul Kyzivat; [email-masked]
> Subject: Re: [dispatch] AD review of draft-holmberg-dispatch-iotl
>
> The IANA considerations section extends nothing - it is merely a set of instructions to IANA on how to update the registration tables.
>
> Therefore what you propose is not a practical solution to the documentation.
>
> Regards
>
> Keith
>
>> -----Original Message-----
>> From: dispatch [mailto:[email-masked]] On Behalf Of Paul 
>> Kyzivat
>> Sent: 12 December 2014 21:07
>> To: [email-masked]
>> Subject: Re: [dispatch] AD review of draft-holmberg-dispatch-iotl
>>
>> On 12/12/14 11:57 AM, Christer Holmberg wrote:
>>> Hi,
>>>
>>>>> There has been some discussion about whether such a change (using
>>>>> =/) constitutes a revision to the base draft. (IMO it does, some 
>>>>> people don't think so.) If you actually do the change as you did 
>>>>> then I think there is no question - it clearly is a revision!
>>>>
>>>> It could be argued both ways, I think.  Strictly speaking,
>> the change
>>>> doesn't extend the set of strings that are generated by 
>>>> <uri-parameter>, so I could argue that the draft only
>> extends the base RFC by providing additional interpretation to 
>> strings that > are already valid.
>>>
>>> My fingers are ready, waiting on the keyboard. Just tell me what to 
>>> type :)
>>
>> My preference is that you not provide any ABNF extending the values 
>> for uri-parameter. The IANA considerations section are sufficient.
>>
>> Obviously we have a difference of opinion here.
>>
>> 	Thanks,
>> 	Paul
>>
>> _______________________________________________
>> dispatch mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dispatch
>>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Dec 2014 10:24:57 -0500

> I think any other values are covered by "other-param", aren't they?

And your new value is already covered by other-param too. So there 
really is no reason to revise the ABNF. In fact, since there is a 
registry, there is no reason for the abnf to mention any alternative 
other than other-param.

When implementing an application that processes sip URIs, you cannot 
count on the abnf definition of uri-parameter from any single source as 
definitive for what parameters you need to handle. You will likely be 
supporting multiple RFCs that define URI parameters, and no single one 
is likely to have an exhaustive list.

> 	"uri-parameter =/  iotl-param"

I've already stated my preference. But I find this acceptable.

	Thanks,
	Paul