Subject: [dispatch] New Version Notification for draft-mohali-dispatch-cause-for-service-number-01.txt

From: <[email-masked]>
Date: Mon, 26 Jan 2015 13:58:35 +0000

Hi all,

I have submitted a new version of the draft http://tools.ietf.org/html/draft-mohali-dispatch-cause-for-service-number-01 (see below).

You can see the following changes:

----------------------------------------------------

- Editorial comments from the mailing list have been taken into account

- More editorial changes have been done : remaining "header" into "header field", "MUST" into "must",

- After Jörgen’s comment about usage of this new cause-param value in the History-Info header field with the pre-requiste of the "mp" parameter or not I changed the way to defined this new value without making a pre-requiste condition concerning the hi-target-param to be used "rc" or "mp" in the History-Info header-field.

- I also added more text on the fact that this document is only about the cause URI parameter and not the cause header field parameter of the Reason header. Indeed, the lack of clear distinction between those 2 "cause" parameters brought many confusion in the past for the History-Info header implementation.

- After Dale’s comment concerning the "IN" wording reference and vocabulary, I added some explanatory text referring to Q1201 to give more background to the reader on this old wording and the link with the new vocabulary.

- A complete example based on the Toll-Free example in RFC7131 has been added.

I hope this new version would be fine and I would like to have some review and feedback on it.

With the previous feedbacks and interests, I hope this document could have a good progress in the working group and be presented at the next meeting.

Best Regards,

Marianne

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]]
Envoyé : mercredi 21 janvier 2015 13:03
À : MOHALI Marianne IMT/OLN; MOHALI Marianne IMT/OLN
Objet : New Version Notification for draft-mohali-dispatch-cause-for-service-number-01.txt

A new version of I-D, draft-mohali-dispatch-cause-for-service-number-01.txt

has been successfully submitted by Marianne Mohali and posted to the IETF repository.

Name:              draft-mohali-dispatch-cause-for-service-number

Revision:          01

Title:                 Session Initiation Protocol (SIP) Cause URI parameter for Service Number translation

Document date:            2015-01-21

Group:             Individual Submission

Pages:             8

URL:            http://www.ietf.org/internet-drafts/draft-mohali-dispatch-cause-for-service-number-01.txt

Status:         https://datatracker.ietf.org/doc/draft-mohali-dispatch-cause-for-service-number/

Htmlized:       http://tools.ietf.org/html/draft-mohali-dispatch-cause-for-service-number-01

Diff:           http://www.ietf.org/rfcdiff?url2=draft-mohali-dispatch-cause-for-service-number-01

Abstract:

   [RFC4458] defines a "cause" URI parameter as having predefined values

   for Redirecting reasons as a mapping from ITU-T Q.732.2-5 Redirecting

   Reasons.  The "cause" URI parameter is to be used in SIP or SIPs URI.

   In particular, it may appear in the History-Info header field

   defined in [RFC7044] that must be added in retargeted requests.

   This specification creates a new predefined value for cases when the

   retargeting is caused by a specific service action leading to a

   called service access number translation.

   This document updates [RFC4458].

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 26 Jan 2015 14:30:37 -0500

This makes more sense to me now than when I first read -00. (I don't 
know if it is because the text is better, or because of all the 
conversation in the meantime.)

I do have a comment:

The introduction now points out that the cause parameter can be used in 
the R-URI as well as in the History-Info header. But the solution only 
mentions the new cause parameter value being used in H-I. Is there a 
reason why it can't be used in the the R-URI?

Also, in message F2 of the example, it *isn't* used in the R-URI of the 
retargeted request, even though it is included in the H-I entry 
containing that same URI. IIUC that URI in the H-I ought to match what 
is in the R-URI.

	Thanks,
	Paul

On 1/26/15 8:58 AM, [email-masked] wrote:
> Hi all,
>
> I have submitted a new version of the draft
> http://tools.ietf.org/html/draft-mohali-dispatch-cause-for-service-number-01
> (see below).
>
> - After Jörgen’s comment about usage of this new cause-param value in
> the History-Info header field with the pre-requiste of the "mp"
> parameter or not I changed the way to defined this new value without
> making a pre-requiste condition concerning the hi-target-param to be
> used "rc" or "mp" in the History-Info header-field.
>
> - I also added more text on the fact that this document is only about
> the cause URI parameter and not the cause header field parameter of the
> Reason header. Indeed, the lack of clear distinction between those 2
> "cause" parameters brought many confusion in the past for the
> History-Info header implementation.
>
> - After Dale’s comment concerning the "IN" wording reference and
> vocabulary, I added some explanatory text referring to Q1201 to give
> more background to the reader on this old wording and the link with the
> new vocabulary.
>
> With the previous feedbacks and interests, I hope this document could
> have a good progress in the working group and be presented at the next
> meeting.
>
> Best Regards,
>
> Marianne
>
> Objet : New Version Notification for
> draft-mohali-dispatch-cause-for-service-number-01.txt
>
> URL:
> http://www.ietf.org/internet-drafts/draft-mohali-dispatch-cause-for-service-number-01.txt
>
> Status:
> https://datatracker.ietf.org/doc/draft-mohali-dispatch-cause-for-service-number/
>
> Htmlized:
> http://tools.ietf.org/html/draft-mohali-dispatch-cause-for-service-number-01
>
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-mohali-dispatch-cause-for-service-number-01
>
> Abstract:
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>