Subject: [dispatch] Fwd: New Version Notification for draft-kyzivat-dispatch-trs-call-info-purpose-00.txt

From: Paul Kyzivat <[email-masked]>
Date: Tue, 13 Jan 2015 11:14:26 -0500

Dispatchers:

I have just submitted a new draft (see below) that needs to be 
dispatched. It defines a new Call-Info 'purpose' parameter value.

The intended audience for this draft is quite limited - to the providers 
of the Video Relay Service in the US, and to the FCC that sponsors that 
service. The Intro section explains this.

I'm hoping this can be dispatched without causing a lot of bother for 
anybody. I don't anticipate that it needs time in Dallas. IIUC documents 
of this sort are often AD sponsored.

	Thanks,
	Paul

-------- Original Message --------
Subject: New Version Notification for 
draft-kyzivat-dispatch-trs-call-info-purpose-00.txt
Date: Tue, 13 Jan 2015 07:46:47 -0800
From: [email-masked]
To: Paul Kyzivat <[email-masked]>,        "Paul Kyzivat" 
<[email-masked]>

A new version of I-D, draft-kyzivat-dispatch-trs-call-info-purpose-00.txt
has been successfully submitted by Paul Kyzivat and posted to the
IETF repository.

Name:		draft-kyzivat-dispatch-trs-call-info-purpose
Revision:	00
Title:		Telecommunications Relay Service Purpose for the Call-Info 
Header Field in the Session Initiation Protocol (SIP)
Document date:	2015-01-13
Group:		Individual Submission
Pages:		4
URL: 
http://www.ietf.org/internet-drafts/draft-kyzivat-dispatch-trs-call-info-purpose-00.txt
Status: 
https://datatracker.ietf.org/doc/draft-kyzivat-dispatch-trs-call-info-purpose/
Htmlized: 
http://tools.ietf.org/html/draft-kyzivat-dispatch-trs-call-info-purpose-00

Abstract:
    This document defines and registers a value of "original-identity"
    for the "purpose" header field parameter of the Call-Info header
    field in the Session Initiation Protocol (SIP).

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 20 Jan 2015 12:53:02 -0500

Based on feedback from the chairs and Brett Tate I have submitted an 
updated version of this draft. It gives more motivation and a list of 
requirements.

	Thanks,
	Paul

On 1/13/15 11:14 AM, Paul Kyzivat wrote:
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

Subject: New Version Notification for draft-kyzivat-dispatch-trs-call-info-purpose-01.txt
From: [email-masked]
To: Paul Kyzivat <[email-masked]>, "Paul Kyzivat" <[email-masked]>
Date: Tue, 20 Jan 2015 09:45:31 -0800

A new version of I-D, draft-kyzivat-dispatch-trs-call-info-purpose-01.txt
has been successfully submitted by Paul Kyzivat and posted to the
IETF repository.

Name:		draft-kyzivat-dispatch-trs-call-info-purpose
Revision:	01
Title:		Telecommunications Relay Service Purpose for the Call-Info Header Field in the Session Initiation Protocol (SIP)
Document date:	2015-01-20
Group:		Individual Submission
Pages:		5
URL:            http://www.ietf.org/internet-drafts/draft-kyzivat-dispatch-trs-call-info-purpose-01.txt
Status:         https://datatracker.ietf.org/doc/draft-kyzivat-dispatch-trs-call-info-purpose/
Htmlized:       http://tools.ietf.org/html/draft-kyzivat-dispatch-trs-call-info-purpose-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-kyzivat-dispatch-trs-call-info-purpose-01

Abstract:

The IETF Secretariat

---

From: [email-masked] (Dale R. Worley)
Date: Thu, 22 Jan 2015 22:44:35 -0500

> service. The Intro section explains this.

The use of "original IP address" as the means to identify the caller
seems rather odd to me.  But I assume that this is what the FCC
specifies, and they have good reason to do this.  Given that:

Should the 'purpose' value be "original-ip-address"?

Should the draft specify that the URI must have the syntax "sip:" +
IPv4address?  It doesn't specify that now, although the usage has that
restriction.  What about IPv6 addresses?  Or should we leave no
restrictions on the URI to allow future improvements, and just note that
the current practice is to use a very limited syntax?

Dale

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 22 Jan 2015 23:29:19 -0500

> specifies, and they have good reason to do this.  Given that:

It is what it is, whether it makes sense or not.

> the current practice is to use a very limited syntax?

I was trying to make the mechanism at least a little less special 
purpose. In practice, when used for TRS, it will contain an IP address. 
But the mechanism doesn't need to be that specialized.

Currently an IPv6 would be acceptable. And an h323 address might also 
make sense. (I included use cases for that.) And in some other context 
(without the FCC requirement) maybe a non-ip address would be ok.

	Thanks,
	Paul

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 23 Jan 2015 19:10:55 +0000

The IP address requirement, while crude, addresses the need to ascertain whether the calling party is currently located in the United States since only such calls are reimbursable. (VPNs are a well-known issue, but the concern is not so much that an there will be an occasional VPN user but wholesale rule bypass. Almost all legitimate calls will originate from consumer or business end user addresses, not, say, cloud servers or other likely VPN entities. There are well-known and pretty accurate IP address-to-country databases, as well as databases of which ISP has the address. The number of VRS users is sufficiently small that any odd-looking patterns can be investigated manually.)

Apparently, since other countries, including other countries in North America, do not offer the same level of VRS service, there's an incentive to "loan" accounts to friends and family elsewhere, or to use it by citizens living abroad.

The idea is not "to identify the caller" as an individual; each caller is already authenticating to the service.

There could well be other uses for this, particularly as other proprietary video communication systems are bridged into VRS.

________________________________________
From: dispatch [[email-masked]] on behalf of Paul Kyzivat [[email-masked]]
Sent: Thursday, January 22, 2015 11:29 PM
To: Dale R. Worley
Cc: [email-masked]
Subject: Re: [dispatch] Fwd: New Version Notification for draft-kyzivat-dispatch-trs-call-info-purpose-00.txt

        Thanks,
        Paul