Subject: Re: [dispatch] PCP for SIP Deployments

From: <[email-masked]>
Date: Thu, 5 Mar 2015 10:18:05 +0000

Hi Partha,

Thank you for the feedback.

I understand more your comment about ICE. I updated the draft accordingly.

Please check the new version and the diff:

URL:            http://www.ietf.org/internet-drafts/draft-boucadair-pcp-sip-ipv6-05.txt

Status:         https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6/

Htmlized:       http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-05

Diff:           http://www.ietf.org/rfcdiff?url2=draft-boucadair-pcp-sip-ipv6-05

Thank you.

Cheers,
Med

De : Parthasarathi R [mailto:[email-masked]]
Envoyé : jeudi 5 mars 2015 01:21
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : RE: [dispatch] PCP for SIP Deployments

Hi Med,

Thanks for incorporating the comments.

ICE is used in the context of SIP over WebSocket (RFC 7118) & WebRTC SDP profile within managed networks. TURN has its own limitation in traversing NAT/FW using UDP transport in case of managed networks. PCP server in NAT &FW resolves these issues. Of course, the current implementations (WebRTC devices) have challenges in using ICE + PCP but IMO, it is good have for future works.

Thanks
Partha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, March 02, 2015 9:56 PM
To: Parthasarathi R; [email-masked]<mailto:[email-masked]>
Subject: RE: [dispatch] PCP for SIP Deployments

Hi Partha,

Many thanks for the review and the comments.

I integrated almost all your suggestion, except the one about the ICE discussion. The reason for that is ICE is not deployed in the managed context; as such I'm afraid there is no value in having such discussion in the I-D.

Please check the diff and let me know if you have further comments.

URL:            http://www.ietf.org/internet-drafts/draft-boucadair-pcp-sip-ipv6-04.txt

Status:         https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6/

Htmlized:       http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-04

Diff:           http://www.ietf.org/rfcdiff?url2=draft-boucadair-pcp-sip-ipv6-04

Thank you.

Cheers,
Med

De : Parthasarathi R [mailto:[email-masked]]
Envoyé : vendredi 27 février 2015 23:47
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>
Objet : RE: [dispatch] PCP for SIP Deployments

Hi Med,

It is a interesting draft. The current writing provides PCP advantages in SIP managed network and particularly cellular. The following information has to be added to provide more clarity about this work:

1)      Network diagram/topology with SIP UA, SIP proxy/B2BUA, PCP client, PCP server

2)      Basic callflow to show how the dialog is established in case P2P is used

3)      The draft title mentions IPv6. My understanding is that this shall be used for IPv4 network as well.

4)      Add more details about how SIP, PCP, ICE interworking happens as the current reference is related to PCP with rtcweb only.

5)      Security implication w.r.t SIP usage of PCP has to be mentioned.

6)      Advantage of using PCP over TURN in SIP network shall be provided in the introduction section for better comparison.

Regards
Partha

From: dispatch [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, February 26, 2015 3:02 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [dispatch] PCP for SIP Deployments

Hi all,

I would like to share with this group a short document that explains how PCP can be of great use in the context SIP-based services:
http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-03

As indicated in the I-D, the main benefits include (but not limited to):

   o  Avoid embedding an ALG in the middleboxes.  Note, ALGs are not

      recommended since the evolution of the service would depend on the

      ALG maintenance.

   o  Not require any Hosted NAT Traversal function (e.g., [RFC7362<http://tools.ietf.org/html/rfc7362>]) to

      be embedded in the SIP server.  Intermediate NATs and firewalls

      are transparent to the SIP service platform.

   o  Avoid overloading the network with keepalive message to maintain

      the mapping in intermediate middleboxes.

   o  Work without requiring symmetric RTP/RTCP [RFC4961<http://tools.ietf.org/html/rfc4961>].

   o  Not require symmetric SIP to work (i.e., rport [RFC3581<http://tools.ietf.org/html/rfc3581>]).

   o  Easily support unidirectional sessions.

When this document was first presented in the PCP WG, I was suggested that it is better to publish it in RAI with a review from the PCP WG. Hence, this message to the list.

Cheers,
Med

---

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 11 Mar 2015 06:04:37 +0530

Hi Med,

The updated version looks good.

Thanks

Partha

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 05, 2015 3:48 PM
To: Parthasarathi R; [email-masked]
Subject: RE: [dispatch] PCP for SIP Deployments

Hi Partha, 

URL:
<http://www.ietf.org/internet-drafts/draft-boucadair-pcp-sip-ipv6-05.txt>
http://www.ietf.org/internet-drafts/draft-boucadair-pcp-sip-ipv6-05.txt

Status:
<https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6/>
https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6/

Htmlized:
<http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-05>
http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-05

Diff:
<http://www.ietf.org/rfcdiff?url2=draft-boucadair-pcp-sip-ipv6-05>
http://www.ietf.org/rfcdiff?url2=draft-boucadair-pcp-sip-ipv6-05

Thank you.

Cheers,

Med

Hi Med,

ICE is used in the context of SIP over WebSocket (RFC 7118) & WebRTC SDP
profile within managed networks. TURN has its own limitation in traversing
NAT/FW using UDP transport in case of managed networks. PCP server in NAT
&FW resolves these issues. Of course, the current implementations (WebRTC
devices) have challenges in using ICE + PCP but IMO, it is good have for
future works.

Thanks

Partha

From:  <mailto:[email-masked]> [email-masked] [
<mailto:[email-masked]> mailto:[email-masked]] 
Sent: Monday, March 02, 2015 9:56 PM
To: Parthasarathi R;  <mailto:[email-masked]> [email-masked]
Subject: RE: [dispatch] PCP for SIP Deployments

Hi Partha,

I integrated almost all your suggestion, except the one about the ICE
discussion. The reason for that is ICE is not deployed in the managed
context; as such I’m afraid there is no value in having such discussion in
the I-D. 

URL:
<http://www.ietf.org/internet-drafts/draft-boucadair-pcp-sip-ipv6-04.txt>
http://www.ietf.org/internet-drafts/draft-boucadair-pcp-sip-ipv6-04.txt

Status:
<https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6/>
https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6/

Htmlized:
<http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-04>
http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-04

Diff:
<http://www.ietf.org/rfcdiff?url2=draft-boucadair-pcp-sip-ipv6-04>
http://www.ietf.org/rfcdiff?url2=draft-boucadair-pcp-sip-ipv6-04

Thank you.

Cheers,

Med

De : Parthasarathi R [ <mailto:[email-masked]>
mailto:[email-masked]] 
Envoyé : vendredi 27 février 2015 23:47
À : BOUCADAIR Mohamed IMT/OLN;  <mailto:[email-masked]> [email-masked]
Objet : RE: [dispatch] PCP for SIP Deployments

Hi Med,

It is a interesting draft. The current writing provides PCP advantages in
SIP managed network and particularly cellular. The following information has
to be added to provide more clarity about this work:

1)      Network diagram/topology with SIP UA, SIP proxy/B2BUA, PCP client,
PCP server

2)      Basic callflow to show how the dialog is established in case P2P is
used

3)      The draft title mentions IPv6. My understanding is that this shall
be used for IPv4 network as well.

4)      Add more details about how SIP, PCP, ICE interworking happens as the
current reference is related to PCP with rtcweb only.

6)      Advantage of using PCP over TURN in SIP network shall be provided in
the introduction section for better comparison.

Regards

Partha

From: dispatch [ <mailto:[email-masked]>
mailto:[email-masked]] On Behalf Of
<mailto:[email-masked]> [email-masked]
Sent: Thursday, February 26, 2015 3:02 PM
To:  <mailto:[email-masked]> [email-masked]
Subject: [dispatch] PCP for SIP Deployments

Hi all,

I would like to share with this group a short document that explains how PCP
can be of great use in the context SIP-based services:

 <http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-03>
http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-03 

   o  Avoid embedding an ALG in the middleboxes.  Note, ALGs are not
      recommended since the evolution of the service would depend on the
      ALG maintenance.
   o  Not require any Hosted NAT Traversal function (e.g., [
<http://tools.ietf.org/html/rfc7362> RFC7362]) to
      be embedded in the SIP server.  Intermediate NATs and firewalls
      are transparent to the SIP service platform.
   o  Avoid overloading the network with keepalive message to maintain
      the mapping in intermediate middleboxes.
   o  Work without requiring symmetric RTP/RTCP [
<http://tools.ietf.org/html/rfc4961> RFC4961].
   o  Not require symmetric SIP to work (i.e., rport [
<http://tools.ietf.org/html/rfc3581> RFC3581]).
   o  Easily support unidirectional sessions.

When this document was first presented in the PCP WG, I was suggested that
it is better to publish it in RAI with a review from the PCP WG. Hence, this
message to the list. 

Cheers,

Med