Subject: [dispatch] Against RFC 3891 :)

From: "Anton Tveretin" <[email-masked]>
Date: Mon, 27 Apr 2015 00:58:31 +0500

Hello All,
Few more notes about my draft.
The question is, should the Ctg request the caller (RFC 3891) or the callee to pick up a call? 
The former, in addition to charging issues, brings up the following:
1. Routing to the caller, which could be hindered by line hunting. I know there is a recently 
published RFC about this.
2. Call barring policy at either side.
3. Information for the callee only (if it could be). Clearly, this is not possible with RFC 3891. It 
is not specified in draft-worley-sipping-pickup-01, nor in draft-tveretin-dispatch-remote-00, but 
will be in -01 version (Subject: header).
Of course, I do not want to restrict applicability of the RFC 3891.
Regards,
Anton.

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 26 Apr 2015 17:31:51 -0400

> The question is, should the Ctg request the caller (RFC 3891) or the callee to pick up a call?

I'm not sure I understand your question. When you say "pick up a call" 
do you mean:
1) answer the call?
2) initiate a call that will replace the initial one?
3) pay for the call?

If you mean *answer* then the question is nonsense.

If you mean *pay for* then the answer is presumably that the Ctg device 
should choose which one it has sufficient control over. (I guess it 
often will be the case that it doesn't have authorization to control 
them both.)

And I think that is also the answer if you meant *pay for*.

	Thanks,
	Paul

> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>