Subject: Re: [dispatch] Standardization of FFV1, Matroska

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 22 Jul 2015 07:38:44 +0000

Can I ask how much buy in these have from the archives community.

So for example, if I search The National Archives site in the UK, I can find no mention of it, despite The National Archives claiming to be front runners in the preservation of digital material.

Are we talking here about one input of many from the archives community, or are we talking about a proposal that already has consensus internationally in the archives community?

Keith

________________________________
From: dispatch [mailto:[email-masked]] On Behalf Of Tessa Fallon
Sent: 21 May 2015 17:31
To: [email-masked]
Subject: [dispatch] Standardization of FFV1, Matroska

Greetings!

MediaConch: Media Conformance Checker (maintained by MediaArea and funded by PREFORMA*) is looking to solicit feedback from the IETF for proposed standardization of FFV1 and Matroska.

The current (and under development) specifications for FFV1 exist here: https://mediaarea.net/ffv1.html<https://mediaarea.net/temp/ffv1.html>
and here for Matroska:
 http://matroska.org/technical/specs/index.html<https://github.com/Matroska-Org/foundation-source/blob/master/spectool/specdata.xml>

The goal of the PREFORMA project is to address the challenge of implementing good quality standardised file formats for preserving data content in the long term. Our objective in regards to standardization FFV1 and Matroska is to improve the sustainability factors for both formats including disclosure, credibility, and transparency while also creating a mechanism to clarify, authoritatively, the intent of the specifications. After careful research into past IETF work (in particular Daala and Opus), we are planning to prepare FFV1 and Matroska for submission to the IETF.

Our preparations are not yet at the stage where we have created a formal draft or submission for the IETF.  Before we proceed, we'd like to engage the IETF community in discussion of the specifications and suitability for IETF.

Briefly, FFV1 is a lossless video codec and Matroska is an extensible open source media container.   Matroska is the base of WebM, and WebM is the preferred container for VP9, which has a draft RFC: https://tools.ietf.org/html/draft-grange-vp9-bitstream-00<https://tools.ietf.org/html/draft-grange-vp9-bitstream-00>

Work on FFV1 is coordinated through the GitHub and the ffmpeg-devel mailing list (http://ffmpeg.org/mailman/listinfo/ffmpeg-devel). Work on Matroska is coordinated through GitHub and the Matroska.org devel mailing list (http://lists.matroska.org/cgi-bin/mailman/listinfo/matroska-devel).

GitHub repositories are here:
https://github.com/MediaArea/FFV1
https://github.com/Matroska-Org/ebml-specification

We look forward to hearing your thoughts and suggestions.

Best wishes,

Tessa Fallon, on behalf of MediaArea

* PREFORMA is a project funded by the European Union as part of FP7. More information about PREFORMA can be found here: http://www.preforma-project.eu/

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Wed, 22 Jul 2015 00:52:37 -0700

DRAGE, Keith (Keith) wrote:
> So for example, if I search The National Archives site in the UK, I can
> find no mention of it, despite The National Archives claiming to be
> front runners in the preservation of digital material.

The commentary at 
http://download.das-werkstatt.com/pb/mthk/info/video/FAQ-digital_video_archiving.html 
suggests that the National Archives are at least looking at it.

http://www.vancouverarchives.ca/2011/10/a-day-in-the-lives-of-2-archivists-gone-digital/ 
and https://wiki.archivematica.org/Media_type_preservation_plans are 
additional relevant examples.

But I am by no means an expert in the archives community.

---

From: Dave Rice <[email-masked]>
Date: Wed, 22 Jul 2015 04:04:59 -0400

> On Jul 22, 2015, at 3:52 AM, Timothy B. Terriberry <[email-masked]> wrote:
> 
> The commentary at http://download.das-werkstatt.com/pb/mthk/info/video/FAQ-digital_video_archiving.html suggests that the National Archives are at least looking at it.

Actually, we conducted an interview Ian Henderson of the UK National Archives last December. The notes are here: https://github.com/MediaArea/MediaConch/blob/master/Interviews/InterviewHenderson.md. He discusses the reason for selecting FFV1 and Matroska for various preservation purposes. Within the interview he actually discusses issues related specifically to the standardization of these formats.

> http://www.vancouverarchives.ca/2011/10/a-day-in-the-lives-of-2-archivists-gone-digital/ and https://wiki.archivematica.org/Media_type_preservation_plans are additional relevant examples.

Peter Bubestinger has drafted a list of FFV1 users on wikipedia at https://en.wikipedia.org/wiki/FFV1#List_of_institutions_known_to_use_FFV1.

Additionally Indiana University is undertaking a large scale campus-wide digitization effort and recently selected FFV1 and Matroska.

The formats are in use in large scale digitization efforts in television archives in Europe. See http://www.tvbeurope.com/rtv-slovenia-installs-noa-systems-2/ and https://news.creativecow.net/story/876820. Also the call for proposals for the next FIAT/IFTA World Conference leads their call for proposals on “Archives and technology evolution” with the question “Is FFV1 the new JPEG2000?” See: http://fiatifta.org/wp-content/uploads/2015/06/call-for-presentation-world-conference.pdf

As FFV1 and Matroska are finding increased implementations, archives are increasingly invested in furthering the standardization of these formats.

> But I am by no means an expert in the archives community.

I am happy to play that role. :)
Best Regards,
Dave Rice