Subject: [dispatch] draft-winterbottom-dispatch-locparam

From: James Winterbottom <[email-masked]>
Date: Sun, 9 Aug 2015 18:41:47 +1000

Hi All,

I have gone through the note of the dispatch meeting for this draft as well as relying only my memory for what was discussed and I am at a bit of a loss as to how to update this draft in a way so that it can proceed.

I totally agree with Keith’s assessment about the relevancy of the privacy issue raised by Cullen.

Keith is right, in that the current primary intended use is not “inside” and IMS network, though I believe that the nodes employing this mechanism will have strong relationships with IMS nodes, most likely an E-CSCF or something resembling one.

Paul is also right. While IMS is not the chief customer, it is likely to be one of the downstream recipients and as such it does rely on strong trust relationships. So to this end a tie to RFC3325 is probably warranted.

Would it be reasonable then to:
Add a tie in to RFC3325 with regards to trust
Explicitly say that the loc-src needs to be a fully qualified host name and that IP address must not be used?

These seem to be be the two main points I took away. If this were done could we do a list-based dispatch for this draft?

Cheers
James

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 10 Aug 2015 09:22:39 -0400

On 8/9/15 4:41 AM, James Winterbottom wrote:
> Hi All,
>
> I have gone through the note of the dispatch meeting for this draft as
> well as relying only my memory for what was discussed and I am at a bit
> of a loss as to how to update this draft in a way so that it can proceed.
>
> Keith is right, in that the current primary intended use is not “inside”
> and IMS network, though I believe that the nodes employing this
> mechanism will have strong relationships with IMS nodes, most likely an
> E-CSCF or something resembling one.
>
> Paul is also right. While IMS is not the chief customer, it is likely to
> be one of the downstream recipients and as such it does rely on strong
> trust relationships. So to this end a tie to RFC3325 is probably warranted.
>
>  1. Add a tie in to RFC3325 with regards to trust

This would make me happy. Without an explanation of the expectations of 
the trust relationship the contents of this header field are meaningless.

	Thanks,
	Paul

>  2. Explicitly say that the loc-src needs to be a fully qualified host
>     name and that IP address must not be used?
>
>
> These seem to be be the two main points I took away. If this were done
> could we do a list-based dispatch for this draft?
>
> Cheers
> James
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: James Winterbottom <[email-masked]>
Date: Thu, 13 Aug 2015 18:36:48 +1000

Thanks Paul.

> On 10 Aug 2015, at 11:22 pm, Paul Kyzivat <[email-masked]> wrote:
> 
> This would make me happy. Without an explanation of the expectations of the trust relationship the contents of this header field are meaningless.
> 
> 	Thanks,
> 	Paul
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/dispatch <https://www.ietf.org/mailman/listinfo/dispatch>
>> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dispatch <https://www.ietf.org/mailman/listinfo/dispatch>