Subject: [dispatch] Fwd: [Technical Errata Reported] RFC7315 (4540)

From: "Ben Campbell" <[email-masked]>
Date: Fri, 20 Nov 2015 09:07:35 -0600

Hi,

Do others agree with this errata report?

Thanks!

Ben.

Forwarded message:

> From: RFC Errata System <[email-masked]>
> To: [email-masked], [email-masked], 
> [email-masked], [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: [Technical Errata Reported] RFC7315 (4540)
> Date: Thu, 19 Nov 2015 21:22:58 -0800 (PST)
>
> The following errata report has been submitted for RFC7315,
> "Private Header (P-Header) Extensions to the Session Initiation 
> Protocol (SIP) for the 3GPP".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=7315&eid=4540
>
> --------------------------------------
> Type: Technical
> Reported by: Dongo Yi <[email-masked]>
>
> Section: 5.1
>
> Original Text
> -------------
> 5.1. P-Associated-URI Header Syntax
>
>
> The syntax of the P-Associated-URI header field is described as
> follows:
>
>       P-Associated-URI       = \\"P-Associated-URI\\" HCOLON
>                                [p-aso-uri-spec]
>                                *(COMMA p-aso-uri-spec)
>       p-aso-uri-spec         = name-addr *(SEMI ai-param)
>       ai-param               = generic-param
>
>
> Corrected Text
> --------------
> 5.1. P-Associated-URI Header Syntax
>
>
> The syntax of the P-Associated-URI header field is described as
> follows:
>
>       P-Associated-URI       = \\"P-Associated-URI\\" HCOLON
>                                (p-aso-uri-spec)
>                                *(COMMA p-aso-uri-spec)
>       p-aso-uri-spec         = name-addr *(SEMI ai-param)
>       ai-param               = generic-param
>
>
> Notes
> -----
> P-Associated-URI cannot include an empty header value (which was able 
> to be included according to RFC 3455)
>
> - Background.
>
> The policy of P-Associated-URI has been updated from RFC 3455.
> RFC 3455 : 4.1.2.2 Procedures at the registrar
> ...
> In case the address-of-record under registration does not have any
> other SIP or SIPS URIs associated, the registrar MUST include an
> empty P-Associated-URI header value.
>
>
> RFC 7315 : 4.1.2.2 Procedures at the Registrar
> ...
> If the address-of-record under registration does not have any
> associated URIs, the P-Associated-URI header field SHALL NOT be
> included.
> ...
>
> Moreover, we can say RFC 3455 has same errata based on this analysis.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC7315 (draft-drage-sipping-rfc3455bis-14)
> --------------------------------------
> Title               : Private Header (P-Header) Extensions to the 
> Session Initiation Protocol (SIP) for the 3GPP
> Publication Date    : July 2014
> Author(s)           : R. Jesske, K. Drage, C. Holmberg
> Category            : INFORMATIONAL
> Source              : IETF - NON WORKING GROUP
> Area                : N/A
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 20 Nov 2015 10:35:04 -0500

> Do others agree with this errata report?

IIUC, 7315 has revised the usage so that the optionality of the URI is 
no longer needed. But the current definition still *works* with 7315. 
(The feature being proposed for removal won't be used.) So I don't see 
that there is an error to fix. The "fix" will mean that implementations 
using 3455 could fail to interoperate with implementations using 7315.

ISTM it would be better to leave the syntax unchanged, but add text 
indicating that use with an empty URI is deprecated, but should be 
accepted for backward compatibility.

	Thanks,
	Paul

> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 Nov 2015 19:37:28 +0000

Hi,

>> IIUC, 7315 has revised the usage so that the optionality of the URI is no longer needed. But the current definition still *works* with 7315. 
>> (The feature being proposed for removal won't be used.) So I don't see that there is an error to fix. The "fix" will mean that implementations 
> ISTM it would be better to leave the syntax unchanged, but add text indicating that use with an empty URI is deprecated, but should be accepted for backward compatibility.

An empty URI means that there are no associated URIs. Perhaps an entity wants to explicitly indicate that - showing that the PAU mechanism is supported, but that there are no associated URIs. I am not sure why we should deprecate that.

However, note that the following syntax allows the following:

	P-Associated-URI:,<uri>    <----- Note the comma before the URI.

Regards,

Christer

>> The following errata report has been submitted for RFC7315, "Private 
>> Header (P-Header) Extensions to the Session Initiation Protocol (SIP) 
>> for the 3GPP".
>>
>> RFC 3455 : 4.1.2.2 Procedures at the registrar ...
>> RFC 7315 : 4.1.2.2 Procedures at the Registrar ...
>> use "Reply All" to discuss whether it should be verified or rejected. 
>> When a decision is reached, the verifying party (IESG) can log in to 
>> change the status and edit the report, if necessary.
>>