Subject: [dispatch] draft-jennings-dispatch-new-media

From: Cullen Jennings <[email-masked]>
Date: Mon, 5 Mar 2018 12:42:54 -0700

I wrote a draft that outlines how to replace STUN, TURN, ICE, RTP, SRTP, DTLS-SRTP, and of course SDP with something simpler. It is at:

https://datatracker.ietf.org/doc/draft-jennings-dispatch-new-media/

Would it be possible to get 20 minutes on the Dispatch agenda to discuss it?

Thanks, Cullen

---

From: Mary Barnes <[email-masked]>
Date: Mon, 5 Mar 2018 15:31:02 -0600

We'll include you at the end of the agenda if there is time ;)    At this
point, as you know, we should have time.

Folks, it would be good for people to review this and provide feedback
prior to the meeting.

Regards,
Mary.

On Mon, Mar 5, 2018 at 1:42 PM, Cullen Jennings <[email-masked]> wrote:

>
> I wrote a draft that outlines how to replace STUN, TURN, ICE, RTP, SRTP,
> DTLS-SRTP, and of course SDP with something simpler. It is at:
>

---

From: "Aijun Wang" <[email-masked]>
Date: Thu, 8 Mar 2018 11:22:09 +0800

Hi, Cullen and Mary:

We are also having interestings to develop the new protocol that replaces current TURN/ICE, which aim is similar with the "snowflake" that Cullen proposed.

If possible, we would like to introduce our thoughts(as described “OARS”) on this topic.  Hope can have such opportunities.

We have submit our proposal and make presentation at IETF98 in Chicago, the related draft is at here https://datatracker.ietf.org/doc/draft-wang-rtcweb-oars/

We can also consider the further actions based on these drafts.

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

发件人: Mary Barnes [mailto:[email-masked]] 
发送时间: 2018年3月6日 5:31
收件人: Cullen Jennings
抄送: DISPATCH list; dispatch chairs
主题: Re: [dispatch] draft-jennings-dispatch-new-media

We'll include you at the end of the agenda if there is time ;)    At this point, as you know, we should have time. 

Folks, it would be good for people to review this and provide feedback prior to the meeting. 

Regards,

Mary. 

Thanks, Cullen

---

From: Mary Barnes <[email-masked]>
Date: Fri, 9 Mar 2018 15:15:01 -0600

Hi Aijun,

So, my understanding is that at IETF98, it was recommended that you bring
the work to the DISPATCH WG for discussion, following the process we have
in place:
https://trac.ietf.org/trac/dispatch/wiki

We sometimes can handle late items, but we have a very full agenda as it
stands.   At this point, your draft is also expired. If you want to
progress the work, you need to engage in discussion on the mailing list as
to whether there's a problem to be solved with your proposed solution.

Regards,
Mary.
- DISPATCH WG tri-chair

On Wed, Mar 7, 2018 at 9:22 PM, Aijun Wang <[email-masked]>
wrote:

> Hi, Cullen and Mary:
>
>
>
> We are also having interestings to develop the new protocol that replaces
> current TURN/ICE, which aim is similar with the "snowflake" that Cullen
> proposed.
>
> If possible, we would like to introduce our thoughts(as described “OARS”)
> on this topic.  Hope can have such opportunities.
>
>
>
> We have submit our proposal and make presentation at IETF98 in Chicago,
> the related draft is at here https://datatracker.ietf.org/
> doc/draft-wang-rtcweb-oars/
>
> *发件人:* Mary Barnes [mailto:[email-masked]]
> *发送时间:* 2018年3月6日 5:31
> *收件人:* Cullen Jennings
> *抄送:* DISPATCH list; dispatch chairs
> *主题:* Re: [dispatch] draft-jennings-dispatch-new-media
>
>
>

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 12 Mar 2018 11:38:04 +0800

Hi, Mary:

I will try to submit the revised version of this draft to DISPATCH WG once the submission is open again. 

But for the new proposal, I think it is better to have chance to introduce it via face-to-face meeting, then we can discuss it on the mail-list.

The reason that I delayed the submission to DISPATCH WG is that our draft focusing on mainly the solution that can coexist or simplify the TURN/ICE protocol, which should be companioned with other demands to put forward it.

As Cullen proposed, I think if there are enough interesting to simplify these protocols(“…STUN, TURN, ICE, RTP, SRTP, DTLS-SRTP, and of course SDP…”), then we can contribute our thoughts to this work.

Best Regards.

Aijun Wang

发件人: Mary Barnes [mailto:[email-masked]] 
发送时间: 2018年3月10日 5:15
收件人: Aijun Wang
抄送: Cullen Jennings; DISPATCH list; dispatch chairs
主题: Re: 答复: [dispatch] draft-jennings-dispatch-new-media

Hi Aijun,

So, my understanding is that at IETF98, it was recommended that you bring the work to the DISPATCH WG for discussion, following the process we have in place:

We sometimes can handle late items, but we have a very full agenda as it stands.   At this point, your draft is also expired. If you want to progress the work, you need to engage in discussion on the mailing list as to whether there's a problem to be solved with your proposed solution.   

Regards,

Mary. 

- DISPATCH WG tri-chair

On Wed, Mar 7, 2018 at 9:22 PM, Aijun Wang <[email-masked]> wrote:

Hi, Cullen and Mary:

 

Best Regards.

Aijun Wang

Regards,

Mary. 

Thanks, Cullen

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 26 Mar 2018 11:18:45 +0800

Hi, Mary and Experts in Dispatch:

I have posted the draft about OARS that aims to update/simplify the current TURN/ICE mechanism at https://datatracker.ietf.org/doc/draft-wang-dispatch-oars/. 

Any expert interested this topic can contact me or discuss it at the new mail list https://www.ietf.org/mailman/listinfo/rt-media-ng that established by Cullen.

Best Regards.

Aijun Wang

发件人: Aijun Wang [mailto:[email-masked]] 
发送时间: 2018年3月12日 11:38
收件人: 'Mary Barnes'
抄送: 'DISPATCH list'; 'Cullen Jennings'; 'dispatch chairs'
主题: [dispatch] 答复: 答复: draft-jennings-dispatch-new-media

Hi, Mary:

 

Best Regards.

Aijun Wang

Hi Aijun,

Regards,

Mary. 

- DISPATCH WG tri-chair

Hi, Cullen and Mary:

 

Best Regards.

Aijun Wang

Regards,

Mary. 

Thanks, Cullen