Subject: [dispatch] draft-asveren-dispatch-http-overload-control

From: "Asveren, Tolga" <[email-masked]>
Date: Sat, 14 Apr 2018 18:57:08 +0000

I just submitted draft-asveren-dispatch-http-overload-control, which specifies a generic overload control mechanism for HTTP/HTTPS applications.

https://www.ietf.org/id/draft-asveren-dispatch-http-overload-control-00.txt

I would appreciate any feedback (as a first step mainly about whether this is something people would be interested in).

Thanks,
Tolga

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 15 Apr 2018 07:22:38 -0600

If the client finds out it should use a 50% drop rate. How does that interact with retries and retransmissions on the client? I’m just looking for a bit more detail on what the client does once it knows a given set of requests should have a 50% drop rate. 

> On Apr 14, 2018, at 12:57 PM, Asveren, Tolga <[email-masked]> wrote:
> 
> https://www.ietf.org/id/draft-asveren-dispatch-http-overload-control-00.txt <https://www.ietf.org/id/draft-asveren-dispatch-http-overload-control-00.txt>
>  
>  
> _______________________________________________
> dispatch mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dispatch <https://www.ietf.org/mailman/listinfo/dispatch>

---

From: "Asveren, Tolga" <[email-masked]>
Date: Sun, 15 Apr 2018 17:05:53 +0000

How to handle that would be somewhat implementation dependent but it probably would be a good idea to mention about it in the draft and also list a few choices. A basic option would be not to use a server for retries/retransmissions (unless it is required because the application protocol is stateful across multiple requests). There are more intelligent schemes as well, e.g. determine the maximum rate based on traffic rate/drop rate at the time of receipt/processing of the drop rate value and use it for all requests toward that server until a new drop rate is received.

This issue is generic for any “drop rate based” overload control (so it applies for SIP as well in the context of RFC7339).

Thanks,
Tolga

From: Cullen Jennings <[email-masked]>
Sent: Sunday, April 15, 2018 9:23 AM
To: Asveren, Tolga <[email-masked]>
Cc: [email-masked]
Subject: Re: [dispatch] draft-asveren-dispatch-http-overload-control

________________________________
NOTICE: This email was received from an EXTERNAL sender
________________________________

On Apr 14, 2018, at 12:57 PM, Asveren, Tolga <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Tolga
_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch