Subject: [dispatch] On JSCalendar

From: Anton Tveretin <[email-masked]>
Date: Sat, 22 Jun 2019 03:09:07 +0500

Hello Robert,
This is (almost) I was looking for for the NGMTP. Few my thoughts:
1. I do not expect any difference between a telephone number and any other immediate contact (SIP, Skype etc.) We have tel: URI. But RoAs could be present, as separate from AoRs (a new element?)
2. The same for mail. But I do not know any scheme that could contain all of mail (paper, Internet, X.400...)
3. Should names follow their order in the legal name, or their meaning? A Russian legal name consists of the family name, the given name, and the patronymic, in that order; a Spanish legal name consists of the given name, the family name 1, and the family name 2. One implementation I've seen splits a name into part 1, part 2, and part 3. Could you provide several examples?
Regards,
Anton.

---

From: "Robert Stepanek" <[email-masked]>
Date: Sat, 29 Jun 2019 16:56:34 +0200

Hi Anton,

> 2. The same for mail. But I do not know any scheme that could contain all of mail (paper, Internet, X.400...)

I am not familiar with the terms RoAs and AoRs? I understand your points 1 and 2 to discuss if we should unify all contact methods into one property , and let implementations determine the type of the listed methods by the URI scheme?

The reason we currently define separate properties for phone, email and others is that it is close to the way how VCARD is organized. It should help to make it simple for developers to switch to our proposed format. It's also close to the layout of the standard adressbooks on mobile devices and a couple other clients.

In any case, we need a type property to distinguish the type of contact method, as existing VCARD data also comes in free-form telephone numbers, email addresses, etc.

I've updated the next draft version to mention the `tel` and `sip` schemes as typical URI schemes for the phones property, but any URI scheme is allowed. The current RFC draft already includes an example to put Skype links in the `online` property, but I agree that's disputable.

> 3. Should names follow their order in the legal name, or their meaning? A Russian legal name consists of the family name, the given name, and the patronymic, in that order; a Spanish legal name con…

 I hope to get more insight into the works of the ISO group ISO/TC 37/SC4 . They aim at representing international names by use of registered profiles. For your example, it would allow to store the names in the card in a pre-defined order, and then use profiles to combine the names in the right order for a particular use case or culture.

Regards,
Robert