Subject: [dispatch] JCS - Abandoning the DISPATCH path

From: Anders Rundgren <[email-masked]>
Date: Wed, 5 Jun 2019 20:24:50 +0200

Due to the lack interest ("active disinterest") we have been advised to not pursue JCS through DISPATCH.

Personally I will continue with JCS in contexts like Open Banking since it obvious (based on existing practice) that Base64Url-encoding of business messages will continue to be a hard sell.  The ability simply taking a hash of a JSON object is also a pretty useful feature not supported by any IETF standard.

For the authors,
Anders Rundgren

Current draft: https://tools.ietf.org/html/draft-rundgren-json-canonicalization-scheme-06
On-line lab combining JWS and JCS: https://mobilepki.org/jws-jcs/home
IETF-104 report: https://cyberphone.github.io/ietf-json-canon/ietf-104-report.html

---

From: Bret Jordan <[email-masked]>
Date: Wed, 5 Jun 2019 13:00:06 -0600

This is really sad and a loss for the IETF.  I would like to know how much interest needs to be given for an idea for it to be accepted and worked on.  Is it 5, 10, 20, 50, 100, ?? People?  And how is consensus achieved, meaning what percentage of people need to be against the work to prevent it?   

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

> On Jun 5, 2019, at 12:24 PM, Anders Rundgren <[email-masked]> wrote:
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Mary Barnes <[email-masked]>
Date: Fri, 7 Jun 2019 13:08:46 -0500

Hi Bret,

In IETF, we don't do counts per se. We have the notion of rough consensus.
The method that WG chairs use has some very basic guidelines, but there is
a lot that's left to the discretion of the chairs.   Here's a document that
describes some of this:  https://tools.ietf.org/html/rfc7282  I think a key
point from that document is around the notion that consensus can be gained
if there objections, if all those can be addressed in some way.  With this
topic, that does not seem possible given the nature of the meeting and
mailing list discussions.

As a chair, what I took away from the discussions were very strong
disagreements about the value of this work.  There were indeed a few
supporters. But, there did not appear to be broad interest such that this
is something the IETF should take on.   And, If we were to decide to
progress this work in IETF, it is very, very likely that those that
disagree with it right now, would continue to raise the same concerns (per
the point about objections being addressed if you want consensus) and
ultimately it's the IESG that judges whether a WG has consensus.  Our AD,
Barry Leiba has already stated his position on this.  And, you do have an
alternative publication path via the ISE.

Regards,
Mary
DISPATCH WG co-chair

On Wed, Jun 5, 2019 at 2:01 PM Bret Jordan <[email-masked]> wrote:

> This is really sad and a loss for the IETF.  I would like to know how much
> interest needs to be given for an idea for it to be accepted and worked
> on.  Is it 5, 10, 20, 50, 100, ?? People?  And how is consensus achieved,
> meaning what percentage of people need to be against the work to prevent
> it?
>
>
> Thanks,
> Bret
> Personally I will continue with JCS in contexts like Open Banking since it
> obvious (based on existing practice) that Base64Url-encoding of business
> messages will continue to be a hard sell.  The ability simply taking a hash
> of a JSON object is also a pretty useful feature not supported by any IETF
> standard.
>
> For the authors,
> Anders Rundgren
>
> Current draft:
> https://tools.ietf.org/html/draft-rundgren-json-canonicalization-scheme-06
> IETF-104 report:
> https://cyberphone.github.io/ietf-json-canon/ietf-104-report.html
>

---

From: Anders Rundgren <[email-masked]>
Date: Sat, 8 Jun 2019 09:28:40 +0200

Hi Mary,
We are apparently forced taking another path although there are no documented technical issues (except for the constraints declared in the draft) and the intended use cases are anything but marginal.

Possibly my assertion that one of the most high-profile IT-projects ever (Open Banking), without exception rejected the "right" solution made a bunch of well-known IETF profiles step out of their engineering role and rather turn to politics.  In politics there is hardly ever consensus.

BTW, VmWare have patented the core idea:
https://patentimages.storage.googleapis.com/68/be/70/582930ff11703d/US20150341176A1.pdf
However, in this particular case the critics' references to XML are indeed applicable; namely as "prior art" indicators. Other comparisons with XML is mostly unverifiable "noise" since JCS [deliberately] is much more limited.

There must also be major misunderstandings how JCS actually works.  Microsoft's Mike Jones co-authored a precursor to JCS
https://tools.ietf.org/html/draft-erdtman-jose-cleartext-jws-01
but rejected JCS although the change only involved a trivial sorting mechanism.  The sorting suddenly made it possible creating compatible implementations for just about any platform with ease while the original design would have forced "a total rewrite of everything".  This revision as well as well as other fundamental parts of JCS were initially proposed by other IETFers.

Regards,
Anders

On 2019-06-07 20:08, Mary Barnes wrote:
> Hi Bret,
> 
> In IETF, we don't do counts per se. We have the notion of rough consensus.  The method that WG chairs use has some very basic guidelines, but there is a lot that's left to the discretion of the chairs.   Here's a document that describes some of this: https://tools.ietf.org/html/rfc7282  I think a key point from that document is around the notion that consensus can be gained if there objections, if all those can be addressed in some way.  With this topic, that does not seem possible given the nature of the meeting and mailing list discussions.
> 
> As a chair, what I took away from the discussions were very strong disagreements about the value of this work.  There were indeed a few supporters. But, there did not appear to be broad interest such that this is something the IETF should take on.   And, If we were to decide to progress this work in IETF, it is very, very likely that those that disagree with it right now, would continue to raise the same concerns (per the point about objections being addressed if you want consensus) and ultimately it's the IESG that judges whether a WG has consensus.  Our AD, Barry Leiba has already stated his position on this.  And, you do have an alternative publication path via the ISE.
> 
> Regards,
> Mary
> DISPATCH WG co-chair
> 
> 
> On Wed, Jun 5, 2019 at 2:01 PM Bret Jordan <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>     On Jun 5, 2019, at 12:24 PM, Anders Rundgren <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>