Subject: [dispatch] Proposal for a mew SIP 4xx Error code

From: Ranjit Avasarala <[email-masked]>
Date: Mon, 28 Oct 2019 23:05:59 -0500

Hello all

Many times I experienced scenarios where SIP requests (e.g. INVITE, PUBLISH
or PRACK or any other) have either invalid parameters in the header or a
particular header is missing in the request or the header value is
incomplete.  Some e.gs are

   - SIP Route header in INVITE contains additional "lr" parameter.
   Ideally, "lr" parameter needs to be associated with a particular route -
   i.e. sip URI
   - the Accept header is missing in SIP PUBLISH
   - the Allow header misses UPDATE method
   - .....  many more

Currently, in all the above cases the SIP Proxy server that receives the
request, responds with a 400 Bad Request.
Though 400 Bad Request is acceptable given that there is some issue in the
SIP request, a more detailed error would be more useful - as sometimes
interpreting 400 Bad Request is harder
E.g.
a  4xx Invalid header/parameter may be more appropriate with reason
E.g. if there is additional "lr" parameter in SIP INVITE, then the proxy
can return a 4xx Invalid Header/parameter with Reason:  SIP code=4xx;
Text="Invalid lr parameter in Route header"

Let me know your thoughts on if this proposal can be taken forward as an
Internet draft.

Thank you
Ranjit

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 29 Oct 2019 06:35:21 +0000

Hi,

I assume this discussion can be moved to SIPCORE, because I don't think DISPATCH needs to discuss the need for a new SIP response code, and where the work defining such would be done.

Regards,

Christer

________________________________
From: dispatch <[email-masked]> on behalf of Ranjit Avasarala <[email-masked]>
Sent: Tuesday, October 29, 2019 6:05 AM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: [dispatch] Proposal for a mew SIP 4xx Error code

Hello all

Many times I experienced scenarios where SIP requests (e.g. INVITE, PUBLISH or PRACK or any other) have either invalid parameters in the header or a particular header is missing in the request or the header value is incomplete.  Some e.gs<https://protect2.fireeye.com/v1/url?k=7d7bb417-21f196fe-7d7bf48c-0cc47ad93e2e-34af2a5be94ea08e&q=1&e=c2646b0c-e4da-4248-94ca-d03438b18bb9&u=http%3A%2F%2Fe.gs%2F> are

  *   SIP Route header in INVITE contains additional "lr" parameter. Ideally, "lr" parameter needs to be associated with a particular route - i.e. sip URI
  *   the Accept header is missing in SIP PUBLISH
  *   the Allow header misses UPDATE method
  *   .....  many more

Currently, in all the above cases the SIP Proxy server that receives the request, responds with a 400 Bad Request.
Though 400 Bad Request is acceptable given that there is some issue in the SIP request, a more detailed error would be more useful - as sometimes interpreting 400 Bad Request is harder
E.g.
a  4xx Invalid header/parameter may be more appropriate with reason
E.g. if there is additional "lr" parameter in SIP INVITE, then the proxy can return a 4xx Invalid Header/parameter with Reason:  SIP code=4xx; Text="Invalid lr parameter in Route header"

Let me know your thoughts on if this proposal can be taken forward as an Internet draft.

Thank you
Ranjit