Subject: [dispatch] Fwd: sip ue-addr contact hdr parameter

From: Ranjit Avasarala <[email-masked]>
Date: Wed, 2 Oct 2019 12:48:19 -0500

Hello all

I am looking for an I-D or RFC that describes the syntax and behaviour of
proxies receiving ue-addr parameter in SIP INVITE and when they do and do
not forward it further

Thank you
Ranjit

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 2 Oct 2019 18:37:58 +0000

Hi,

This question probably belongs to SIPCORE.

…and, what is ue-addr parameter?

Regards,

Christer

Lähettäjä: dispatch <[email-masked]> Puolesta Ranjit Avasarala
Lähetetty: keskiviikko 2. lokakuuta 2019 20.48
Vastaanottaja: [email-masked]
Aihe: [dispatch] Fwd: sip ue-addr contact hdr parameter

Hello all

I am looking for an I-D or RFC that describes the syntax and behaviour of proxies receiving ue-addr parameter in SIP INVITE and when they do and do not forward it further

Thank you
Ranjit

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 2 Oct 2019 14:56:15 -0400

> This question probably belongs to SIPCORE.

A more appropriate place would be [email-masked].

> …and, what is ue-addr parameter?

AFAIK it isn't a term that appears in ietf sip documents.
Given the use of "ue" I guess perhaps this may be a question about 3gpp.

	Thanks,
	Paul

> Regards,
> 
> Christer
> 
> *Lähettäjä:*dispatch <[email-masked]> *Puolesta *Ranjit Avasarala
> *Lähetetty:* keskiviikko 2. lokakuuta 2019 20.48
> *Vastaanottaja:* [email-masked]
> *Aihe:* [dispatch] Fwd: sip ue-addr contact hdr parameter
> 
> Hello all
> 
> I am looking for an I-D or RFC that describes the syntax and behaviour 
> of proxies receiving ue-addr parameter in SIP INVITE and when they do 
> and do not forward it further
> 
> Thank you
> 
> Ranjit
> 
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: [email-masked] (Dale R. Worley)
Date: Thu, 10 Oct 2019 21:11:41 -0400

> proxies receiving ue-addr parameter in SIP INVITE and when they do and do

In regard to parameters in the URI in the *request* line, the RFCs give
a device complete flexibility in regard to how they modify that URI
before forwarding the request.

In regard to the *Contact* headers, proxies aren't supposed to modify
those at all.  However "B2BUAs" can have arbitrary behavior.

Dale