Subject: Re: [dispatch] Virtual IETF107 - SRT draft is available

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 18 Mar 2020 16:23:47 +0000

Hi Ben,

I think it still best fits in MOPS, at least initially.  SRT is a popular protocol in use operationally amongst media companies and doing an ingest initially in via MOPS will help get it the visibility and discussion from the media operations viewpoint.    

 While MOPS won't meet until the virtual meetup being planned for April, all that really means is that there won't be an opportunity to present on the draft to a WG until then - but the interims are only a couple weeks out from now, so it's not a massive delay.   

Between now and the interim MOPS meeting the draft can still be discussed and reviewed on the MOPS list.

My worry is that skipping having it run through MOPS to gain the input there would be skipping an important set of eyes that can helpfully contribute to commenting on the draft.

-glenn

On 3/18/20, 9:09 AM, "dispatch on behalf of Ben Campbell" <[email-masked] on behalf of [email-masked]> wrote:

    Hi All,
    
    The chairs would like to see comments about what an appropriate discussion venue for this draft would be. It seems like it sits on the border between TSV and ART.
    
    Thanks!
    
    Ben.
    
    > On Mar 18, 2020, at 1:37 AM, 김준웅님(JOONWOONG.KIM) <[email-masked]> wrote:
    > 
    > Hi all
    > 
    > I would like to draw you attention to SRT draft which is added in the last minute to the agenda of DISPATCH session, coming week (if time is allowed after existing agenda items are handled):
    > 
    > https://datatracker.ietf.org/doc/draft-sharabayko-mops-srt/
    > 
    > SRT (Secure Reliable Transport) protocol is a user level protocol optimized for low-latency live video contribution based on UDT and UDP, over different network conditions. While it has been rather successfully deployed by some industries, we would like to make it an Internet standard and further collaborate in IETF communities for enhancements, which would be beneficial to Internet community and Industries.
    > 
    > The draft was originally submitted for MOPS WG of IETF 107 for discussions, but now there will not be any MOPS meeting until late April. Therefore we would like to discuss this draft in DISPATCH, which might be more appropriate venue to find out where and how a new protocol draft can be handled. I appreciate DISPATCH leaderships and members, for kind consideration.
    > 
    > If you need more clarification about SRT protocol or our intention, please let me know. Any comments or discussions before the meeting would be helpful as well. In the meantime, you can find more information about SRT here (white papers, simple video clips, and open source code):
    > https://www.srtalliance.org/
    > http://www3.haivision.com/srt-open-source-wp
    > https://github.com/Haivision/srt
    > 
    > Thanks so much for reading and your help in advance.
    > 
    > thanks
    > Joonwoong
    > ==
    > Joonwoong Kim | Global Standardization | SK Telecom mailto:[email-masked]
    > 
    > 
    > _______________________________________________
    > dispatch mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 19 Mar 2020 07:25:48 +1100

As this is an entirely new transport protocol, I don't see this as being within the MOPS charter.  This would be something at the scale of a working group, likely in the transport area, if the IETF took it on.  But several questions come from this:

* is the intent here to transfer change control to the IETF?

* why would anyone choose to do this as opposed to something like QUIC?  QUIC provides certain security properties, whereas I have very little confidence in the claimed security properties of this protocol.

On Thu, Mar 19, 2020, at 03:23, Deen, Glenn (NBCUniversal) wrote:
> Hi Ben,
> 
> I think it still best fits in MOPS, at least initially.  SRT is a 
> popular protocol in use operationally amongst media companies and doing 
> an ingest initially in via MOPS will help get it the visibility and 
> discussion from the media operations viewpoint.    
> 
>  While MOPS won't meet until the virtual meetup being planned for 
> April, all that really means is that there won't be an opportunity to 
> present on the draft to a WG until then - but the interims are only a 
> couple weeks out from now, so it's not a massive delay.   
> 
> My worry is that skipping having it run through MOPS to gain the input 
> there would be skipping an important set of eyes that can helpfully 
> contribute to commenting on the draft.
> 
> -glenn
> 
> 
> On 3/18/20, 9:09 AM, "dispatch on behalf of Ben Campbell" 
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>     Hi All,
>     
>     The chairs would like to see comments about what an appropriate 
> discussion venue for this draft would be. It seems like it sits on the 
> border between TSV and ART.
>     
>     Thanks!
>     
>     Ben.
>     
>     > I would like to draw you attention to SRT draft which is added in 
> the last minute to the agenda of DISPATCH session, coming week (if time 
> is allowed after existing agenda items are handled):
>     > 
>     > SRT (Secure Reliable Transport) protocol is a user level protocol 
> optimized for low-latency live video contribution based on UDT and UDP, 
> over different network conditions. While it has been rather 
> successfully deployed by some industries, we would like to make it an 
> Internet standard and further collaborate in IETF communities for 
> enhancements, which would be beneficial to Internet community and 
> Industries.
>     > 
>     > The draft was originally submitted for MOPS WG of IETF 107 for 
> discussions, but now there will not be any MOPS meeting until late 
> April. Therefore we would like to discuss this draft in DISPATCH, which 
> might be more appropriate venue to find out where and how a new 
> protocol draft can be handled. I appreciate DISPATCH leaderships and 
> members, for kind consideration.
>     > 
>     > If you need more clarification about SRT protocol or our 
> intention, please let me know. Any comments or discussions before the 
> meeting would be helpful as well. In the meantime, you can find more 
> information about SRT here (white papers, simple video clips, and open 
> source code):

---

From: 김준웅님(JOONWOONG.KIM) <[email-masked]>
Date: Thu, 19 Mar 2020 06:30:16 +0000

Thanks so much for sharing your views. The intention (at least for me) is to find the right venue and right track for IETF work. As Glenn suggested, I believe MOPS is the appropriate place for discussion of media related protocols and real world operations (to contribute by requirements and use cases). However, MOPS does not work on a protocol itself in my understanding (considering the charter of WG; correct me if I'm wrong). We are certainly open to all the possibilities, but we would like to understand if the current SRT protocol could be standardized or documented within IETF. If it would be WG standard, personally I think change control could be transferred to IETF (of course, it needs to be aligned with developments of open source). For all those different opportunities, I thought the discussion in the dispatch style working group might be helpful in addition to potential discussion at MOPS, but we do not have hands-on experience of IETF process..

cheers
joonwoong

-----Original Message-----
From: dispatch <[email-masked]> On Behalf Of Martin Thomson
Sent: Thursday, March 19, 2020 5:26 AM
To: [email-masked]
Subject: Re: [dispatch] Virtual IETF107 - SRT draft is available

On Thu, Mar 19, 2020, at 03:23, Deen, Glenn (NBCUniversal) wrote:
> popular protocol in use operationally amongst media companies and 
> doing an ingest initially in via MOPS will help get it the visibility and
>     > I would like to draw you attention to SRT draft which is added 
> in the last minute to the agenda of DISPATCH session, coming week (if 
> time is allowed after existing agenda items are handled):
>     > 
>     > SRT (Secure Reliable Transport) protocol is a user level 
> protocol optimized for low-latency live video contribution based on 
> UDT and UDP, over different network conditions. While it has been 
> rather successfully deployed by some industries, we would like to make 
> it an Internet standard and further collaborate in IETF communities 
> for enhancements, which would be beneficial to Internet community and 
> Industries.
>     > 
> April. Therefore we would like to discuss this draft in DISPATCH, 
> which might be more appropriate venue to find out where and how a new

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 19 Mar 2020 17:39:03 +1100

On 19 Mar 2020, at 5:30 pm, 김준웅님(JOONWOONG.KIM) <[email-masked]> wrote:
> 
> we would like to understand if the current SRT protocol could be standardized or documented within IETF

That's not how things typically work. When new works comes to the IETF, change control for the specification is explicitly given to this community. We then come to consensus about what gets standardised, and as a result, the output may look very little like the input.

Indeed, this is exactly what happened to QUIC, and to SPDY before it.

If you'd like the *current* SRT protocol to be documented, I'd suggest publishing it on your Github repository, or perhaps a journal. The RFC Editor also has an "independent" stream for documents, but there's a filter in place for work that conflicts with the IETF's, so that may not be workable here (you'd have to try).

If, on the other hand, you'd like to bring a proposal or a use case to a community with deep knowledge of networking and security, and have the benefit of broad review and input as well as potential buy-in from a much broader group of implementers, the IETF is a good place to do that. You just can't expect what comes out to look like what you bring to the table; it does occasionally happen, but you can't count on it.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: 김준웅님(JOONWOONG.KIM) <[email-masked]>
Date: Thu, 19 Mar 2020 06:58:19 +0000

Thanks a lot for the comment, Mark. I think this kind of advice is very much helpful for us. I can understand or imagine that it is a collaborative work in principle, and thus the outcome could be quite different from the original proposal. I agree with you on the main purpose and merit of the process. The documenting the current SRT is just one of possibilities (which may lead to a trial of independent informational RFC).

thanks
joonwoong

-----Original Message-----
From: Mark Nottingham <[email-masked]> 
Sent: Thursday, March 19, 2020 3:39 PM
To: 김준웅님(JOONWOONG.KIM)/기술표준화팀 <[email-masked]>
Cc: Martin Thomson <[email-masked]>; [email-masked]
Subject: Re: [dispatch] Virtual IETF107 - SRT draft is available

Cheers,