Subject: [dispatch] Virtual IETF107 - SRT draft is available

From: 김준웅님(JOONWOONG.KIM) <[email-masked]>
Date: Wed, 18 Mar 2020 06:37:05 +0000

Hi all

I would like to draw you attention to SRT draft which is added in the last minute to the agenda of DISPATCH session, coming week (if time is allowed after existing agenda items are handled):

https://datatracker.ietf.org/doc/draft-sharabayko-mops-srt/

SRT (Secure Reliable Transport) protocol is a user level protocol optimized for low-latency live video contribution based on UDT and UDP, over different network conditions. While it has been rather successfully deployed by some industries, we would like to make it an Internet standard and further collaborate in IETF communities for enhancements, which would be beneficial to Internet community and Industries.

The draft was originally submitted for MOPS WG of IETF 107 for discussions, but now there will not be any MOPS meeting until late April. Therefore we would like to discuss this draft in DISPATCH, which might be more appropriate venue to find out where and how a new protocol draft can be handled. I appreciate DISPATCH leaderships and members, for kind consideration.

If you need more clarification about SRT protocol or our intention, please let me know. Any comments or discussions before the meeting would be helpful as well. In the meantime, you can find more information about SRT here (white papers, simple video clips, and open source code): 
https://www.srtalliance.org/
http://www3.haivision.com/srt-open-source-wp
https://github.com/Haivision/srt

Thanks so much for reading and your help in advance.

thanks
Joonwoong
==
Joonwoong Kim | Global Standardization | SK Telecom mailto:[email-masked]

---

From: Ben Campbell <[email-masked]>
Date: Wed, 18 Mar 2020 11:07:56 -0500

Hi All,

The chairs would like to see comments about what an appropriate discussion venue for this draft would be. It seems like it sits on the border between TSV and ART.

Thanks!

Ben.

> On Mar 18, 2020, at 1:37 AM, 김준웅님(JOONWOONG.KIM) <[email-masked]> wrote:
> 
> Hi all
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 18 Mar 2020 09:25:39 -0700

I would say ART. This is for media, not a generic transport protocol like
QUIC.

On Wed, Mar 18, 2020 at 9:08 AM Ben Campbell <[email-masked]> wrote:

> Hi All,
>
> The chairs would like to see comments about what an appropriate discussion
> venue for this draft would be. It seems like it sits on the border between
> TSV and ART.
>
> Thanks!
>
> Ben.
>
> > I would like to draw you attention to SRT draft which is added in the
> last minute to the agenda of DISPATCH session, coming week (if time is
> allowed after existing agenda items are handled):
> >
> > SRT (Secure Reliable Transport) protocol is a user level protocol
> optimized for low-latency live video contribution based on UDT and UDP,
> over different network conditions. While it has been rather successfully
> deployed by some industries, we would like to make it an Internet standard
> and further collaborate in IETF communities for enhancements, which would
> be beneficial to Internet community and Industries.
> >
> > The draft was originally submitted for MOPS WG of IETF 107 for
> discussions, but now there will not be any MOPS meeting until late April.
> Therefore we would like to discuss this draft in DISPATCH, which might be
> more appropriate venue to find out where and how a new protocol draft can
> be handled. I appreciate DISPATCH leaderships and members, for kind
> consideration.
> >
> > If you need more clarification about SRT protocol or our intention,
> please let me know. Any comments or discussions before the meeting would be
> helpful as well. In the meantime, you can find more information about SRT
> here (white papers, simple video clips, and open source code):

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 18 Mar 2020 09:30:07 -0700

Despite the title "secure" the description of encryption is rather thin.
For instance, it appears that data packets can be "encrypted" but this does
not describe how AFAICT. Is there a complete description somewhere? What
are the desired security properties of this protocol?

-Ekr

On Tue, Mar 17, 2020 at 11:37 PM 김준웅님(JOONWOONG.KIM) <[email-masked]>
wrote:

> Hi all
>
> I would like to draw you attention to SRT draft which is added in the last
> minute to the agenda of DISPATCH session, coming week (if time is allowed
> after existing agenda items are handled):
>
> If you need more clarification about SRT protocol or our intention, please
> let me know. Any comments or discussions before the meeting would be

---

From: 김준웅님(JOONWOONG.KIM) <[email-masked]>
Date: Thu, 19 Mar 2020 05:23:34 +0000

Hi Eric

Thanks for the question. At this time, we couldn't complete security (encryption) section due to limited time. I think that other sections need improvements as well. Full details on encryption (and key establishment) are available in SRT Technical Overview paper, which is available at:
https://github.com/Haivision/srt/files/2489142/SRT_Protocol_TechnicalOverview_DRAFT_2018-10-17.pdf

SRT supports confidentiality protection of payload with a stream cipher mainly based on AES counter mode as well as key establishment mechanisms. Other modes like GCM could be used instead (for integrity check, for example), but the related procedures were not specified yet and left for the future enhancement. SRT did not provide authentication of peers, although it would be interesting to see if TLS would applicable to SRT. We can think of "secure" for SRT as rather basic but efficient protection of payload for live video delivery, and other security aspects have to be dealt with applications. More complete analysis of security might be needed for future enhancements, hopefully through collaboration with experts in IETF community.

cheers
joonwoong

From: Eric Rescorla <[email-masked]>
Sent: Thursday, March 19, 2020 1:30 AM
To: 김준웅님(JOONWOONG.KIM)/기술표준화팀 <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [dispatch] Virtual IETF107 - SRT draft is available

Despite the title "secure" the description of encryption is rather thin. For instance, it appears that data packets can be "encrypted" but this does not describe how AFAICT. Is there a complete description somewhere? What are the desired security properties of this protocol?

-Ekr

On Tue, Mar 17, 2020 at 11:37 PM 김준웅님(JOONWOONG.KIM) <[email-masked]<mailto:[email-masked]>> wrote:
Hi all

thanks
Joonwoong
==
Joonwoong Kim | Global Standardization | SK Telecom mailto:[email-masked]<mailto:[email-masked]>

_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch