Subject: [dispatch] Tiny update to RFC 3405

From: Ted Hardie <[email-masked]>
Date: Wed, 3 Jun 2020 16:13:21 -0700

Howdy,

This is one the shortest drafts I've ever written:
https://datatracker.ietf.org/doc/draft-hardie-dispatch-rfc3405-update/ .
Basically, RFC 3405 used to require that registrations in URI.ARPA be from
the "IETF Tree".  That tree was deprecated after the document was
published.  As it happens, there are very few registrations in URI.ARPA, so
we did not catch it and fix it before now.

This draft updates RFC 3405 to require "permanent" scheme registrations.
The salient bit is this:

All registrations in URI.ARPA MUST be for schemes which are permanent
   registrations, as they are described in BCP 35.

I'm hoping for a quick dispatch of this, but happy to discuss.

regards,

Ted Hardie

---

From: Patrick McManus <[email-masked]>
Date: Thu, 4 Jun 2020 20:08:08 -0400

does the group have any thoughts on what the appropriate dispatch for Ted's
work (below) would be?

We certainly can do this outside of a list if there is participation and
rough consensus.. would be good to build that skill in this remote-only
period, right?

-Patrick

On Wed, Jun 3, 2020 at 7:13 PM Ted Hardie <[email-masked]> wrote:

> https://datatracker.ietf.org/doc/draft-hardie-dispatch-rfc3405-update/
> <https://datatracker.ietf..org/doc/draft-hardie-dispatch-rfc3405-update/>
> .   Basically, RFC 3405 used to require that registrations in URI.ARPA be
> from the "IETF Tree".  That tree was deprecated after the document was
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Scott Kitterman <[email-masked]>
Date: Fri, 05 Jun 2020 00:29:53 +0000

What did you have in mind as an alternative to an mailing list?

Scott K

---

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Jun 2020 14:02:30 -0500

I don't think there's work to do here that Ted's not already done - the 
draft looks ready to IETF LC. My preference would be to dispatch this to 
an AD to sponsor it, and let it go.

RjS

On 6/4/20 7:08 PM, Patrick McManus wrote:
> does the group have any thoughts on what the appropriate dispatch for 
> Ted's work (below) would be?
>
> We certainly can do this outside of a list if there is participation 
> and rough consensus.. would be good to build that skill in this 
> remote-only period, right?
>
> -Patrick
>
>
> On Wed, Jun 3, 2020 at 7:13 PM Ted Hardie <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Howdy,
>
>     .   Basically, RFC 3405 used to require that registrations in
>     URI.ARPA be from the "IETF Tree".  That tree was deprecated after
>     the document was published.  As it happens, there are very few
>     registrations in URI.ARPA, so we did not catch it and fix it
>     before now.
>
>     This draft updates RFC 3405 to require "permanent" scheme
>     registrations.  The salient bit is this:
>
>     [email-masked] <mailto:[email-masked]>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 9 Jun 2020 15:22:07 -0500

(no hats)

I agree with Robert that this is a reasonable candidate to be AD sponsored.

I propose the following edit to section 2, just to be formal about things. (I recognize it’s a bit pedantic :-) )

OLD:
All registrations in URI.ARPA MUST be for schemes which are permanent registrations, as they are described in BCP 35
.
NEW: 
This document removes the normative requirement in [RFC 3405] for registrations in URI.ARPA to be in the IETF URI Tree. 

All registrations in URI.ARPA MUST be for schemes which are permanent registrations, as they are described in BCP 35.

Ben.

> On Jun 3, 2020, at 6:13 PM, Ted Hardie <[email-masked]> wrote:
> 
> Howdy,
> 
> This is one the shortest drafts I've ever written:  https://datatracker.ietf.org/doc/draft-hardie-dispatch-rfc3405-update/ .   Basically, RFC 3405 used to require that registrations in URI.ARPA be from the "IETF Tree".  That tree was deprecated after the document was published.  As it happens, there are very few registrations in URI.ARPA, so we did not catch it and fix it before now.  
> 
> This draft updates RFC 3405 to require "permanent" scheme registrations.  The salient bit is this:
>

---

From: Ted Hardie <[email-masked]>
Date: Tue, 9 Jun 2020 13:42:48 -0700

Thanks for the review, Ben.  This change is made in my working copy; I'll
upload that when we get a dispatch decision or after receiving other
updates.

Ted

On Tue, Jun 9, 2020 at 1:22 PM Ben Campbell <[email-masked]> wrote:

> This document removes the normative requirement in [RFC 3405] for
> registrations in URI.ARPA to be in the IETF URI Tree.
>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 9 Jun 2020 15:56:30 -0500

Does anyone disagree with Robert’s recommendation for DISPATCH to recommend this become AD sponsored?

Thanks!

Ben.

> On Jun 5, 2020, at 2:02 PM, Robert Sparks <[email-masked]> wrote:
> 
> I don't think there's work to do here that Ted's not already done - the draft looks ready to IETF LC. My preference would be to dispatch this to an AD to sponsor it, and let it go.
> 
> RjS
> 
>> does the group have any thoughts on what the appropriate dispatch for Ted's work (below) would be?
>> 
>> We certainly can do this outside of a list if there is participation and rough consensus.. would be good to build that skill in this remote-only period, right?
>> 
>> -Patrick
>> 
>> 
>> On Wed, Jun 3, 2020 at 7:13 PM Ted Hardie <[email-masked] <mailto:[email-masked]>> wrote:
>> Howdy,
>> 
>> This is one the shortest drafts I've ever written:  https://datatracker.ietf.org/doc/draft-hardie-dispatch-rfc3405-update/ <https://datatracker.ietf..org/doc/draft-hardie-dispatch-rfc3405-update/> .   Basically, RFC 3405 used to require that registrations in URI.ARPA be from the "IETF Tree".  That tree was deprecated after the document was published.  As it happens, there are very few registrations in URI.ARPA, so we did not catch it and fix it before now.  
>> 
>> https://www.ietf.org/mailman/listinfo/dispatch <https://www.ietf.org/mailman/listinfo/dispatch>
>> 
>> 
>> https://www.ietf.org/mailman/listinfo/dispatch <https://www.ietf.org/mailman/listinfo/dispatch>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 9 Jun 2020 15:57:45 -0500

I suspect Patrick meant “outside of a working group”. Patrick?

> On Jun 4, 2020, at 7:29 PM, Scott Kitterman <[email-masked]> wrote:
> 
>> and
>> URI.ARPA be

---

From: Patrick McManus <[email-masked]>
Date: Tue, 9 Jun 2020 17:12:45 -0400

I asked the question in an open ended spirit with all of the usual dispatch
outcomes on the table. (but expressed it in phone keyboard speak - sorry.)

I would anticipate that this would generate an AD sponsored recommendation
due to its nature, but it would be nice to hear a few more comments
responsive to that before considering the consensus question..

On Tue, Jun 9, 2020 at 4:57 PM Ben Campbell <[email-masked]> wrote:

> >> <https://datatracker.ietf.
> .org/doc/draft-hardie-dispatch-rfc3405-update/>

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 09 Jun 2020 17:18:32 -0400

Thanks.  I have no issue with that.  I think it makes sense.

I was worried alternative to a mailing list was going to turn out to be some 
horrendous piece of web forum software.

Scott K

On Tuesday, June 9, 2020 5:12:45 PM EDT Patrick McManus wrote:
> > > On Jun 4, 2020, at 7:29 PM, Scott Kitterman <[email-masked]>
> > 
> > wrote:
> > > On June 5, 2020 12:08:08 AM UTC, Patrick McManus <[email-masked]>
> > 
> > wrote:
> > >>> from the "IETF Tree".  That tree was deprecated after the document
> > >> 
> > >> was
> > >> 
> > >>> published.  As it happens, there are very few registrations in
> > >> 
> > >> URI.ARPA, so
> > >> 
> > >> registrations.

---

From: Ben Campbell <[email-masked]>
Date: Mon, 22 Jun 2020 17:51:23 -0500

Hi Everyone,

The ART ADs have reminded the chairs that our charter allows us to adopt “simple administrative” work such as IANA registration documents. This draft seems to fit squarely in that category. Does anyone see a reason we shouldn’t just adopt it, with the expectation of going immediately to WGLC? (The last-call timeline is the same either way, either 2 weeks WGLC and 2 weeks IETF LC for a working group draft, or 4 weeks IETF LC for an AD sponsored draft.)

Thanks!

Ben (as co-chair)

---

From: Robert Sparks <[email-masked]>
Date: Tue, 23 Jun 2020 09:12:10 -0500

I can live with either path, but I still think allowing Dispatch to 
adopt work was a step onto the slippery slope mistake.

On 6/22/20 5:51 PM, Ben Campbell wrote:
> Hi Everyone,
>
> The ART ADs have reminded the chairs that our charter allows us to 
> adopt “simple administrative” work such as IANA registration 
> documents. This draft seems to fit squarely in that category. Does 
> anyone see a reason we shouldn’t just adopt it, with the expectation 
> of going immediately to WGLC? (The last-call timeline is the same 
> either way, either 2 weeks WGLC and 2 weeks IETF LC for a working 
> group draft, or 4 weeks IETF LC for an AD sponsored draft.)
>
> Thanks!
>
> Ben (as co-chair)
>
>> On Jun 3, 2020, at 6:13 PM, Ted Hardie <[email-masked] 
>> URI.ARPA be from the "IETF Tree". That tree was deprecated after the 
>> document was published.  As it happens, there are very few 
>> registrations in URI.ARPA, so we did not catch it and fix it before now.
>>

---

From: Mary Barnes <[email-masked]>
Date: Tue, 23 Jun 2020 11:29:55 -0500

I totally agree with Robert.

On Tue, Jun 23, 2020 at 9:12 AM Robert Sparks <[email-masked]> wrote:

> I can live with either path, but I still think allowing Dispatch to adopt
> work was a step onto the slippery slope mistake.
> The ART ADs have reminded the chairs that our charter allows us to adopt
> “simple administrative” work such as IANA registration documents. This
> draft seems to fit squarely in that category. Does anyone see a reason we
> shouldn’t just adopt it, with the expectation of going immediately to WGLC?
> (The last-call timeline is the same either way, either 2 weeks WGLC and 2
> weeks IETF LC for a working group draft, or 4 weeks IETF LC for an AD
> sponsored draft.)
>
> Thanks!
>
> Ben (as co-chair)
>
> dispatch mailing [email-masked]://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Ben Campbell <[email-masked]>
Date: Fri, 26 Jun 2020 10:40:39 -0500

I read Robert’s email to be an objection to the fact that our existing charter allows us to adopt certain documents at all, not an objection that this draft does not fit under the charter. If that’s not the case, please correct me.

Ben.

> On Jun 23, 2020, at 11:29 AM, Mary Barnes <[email-masked]> wrote:
> 
> On Tue, Jun 23, 2020 at 9:12 AM Robert Sparks <[email-masked] <mailto:[email-masked]>> wrote:
> I can live with either path, but I still think allowing Dispatch to adopt work was a step onto the slippery slope mistake.
> 
>>> On Jun 3, 2020, at 6:13 PM, Ted Hardie <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Howdy,
>>>