Subject: Re: [dispatch] A WG for HTTP API Building Blocks

From: Anton Tveretin <[email-masked]>
Date: Thu, 16 Jul 2020 21:32:15 +0500

Hello,

Of HTTP APIs, I know XMLHTTPRequest. Is it unsufficient?

And I think there are no common server-side APIs, only server (implementation) specific.

Sincerely yours.

---

From: Richard Barnes <[email-masked]>
Date: Thu, 16 Jul 2020 14:27:45 -0400

> Of HTTP APIs, I know XMLHTTPRequest. Is it unsufficient?

You mean fetch()?  :)  Yes, the idea here is that raw XHR is insufficient.
Saying "XHR is all you need" is like saying "TCP is all you need".

> (implementation) specific.

There are plenty of standardized things that are effectively HTTP APIs.
See, for example:

https://tools.ietf.org/html/rfc7030
https://tools.ietf.org/html/rfc8555
https://tools.ietf.org/html/rfc6749
https://tools.ietf.org/html/rfc8620

... in addition to many examples outside the IETF.

--RLB

> Sincerely yours.
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 16 Jul 2020 20:40:40 +0200

> Of HTTP APIs, I know XMLHTTPRequest. Is it unsufficient?

There are tons of APIs for clients. Not everything is a browser.

> (implementation) specific.

There are many, for instance the Java Servlet API or JAX-RS for Java.
I'm sure there are similar things for other languages.

Best regards, Julian

---

From: Mary Barnes <[email-masked]>
Date: Thu, 16 Jul 2020 13:54:47 -0500

And, just to add to the list:
XCON CCMP:  https://tools.ietf.org/html/rfc6503
HELD:  https://tools.ietf.org/html/rfc5985

We've been doing a lot of this for a while.

- MLB

On Thu, Jul 16, 2020 at 1:28 PM Richard Barnes <[email-masked]> wrote:

> You mean fetch()?  :)  Yes, the idea here is that raw XHR is
> insufficient.  Saying "XHR is all you need" is like saying "TCP is all you
> need".
>
>