Subject: [dispatch] HTTPAPI Charter

From: Ben Campbell <[email-masked]>
Date: Mon, 10 Aug 2020 21:07:29 -0500

Hi Everyone,

Based on discussion in the IETF108 meeting and followup on the list, the chairs think that the HTTPAPI charter [1] is ready to go to the ADs. If people have additional feedback, there will be opportunity to refine it further during the cross-IETF external review period.

[1] https://gist.github.com/mnot/8a29455df65df33d92902a1ecc3e7e68 (pasted below for convenience)

Thanks!

The DISPATCH Chairs.

——————————————————

Building Blocks for HTTP APIs Working Group (HTTPAPI)

HTTP is often for not only Web browsing, but also machine-to-machine communication, often called 'HTTP APIs'. This Working Group will standardise HTTP protocol extensions for use in such cases, with a focus on building blocks for separate or combined use.

Its output can include:

	• Specifications for new HTTP header and/or trailer fields
	• Specifications for new message body formats, or conventions for use in them (e.g., patterns of JSON objects)
	• Proposals for new HTTP status codes, methods, or other generic extensions, to be considered by the HTTP Working Group
	• Best practices and other documentation for HTTP API designers, consumers, implementers, operators, etc.
Other items are out of scope. In particular, this WG will not take on work items for APIs for specific use cases or applications, and it will not define new HTTP extension points, or new extensions that are likely to be implemented by Web browsers (based upon consultation with the HTTP WG). APIs for HTTP itself (e.g., in clients and servers) are also out of scope.

New work items can be added after a Call for Adoption on the working group mailing list and consultation with the Area Director.

To be successful, this Working Group will need to have active and broad representation from across the industry -- e.g., API gateway vendors (and other intermediaries), API consultants, API tool vendors, in-house API teams. Therefore, adopted proposals should have public support from multiple implementers and/or deployments before being sent to the IESG.

This Working Group will need to coordinate closely with the HTTP Working Group.

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 11 Aug 2020 17:07:35 +0900

Hello Ben, others,

I suggest the following (purely editorial) change:

OLD
HTTP is often for not only Web browsing

NEW
HTTP is often used for not only Web browsing

EVEN BETTER
HTTP is often used not only for Web browsing

Regards,   Martin.

On 11/08/2020 11:07, Ben Campbell wrote:
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
> 

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan