Subject: Re: [dispatch] WHIP - WebRTC HTTP ingestion protocol

From: Sergio Garcia Murillo <[email-masked]>
Date: Tue, 1 Dec 2020 22:40:46 +0100

On 30/11/2020 18:56, Adam Roach wrote:
>
> Having read through the proposal and watched the corresponding segment 
> of the DISPATCH meeting from two weeks ago, I think that having 
> something like this standardized would be very useful, both for the 
> handful of broadcasting tools that exist as well as for the various 
> WebRTC broadcast networks that are being deployed.
>
> So I definitely think we should pursue this work in the IETF.
>
> It's a little less clear to me whether we want to slot this into 
> something like MMUSIC or to create a short-lived working group. I'm 
> leaning towards the second, for a couple of reasons. First, I found 
> Ted's comments at the DISPATCH meeting to be kind of illuminating as 
> far as the kinds of additional work that might be necessary (and I 
> have my own list of things that might need some refinement, like 
> negotiation of authentication mechanisms); and that nudges the effort 
> into a "maybe a little larger than just one work item in a 
> long-standing working group." More importantly, this work straddles 
> the real-time media and web disciplines, and I'd like to make sure we 
> have people from the latter group putting eyes on it. I seriously 
> doubt we can get HTTP experts showing up at MMUSIC, but there's at 
> least a fair chance that we might get them interested in a 
> lower-volume mailing list such as a dedicated WHIP WG.
>
> I think this mirrors, for the most part, the tentative conclusion that 
> came out of the DISPATCH discussion earlier this month. If we decide 
> to take this path of creating a short-lived WG, I'm happy to help 
> craft a charter and plan to be actively involved in the technical work.
>
I agree with you, a dedicated small/short lived WG would be the best way 
to have right people involved and focused. Also, your collaboration is 
really appreciated, looking forward to start working on it.

Best regards

Sergio

---

From: Alexandre GOUAILLARD <[email-masked]>
Date: Wed, 2 Dec 2020 06:36:28 +0800

+1 with Sergio

Sent from my iPhone

> On 2 Dec 2020, at 05:40, Sergio Garcia Murillo <[email-masked]> wrote:
> 
>> Having read through the proposal and watched the corresponding segment of the DISPATCH meeting from two weeks ago, I think that having something like this standardized would be very useful, both for the handful of broadcasting tools that exist as well as for the various WebRTC broadcast networks that are being deployed.
>> 
>> It's a little less clear to me whether we want to slot this into something like MMUSIC or to create a short-lived working group. I'm leaning towards the second, for a couple of reasons. First, I found Ted's comments at the DISPATCH meeting to be kind of illuminating as far as the kinds of additional work that might be necessary (and I have my own list of things that might need some refinement, like negotiation of authentication mechanisms); and that nudges the effort into a "maybe a little larger than just one work item in a long-standing working group." More importantly, this work straddles the real-time media and web disciplines, and I'd like to make sure we have people from the latter group putting eyes on it. I seriously doubt we can get HTTP experts showing up at MMUSIC, but there's at least a fair chance that we might get them interested in a lower-volume mailing list such as a dedicated WHIP WG.
>> 
>> I think this mirrors, for the most part, the tentative conclusion that came out of the DISPATCH discussion earlier this month. If we decide to take this path of creating a short-lived WG, I'm happy to help craft a charter and plan to be actively involved in the technical work.
>> 
> I agree with you, a dedicated small/short lived WG would be the best way to have right people involved and focused. Also, your collaboration is really appreciated, looking forward to start working on it.
> 
> Best regards
> 
> Sergio
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch