Subject: [Diversity] Starting the discussion

From: SM <[email-masked]>
Date: Sun, 14 Apr 2013 13:28:46 -0700

Hello,

To start the discussion I'll quote Jari Arkko:

   "we think of diversity as something that covers international participation,
    different cultures, gender, age, organisational background, and so on.
    While the IETF has become a very international organisation (with
    participants from 60 countries working on documents, for instance),
    there are many aspects of diversity where we could do much better.  Overall
    participation is concentrated in some areas of the world, with little
    participation from Africa and South America, for instance. Similarly,
    while the IETF has some very active female participants and leadership
    members, the numbers are very small.  Much of the work in the IETF is
    driven by large networking companies, yet academia and small companies
    would have more to give, and operational experience from additional
    operators would be similarly appreciated.

   Importantly, these disparities appear most prominently in our leadership"

There is little participation from developing countries as the people 
identified to participate in the IETF do not do protocol-related 
work.  I don't know whether anyone on this mailing list has seen 
http://www.africafornorway.no/  That's the approach currently being 
taken.  It is not in the interest of anybody to raise the issue.  The 
few people who attempt to participate in a discussion can receive 
disparaging remarks from regular IETF participants.  Nobody raises 
any objection.  I saw a case recently.  I did not say anything as in 
my opinion there would not be any community support.

Someone mentioned "be persistent" in a discussion on an unrelated 
IETF mailing list.  The IETF culture discourages people who are not 
familiar with U.S. culture to participate.  It's not that the people 
are not persistent; it's difficult to understand how the IETF works.

In my opinion the IETF does not understand young people.  There is a 
tendency to either take a paternalistic approach or else expect 
people to go through the same difficulties so that they can learn.

If a person comes to an IETF meeting he/she will see women at the 
registration desk and maybe one or two women in a working group 
session.  He/she won't see any women on the IESG.  It looks like the 
usual stereotypes.  The five women who went to the microphone were 
courageous enough to do so.

It has been mentioned that the values are more important than who 
"represents" whom.  The values do not map to what the average 
participant sees.  There is a saying: "Not only must justice be done; 
it must also be seen to be done".

Regards,
-sm

---

From: Hector Santos <[email-masked]>
Date: Wed, 17 Apr 2013 12:21:12 -0400

Hi,

I would like to get a good feel for what the IETF believes are the 
diversity problems, ones that are not helping it, i.e. causing problems, 
and thus we are seeking suggestions to improve the IETF as a whole?

What are the diversity problems to solve/address?  Diversity can mean 
many things as well.  It could be the IETF is diversifying in its 
product lines, like addressing new problems other than the development 
of the Internet protocols and methods.  Is this related to other forms 
of diversity? mindsets and philosophies?

So far, it seems to me that the key diversity concerns falls into a 
gender/cultural vs everything else diversity issue.

   o Gender Diversity
   X International Diversity (completed??)
   X Electronic Diversity (completed?? anyone can "join" electronically)
   o Vendor Diversity
   o Diversity in Leadership
   o Diversity in Projects (working groups)
   o Diversity in Reviewers
   o Others?

I think one of the main goals of diversity is how it addresses the 
questions for sense of fairness and conflicts of interest.  One of the 
attributes of having lesser participation is more of the IETF projects 
are monopolized by the same folk(s), naturally.  That can be good but 
also a problem in my view when the synergism is lost, input is not 
considered, etc.   I think there are some process issues that are being 
exploited (because they are allowed) by IETF folks that is not always 
ideal.  We see the pressures to expedite and "rubber stamp" the work 
efforts.

As far as gender, well, I don't think the IETF has a copyright on this 
problem, nor do I believe it can find an ideal solution that will not 
include a quota system.  Having asked the question of Human Resources 
folks and also dealing with it myself, every company and organization 
(especially those doing any form of work related to the federal 
government) that is concern about it, uses a quota system. I don't see 
how it can be avoided.

But overall, I think the two (Gender/Culture vs Everything else) are 
totally different set of problems with two different sets of solutions.

--
HLS

On 4/14/2013 4:28 PM, SM wrote:
> identified to participate in the IETF do not do protocol-related work.
> I don't know whether anyone on this mailing list has seen
> disparaging remarks from regular IETF participants.  Nobody raises any
> objection.  I saw a case recently.  I did not say anything as in my
> opinion there would not be any community support.
>
> Someone mentioned "be persistent" in a discussion on an unrelated IETF
> mailing list.  The IETF culture discourages people who are not familiar
> with U.S. culture to participate.  It's not that the people are not
> persistent; it's difficult to understand how the IETF works.
>
> tendency to either take a paternalistic approach or else expect people
> to go through the same difficulties so that they can learn.
>
> participant sees.  There is a saying: "Not only must justice be done; it
> must also be seen to be done".
>
> Regards,
> -sm
>
> _______________________________________________
> diversity mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/diversity
>
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 17 Apr 2013 17:27:19 +0000

Hi,

On Apr 17, 2013, at 9:21, Hector Santos <[email-masked]> wrote:
> So far, it seems to me that the key diversity concerns falls into a gender/cultural vs everything else diversity issue.

I agree that the most pressing diversity "dimensions" are probably gender and cultural/regional background.

Lack of diversity along those dimensions is an issue both in terms of the general body of IETF participants as well we in terms of the group of IETF leaders (WG chairs, I*, etc.)

I'd personally be very happy if we could increase diversity along those two dimensions in those two sets of people. Yes, there are probably other diversity dimensions, and there are probably other sets of people and things we could apply these and other dimensions to. But to me personally, those are secondary.

The set of attendees is the pool out of which leadership positions get filled. So measures and processes to make the IETF an attractive place for all kinds of folks to participate in should be one of our focus areas. As should measures/processes that will bring new attendees closer into the IETF once they have begun to attend, such as training them for leadership positions.

And then there are the various leadership selection processes (chair selection, NomCom appointments, various other appointments done by I*, etc.) For many of those, we already have detailed processes, and I personally wouldn't want to spend much energy on trying to patch them in the hopes of increasing diversity. I hope that this will resolve itself when the attendee pool is more diverse.

Half-baked thought: In the meantime, instead of tweaking selection processes, maybe it would be a fist step to simply ask the various selecting bodies and individuals for a pledge. The pledge would be that when they pick someone for a leadership position, they take a moment to ask themselves "if we're selecting a white male person, is he really the best selection for this position, in terms of individual qualification and in terms of making sure that the diversity of the community is represented in its leadership?"

Lars

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 17 Apr 2013 18:51:23 +0000

> Lack of diversity along those dimensions is an issue both in terms of the
> general body of IETF participants as well we in terms of the group of IETF
> leaders (WG chairs, I*, etc.)
> 
> I'd personally be very happy if we could increase diversity along those two
> dimensions in those two sets of people. Yes, there are probably other
> diversity dimensions, and there are probably other sets of people and things
> we could apply these and other dimensions to. But to me personally, those
> are secondary.

I would like to suggest that one of the problems that IETF has is not just about who the attendees/participants/leadership are, but about the behavior that is tolerated, espoused, and demonstrated by all of these. I'm not personally aware of overly bad behavior being espoused or demonstrated by leaders, but I am keenly aware of it among some attendees and participants. Which suggests to me that there is not a very strong message from leadership to discourage it (i.e., it is being tolerated).

I'd also like to mention (in case IETF members aren't aware) that IETF has a rather bad reputation in the operator community as being an incredibly hostile place to do business, where operators are routinely insulted and bashed (as an industry), and discussions around operational complexity are treated dismissively and derisively. v6ops is an exception; an exception that had to specifically be created as a place where operators would feel "safe" in trying to have those discussions. Personally, I try to steer standards efforts that I can influence anywhere else but IETF, because I dislike working in a hostile environment. In talking with other employees of operators, I've concluded I'm not the only one who feels this way. I work in a variety of other SDOs and SIGs, where there is strong and often contentious discussion, and where behavior of segments of the industry or specific companies is often directly discussed. But nowhere have I experienced such open hostility towards operators as in IETF. BTW, I notice there's a distinct lack of operators in the IETF leadership. I wonder if there's any correlation. 

This sort of diversity does fall into the "everything else" category, and it may be something that IETF doesn't want to address. IETF may be happy with its limited operator participation -- I don't know. I do suspect, though, that if there were less tolerance (by all in IETF) of foul language, openly hostile and insulting comments (directed at anybody), and other bad behavior, that it might improve the willingness of more women and people from other regions to participate, as well as people who work for operators. But such expectations would have to come from the top.

Please know, I'm not saying all of this to belittle IETF. I'm saying this because I truly would like for IETF to become an organization that doesn't make me cringe whenever I think about doing work within its confines. The armor and bullet-proof vests I surround myself with to participate in IETF discussions is about 10 times thicker than the armor I surround myself with for other SDOs and SIGs. And it's not the technical comments I'm defending against. It's the irrational FUD and the ones that get personal.
Barbara

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 17 Apr 2013 19:17:32 +0000

Hi,

> I would like to suggest that one of the problems that IETF has is not just about who the attendees/participants/leadership are, but about the behavior that is tolerated, espoused, and demonstrated…

I'm sorry to hear this. Have you brought these to the attention of the IESG or IAB? I'm sure that neither condones any such behavior, but in order to send a strong message when such things do occur, they/we need to know about it. 

(We could obviously publish a code of conduct, but that would necessarily be a pretty generic statement. Still, it may be useful to do so, and maybe link it to the Note Well.)

There has been one instance in one of the IRTF RGs recently where a clearly inappropriate image was included in a presentation by someone new to the IETF. Since I was in the room, I could react, but otherwise I may not have heard about it and would not have been able to do something about it.

> I'd also like to mention (in case IETF members aren't aware) that IETF has a rather bad reputation in the operator community as being an incredibly hostile place to do business

Right. I also think that - for example - we have successfully scared away much of the research community from the IETF, which is one reason why potentially disrupting technologies that are coming out of university research (such as SDN & OpenFlow) are being developed in new fora rather than here.

> This sort of diversity does fall into the "everything else" category, and it may be something that IETF doesn't want to address.

I don't think the IETF has made any such decision; my earlier email just tried to summarize what I think we should focus on. More operators - and more researchers, for that matter - would make the organization stronger. The reason I tried to argue for a narrow scope, i.e., picking a few key diversity issues - at least initially -and doing something concrete about them sooner rather than later, is that otherwise I fear this list will turn into a discussion club and be ineffective.

I'd love for us to actually TRY something by the Berlin or at least Vancouver meeting.

Lars

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 17 Apr 2013 20:30:27 +0100

I've no clear view as to what the operator community think
but would be interested to find out and agree it'd be
better to have more of 'em about.

I think its easy to agree to not condone bad behaviour. But
one person's robust debate is another's foul language maybe
so for this thread to be useful someone sometime would need
to try figure out what's problematic and what's not, which
I guess can mostly only be done via illustrative examples
about which folks would wildly disagree. (I'm not asking
that we do that now via email, that'd likely be
counterproductive, someone should ponder it a bit more
first probably.)

> Right. I also think that - for example - we have successfully scared away much of the research community from the IETF, which is one reason why potentially disrupting technologies that are coming o…

But I don't think this is right. I think by far the most
important factor there is that academics are now so
publication (and publication metric) obsessed that they
don't care about the IETF since our publications simply
don't count in that universe. If you can get a sigcomm
paper via ns-2 that's much more productive than spending
a couple of years haggling with the real Internet.
I'd be surprised if they had been scared off by bad or
good behaviour. They could be attracted back if RFCs or
chairing counted for tenure maybe, if someone could try
encourage that. It'd probably take a few top-ranked
universities doing it publicly or something though for
it to start happening.

S.

---

From: Thomas Narten <[email-masked]>
Date: Wed, 17 Apr 2013 15:54:49 -0400

"STARK, BARBARA H" <[email-masked]> writes:

> I would like to suggest that one of the problems that IETF has is
> not just about who the attendees/participants/leadership are, but
> about the behavior that is tolerated, espoused, and demonstrated by
> all of these. I'm not personally aware of overly bad behavior being
> espoused or demonstrated by leaders, but I am keenly aware of it
> among some attendees and participants. Which suggests to me that
> there is not a very strong message from leadership to discourage it
> (i.e., it is being tolerated).

What this suggests to me is that we may want to spend time on how to
improve the overall participation "enviroment" of the IETF. If the
environment turns folk away, we need to think seroiusly about changing
the environment. This is of course not easy, but is part of the
background that enables (or fosters) diversity issues more
generally. 

One thing this will take is looking at specific examples (when they
happen) and dealing with them in a direct way. It's easy to downplay
individual incidents as "not that bad" or "exceptions", but they do
have a way fo building up over time.

I doubt raising these issues with the I* is enough. Has it been done?
Has there been results?

I personally know of one very outrageous example that occurred in
Atlanta. But talking about it publically puts the target in a very
awkward position and many folk don't want to do that because they fear
the repurcussions. That this does indeed happen makes clear to me we
have a real issue in this community.

> I'd also like to mention (in case IETF members aren't aware) that
>  IETF has a rather bad reputation in the operator community as being
>  an incredibly hostile place to do business, where operators are
>  routinely insulted and bashed (as an industry), and discussions
>  around operational complexity are treated dismissively and
>  derisively.

Yes. I've seen it and talked to operators that are now on the side
lines saying "who are they to tell me that how I run my data center is
stupid and I should just change it?" Part of this comes from an
attitude among some IETFers that the louder (and more frequently) one
shouts (whether what one says actually makes sense or not) is the way
you get things done or "become a leader" in the IETF. That is an
example of something the IETF has long tolerated and creates a
negative environment.

Thomas

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Wed, 17 Apr 2013 16:14:24 -0400

These are great pints and I think it seems evident that change is needed to improve diversity.  I do think stories are helpful, especially when something was done successfully to correct a situation.  We can learn from this and figure out how we can apply it more broadly to open up the environment to others.  I would like to learn more about how this issue was fixed in v6ops and how that may be replicated (if appropriate).  

I also had an experience in Atlanta where someone was very excited about his work, and maybe the presentation could have been a little shorter, but it was good.  I personally appreciated seeing someone that excited about the improvements in their work.  A few comments were made by others sitting near me (long-time attendees).  I shut down the side conversation near me (in a way that was well received), but that should not have been necessary.  There were no derogatory comments, it just wasn't as friendly to newcomers.  Efforts like this will be needed to change the culture and it may be easier to make them before the comments get worse (usually they progress). 

Please keep the stories coming, preferably with solutions that worked!  It may be good to look at several examples and then take a step back to review and determine improvements that can be made to existing programs/policies or new ones that are needed... or methods that we could use to open up the culture to diversity by improving the interactions and respect between participants. 

I have also participated in a few SDOs.  I like the IETF format and expertise of participants, but we could benefit if it were easier for diverse viewpoints to be represented.

Thank you,
Kathleen    

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Wednesday, April 17, 2013 3:55 PM
To: STARK, BARBARA H
Cc: Hector Santos; Eggert, Lars; <[email-masked]>
Subject: Re: [Diversity] Defining the Diversity problems (was: Starting the discussion)

Thomas

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 17 Apr 2013 22:01:07 -0400

Hi Stephen,

> universities doing it publicly or something though for

Brian Carpenter wrote this article in the SIGCOMM CCR a couple of years
ago that recommended considering RFCs as being equivalent to other
scholarly publications, but I am not sure if it gained any traction in
the academic community.

http://www.sigcomm.org/sites/default/files/ccr/papers/2010/January/1672308-1672315.pdf

Thanks
Suresh

---

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Apr 2013 09:38:35 +0300

> scholarly publications, but I am not sure if it gained any traction in

FWIW, impacts to standards (like RFCs from IETF) are highly appreciated in research projects, such as those funded by EU. However, perhaps the issue is that for the academic institution and the researcher's employment there, they do not count. Or at least do not count everywhere. Maybe Lars could work on getting at least IRTF RFCs accepted similarly as journal articles in some key institutions :-)

Jari

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 18 Apr 2013 19:12:15 +0000

On Apr 17, 2013, at 23:38, Jari Arkko <[email-masked]> wrote:
> Maybe Lars could work on getting at least IRTF RFCs accepted similarly as journal articles in some key institutions :-)

Brian Carpenter and Craig Partridge have tried to make this argument, unfortunately without much luck:

Lars

---

From: Aaron Yi DING <[email-masked]>
Date: Wed, 24 Apr 2013 14:22:49 +0300

>> Maybe Lars could work on getting at least IRTF RFCs accepted similarly as journal articles in some key institutions :-)

One thing that may help (from IETF side) is to cite in RFCs and/or I-Ds 
the research work e.g. papers that are done by IETF researchers, or 
their content being relevant to the technical scheme.

Citation is an important factor that matters to academic research.

My 2 cents,
Aaron

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 24 Apr 2013 14:14:06 +0000

Hi,

On Apr 24, 2013, at 4:22, Aaron Yi DING <[email-masked]> wrote:
> One thing that may help (from IETF side) is to cite in RFCs and/or I-Ds the research work e.g. papers that are done by IETF researchers, or their content being relevant to the technical scheme.
> 

good point.

Also, maybe the details of this discussion are better had on the irtf-discuss list?

Lars