Subject: [DMM] Network-based DMM demo (Thu 15:30 room 251)

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Tue, 27 Mar 2012 17:34:53 +0200

Hi all,

We'd like to announce that our network-based DMM demo will take place on
Thursday at 15:30 in room 251.

The demo will show a Linux-based prototype based on [1] and [2] running
on a live setup.

The setup is composed of three "anchor routers", a "centralized LMA" for
control plane, a couple of correspondent nodes (a netbook and an IPv6
camera) and a legacy IPv6 mobile node (a netbook).

Looking forward to seeing you there and getting your feedback.

Thanks,

Carlos, Telemaco and Juan Carlos

[1] http://tools.ietf.org/html/draft-bernardos-dmm-pmip-01
[2]
http://tools.ietf.org/html/draft-bernardos-dmm-distributed-anchoring-00
-- 
Carlos Jesús Bernardos Cano  http://www.netcom.it.uc3m.es/
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 28 Mar 2012 11:02:00 +0200

Hi Dapeng,

On Wed, 2012-03-28 at 15:54 +0800, Dapeng Liu wrote:
> Hello Carlos,
> 
> Sounds interesting, may I ask how many virtual routers is running on the
> anchor router?

Thanks.

I'm not sure I got your question right. If you are asking how many
"virtual machines" we are running in our demo, then the answer is none,
we are using different physical boxes for each entity.
If you are asking how many distributed logical interfaces are configured
on each anchor router, this depends on the mobility pattern of the MN,
but since we have one MN and three anchor routers, each of them can have
at most three.

Thanks,

Carlos

> 
> Regards,
> -Dapeng Liu
> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Carlos Jesú
> s Bernardos Cano
> 发送时间: 2012年3月27日 23:35
> 收件人: [email-masked]; [email-masked]
> 抄送: Telemaco Melia
> 主题: [DMM] Network-based DMM demo (Thu 15:30 room 251)
> 
> Hi all,
> 
> The demo will show a Linux-based prototype based on [1] and [2] running on a
> live setup.
> 
> Carlos Jesús Bernardos Cano  http://www.netcom.it.uc3m.es/ GPG FP: D29B
> 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67
>

---

From: Rute Sofia <[email-masked]>
Date: Wed, 28 Mar 2012 11:07:45 +0100

Hello Carlos,

I cannot attend the meeting but would like to know if it is possible to 
have access to the software, as you mention it is open-source.

BR,
Rute Sofia

On 03/27/2012 04:34 PM, Carlos Jesús Bernardos Cano wrote:
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

-- 
Rute Sofia, PhD ([email-masked])
Scientific Director for Technology
Research Unit in Informatics Systems and Technologies (SITI)
Coordinator of the Internet Architecture and Networking Lab (IAN Lab)
University Lusofona, Portugal
[email-masked]

http://siti.ulusofona.pt
Tel.: 217 515 500 Fax: 21 757 7006
.......................................................

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 28 Mar 2012 14:05:28 +0200

Hi Dapeng,

(removing netext from the destination, so we avoid cross posting,
apologies for the previous messages).

Please, see below...

On Wed, 2012-03-28 at 17:14 +0800, Dapeng Liu wrote:
> Hi Carlos,
> 
> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Carlos Jesús Bernardos Cano
> 发送时间: 2012年3月28日 17:02
> 收件人: Dapeng Liu
> 抄送: [email-masked]; [email-masked]; 'Telemaco Melia'
> 主题: Re: [DMM] 答复: Network-based DMM demo (Thu 15:30 room 251)
> 
> Hi Dapeng,
> 
> > Sounds interesting, may I ask how many virtual routers is running on 
> > the anchor router?
> 
> Thanks.
> 
> I'm not sure I got your question right. If you are asking how many "virtual machines" we are running in our demo, then the answer is none, we are using different physical boxes for each entity.
> If you are asking how many distributed logical interfaces are configured on each anchor router, this depends on the mobility pattern of the MN, but since we have one MN and three anchor routers, each of them can have at most three.
> 
> [Dapeng]
> Yeah, I am referring the 'distributed logical interfaces'. How about
> the scalability? since it depends on the mobility pattern of MN..
> 

Creation and maintenance of logical interfaces is a very low resource
consuming task.

Besides, in realistic deployments, the chances that an MN has active
anchored prefixes in more than 2-3 D-GWs will be very low. Most likely,
address continuity will be only provided for one prefix anchored at a
different D-GW.

Thanks,

Carlos

> > We'd like to announce that our network-based DMM demo will take place 
> > on Thursday at 15:30 in room 251.
> > 
> > The demo will show a Linux-based prototype based on [1] and [2] 
> > running on a live setup.
> > 
> > The setup is composed of three "anchor routers", a "centralized LMA" 
> > for control plane, a couple of correspondent nodes (a netbook and an 
> > IPv6
> > Carlos Jesús Bernardos Cano  http://www.netcom.it.uc3m.es/ GPG FP: 
> > D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67
> > 
> 
> --
> Carlos Jesús Bernardos Cano  http://www.netcom.it.uc3m.es/ GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67
>

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 28 Mar 2012 14:29:00 +0200

Hi Rute,

> have access to the software, as you mention it is open-source.

This is under discussion. We'll announce to the list.

Thanks,

Carlos

---

From: "Dapeng Liu" <[email-masked]>
Date: Wed, 28 Mar 2012 17:14:46 +0800

Hi Carlos,

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Carlos Jesús Bernardos Cano
发送时间: 2012年3月28日 17:02
收件人: Dapeng Liu
抄送: [email-masked]; [email-masked]; 'Telemaco Melia'
主题: Re: [DMM] 答复: Network-based DMM demo (Thu 15:30 room 251)

Hi Dapeng,

Thanks.

[Dapeng]
Yeah, I am referring the 'distributed logical interfaces'. How about the scalability? since it depends on the mobility pattern of MN..

Regards,
-Dapeng Liu

Thanks,

Carlos