Subject: [DMM] draft requirement REQ-4: compatibility

From: h chan <[email-masked]>
Date: Mon, 7 May 2012 18:04:04 +0000

REQ-4: compatibility
The DMM solutions SHALL support existing network deployment with IPv6 (e.g. existing IPv6 address assignment), be compatible with other mobility protocols, and be interoperable with the network or the mobile hosts/routers that do not support the DMM enabling protocol so that the existing network deployments are unaffected.

REQ-4M (Motivation for REQ-4)
Motivation: The motivation of this requirement is to be able to work with network architectures of both hierarchical networks and flattened networks, so that the mobility management protocol possesses enough flexibility to support different networks, and so that the existing networks and hosts are not affected and do not break.

OTHER related problem
O-PS3: Complicated deployment with too many variants and extensions of MIP
Deployment is complicated with many variants and extensions of MIP. When introducing new functions which may add to the complicity, existing solutions are more vulnerable to break.

(The above has been drafted with contributions, inputs and discussions from various people. Additional contributions and comments are most welcome.)

H Anthony Chan

---

From: jouni korhonen <[email-masked]>
Date: Fri, 18 May 2012 03:00:23 +0300

> Motivation: The motivation of this requirement is to be able to work with network architectures of both hierarchical networks and flattened networks, so that the mobility management protocol posses…

Isn't the motivation just "SHALL not break existing network deployments and end hosts" ?
Either the network or the host may not have any idea of the solutions developed in DMM.

- JOuni

> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: Peter McCann <[email-masked]>
Date: Fri, 18 May 2012 15:00:03 +0000

Hi, Jouni,

jouni korhonen wrote:
>> The DMM solutions SHALL support existing network deployment with
>> IPv6
>> (e.g. existing IPv6 address assignment), be compatible with other
>> mobility protocols, and be interoperable with the network or the
>> mobile hosts/routers that do not support the DMM enabling protocol so
>> that the existing network deployments are unaffected.
>> 
>> Motivation: The motivation of this requirement is to be able to work
>> with network architectures of both hierarchical networks and flattened
>> networks, so that the mobility management protocol possesses enough
>> flexibility to support different networks, and so that the existing
>> networks and hosts are not affected and do not break.
> 

I think that's a reasonable simplification.  We need a strategy for
backwards compatibility.

-Pete

> - JOuni
> 
>> 
>> OTHER related problem O-PS3: Complicated deployment with too many
>> variants and extensions of MIP Deployment is complicated with many
>> variants and extensions of
> MIP. When introducing new functions which may add to the complicity,
> existing solutions are more vulnerable to break.
>> 
>> (The above has been drafted with contributions, inputs and discussions
>> from various people. Additional contributions and comments are most
>> welcome.)
>> 
>> H Anthony Chan
>> 
>>

---

From: h chan <[email-masked]>
Date: Thu, 24 May 2012 01:01:42 +0000

An attempt to clean up the text for REQ-4:

REQ-4: compatibility 
The DMM solutions SHALL support existing network deployment with IPv6 (e.g. existing IPv6 address assignment), be compatible with other mobility protocols, and be interoperable with the network or the mobile hosts/routers that do not support the DMM enabling protocol so that the existing network deployments and end hosts are not broken.
REQ-4M (Motivation for REQ-4)
Motivation: The motivation of this requirement is not to break existing network deployments and end hosts. 
OTHER related problem
O-PS3: Complicated deployment with too many variants and extensions of MIP
Deployment is complicated with many variants and extensions of MIP. When introducing new functions which may add to the complicity, existing solutions are more vulnerable to break.

H Anthony Chan

-----Original Message-----
From: Peter McCann 
Sent: Friday, May 18, 2012 10:00 AM
To: jouni korhonen; h chan
Cc: [email-masked]
Subject: RE: [DMM] draft requirement REQ-4: compatibility

Hi, Jouni,

-Pete