Subject: Re: [DMM] DMM functional framework posted

From: <[email-masked]>
Date: Sun, 4 Nov 2012 20:02:30 +0000

Hi Marco,

I have read this draft and I think that it is useful for the DMM WG. However, I have some comments:

1) Can you please emphasize which approach have you followed in order to derive the functional entities that are described in Section 3. One could derive other FEs than the ones mentioned in Section 3.

2) What are the main differences between the framework that you propose in this draft and the one proposed in: framework, like the one introduced in http://www.ietf.org/id/draft-chan-dmm-framework-gap-analysis-05.txt.

Best regards,
Georgios

________________________________________
Van: [email-masked] [[email-masked]] namens Marco Liebsch [[email-masked]]
Verzonden: dinsdag 16 oktober 2012 18:04
To: [email-masked]
Onderwerp: [DMM] DMM functional framework posted

As follow up of a discussion during last IETF meeting with some of you,  we posted a
new draft about an initial functional framework for DMM. We think that
discussing BCP and gaps can be supported by using well defined functional entities (FE)
and reference points to enable DMM. Different constellations of FEs can match architectures
of existing protocols and gaps as well as strengths or weak points of the associated
architecture/protocol can be easily identified.

The current version provides a basic set of FEs and interfaces and depicts two
key models as starting point to group FEs according to the WG's current understanding
how DMM may be solved.

Any opinion about the proposed framework and approach as well as contributions to an
updated version of this draft are appreciated.

Marco

--
A new version of I-D, draft-liebsch-dmm-framework-analysis-00.txt
has been successfully submitted by Marco Liebsch and posted to the IETF repository.

Filename:        draft-liebsch-dmm-framework-analysis
Revision:        00
Title:           Distributed Mobility Management - Framework & Analysis
Creation date:   2012-10-15
WG ID:           Individual Submission
Number of pages: 16
URL:             http://www.ietf.org/internet-drafts/draft-liebsch-dmm-framework-analysis-00.txt
Status:          http://datatracker.ietf.org/doc/draft-liebsch-dmm-framework-analysis
Htmlized:        http://tools.ietf.org/html/draft-liebsch-dmm-framework-analysis-00

Abstract:
   Mobile operators consider the distribution of mobility anchors to
   enable offloading some traffic from their core network.  The
   Distributed Mobility Management (DMM) Working Group is investigating
   the impact of decentralized mobility management to existing protocol
   solutions, while taking into account well defined requirements, which
   are to be met by a future solution.  This document discusses DMM
   using a functional framework.  Functional Entities to support DMM as
   well as reference points between these Functional Entities are
   introduced and described.  The described functional framework allows
   distribution and co-location of Functional Entities and build a DMM
   architecture that matches the architecture of available protocols.
   Such methodology eases the analysis of best current practices with
   regard to functional and protocol gaps.

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: Marco Liebsch <[email-masked]>
Date: Sun, 4 Nov 2012 22:30:39 +0000

Hi Georgios,

thanks for your comments. Please see inline for my response.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Sonntag, 4. November 2012 21:02
>To: Marco Liebsch; [email-masked]
>Subject: RE: DMM functional framework posted
>
>Hi Marco,
>
>1) Can you please emphasize which approach have you followed in order to
>derive the functional entities that are described in Section 3. One could derive
>other FEs than the ones mentioned in Section 3.

The approach is to assume a mobility anchor/gateway and add functional
entities to enable DMM without taking assumptions on the mobility protocol.
Hence, it does not take assumptions on mobility protocol dependency.

As soon as a suitable set of functional entities is defined, we can take mobility
protocols (MIP6, PMIP6), either with or without extension protocols, such as
runtime LMA redirection. Then the DMM functional entities can be placed to
the associated architecture in different ways, either collocated with mobility
components or other components, e.g. provided by the transport network, and
we can analyze if a function is implicitly supported by the mobility protocol or
needs a further extension or support from an external protocol.

Latter point is still important, IMHO, I still think DMM should be enabled by looking
for support from other protocols outside the IP-mobility protocol space. 

>
>2) What are the main differences between the framework that you propose in
>this draft and the one proposed in: framework, like the one introduced in
>http://www.ietf.org/id/draft-chan-dmm-framework-gap-analysis-05.txt.

The main difference is that it defines DMM functional entities without being dependent
on functions of available IP mobility architecture. We discussed such framework
during last IETF and came to the conclusion that such framework is useful 
for the gap analysis and the specification of protocol extensions without being
Dependent on mobility protocols. 
 
I received some feedback to version -00 about further separation of defined
functional entities into control- and data-plane, which can help to apply the
DMM functional elements to available components of Mobile IP, Proxy Mobile
IPv6, LISP on top of a Mobile IP architecture or even an OpenFlow-based architecture
in the mobile carrier's transport network.

The draft is simply the way of communicating the approach of using these functional
elements for the analysis and the specification of protocol extensions to enable DMM.

It's not meant as further competing gap analysis draft :-) But it reflects what I could discuss
with some DMM folks and hopefully supports the discussion about DMM while tackling
the associated complexity behind this topic.

marco

>As follow up of a discussion during last IETF meeting with some of you,  we
>posted a new draft about an initial functional framework for DMM. We think
>that discussing BCP and gaps can be supported by using well defined functional
>entities (FE) and reference points to enable DMM. Different constellations of FEs
>can match architectures of existing protocols and gaps as well as strengths or
>weak points of the associated architecture/protocol can be easily identified.
>
>key models as starting point to group FEs according to the WG's current
>understanding how DMM may be solved.
>
>Any opinion about the proposed framework and approach as well as
>contributions to an updated version of this draft are appreciated.
>
>Marco
>
>--

---

From: <[email-masked]>
Date: Thu, 8 Nov 2012 15:01:36 +0000

Hi Marco,

Thanks for the answers!
I think that the draft is valuable. In particular, this draft can provide the basis for the work on gap analysis!

Best regards,
Georgios

________________________________________
Van: Marco Liebsch [[email-masked]]
Verzonden: zondag 4 november 2012 23:30
To: Karagiannis, G. (EWI); [email-masked]
Onderwerp: RE: DMM functional framework posted

Hi Georgios,

marco