Subject: [DMM] Requirements on cmm

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 16 Nov 2012 15:20:39 -0600

Hi Georgios,

Can you please suggest some requirements on cmm in DMM?

I think that it would be relevant and useful to DMM while requirements
are still being discussed.

Regards,

Behcet
On Sun, Nov 4, 2012 at 1:52 PM,  <[email-masked]> wrote:
> Hi Behcet,
>
> I would like to mention that I find this draft useful due to the following reasons.
>
> Currently, there is a trend to implement more and more functions of a mobile communication network in software, e.g., for signal and protocol processing. This enables the use of cloud computing infrastructures as processing platforms for signal and protocol processing of mobile communication networks, in particular for current (4G) and future (5G) generation cellular networks.
> This can of course only be realized if, among others, efficient mobility management solutions are supported like the ones that are in line with what DMM would like to specify.
> I think therefore, that the DMM WG could also consider the distributed mobility management support in cloud computing like architectures as a possible use case.
>
> Regarding your draft I have some comments:
> The draft mentions some limitation of the existing mobility management solutions in cloud-like architectures. However, these limitations are not clearly focussing on the requirements specified in http://www.ietf.org/id/draft-ietf-dmm-requirements-02.txt.
> I think that this will make the desciption of the limitations clearer!
> Moreover, it might also be useful to show describe these limitations by using as use as context a generic framework, like the one introduced in http://www.ietf.org/id/draft-chan-dmm-framework-gap-analysis-05.txt and/or
> http://www.ietf.org/id/draft-liebsch-dmm-framework-analysis-00.txt.
>
> Best regards,
> Georgios
>
>
>
>
> ________________________________________
> Van: [email-masked] [[email-masked]] namens Behcet Sarikaya [[email-masked]]
> Verzonden: dinsdag 23 oktober 2012 21:51
> To: [email-masked]
> Onderwerp: [DMM] New Version Notification for   draft-sarikaya-dmm-cloud-mm-00.txt
>
> Hi all,
>
> I have submitted a new draft on Mobility Management Protocols for
> Cloud-Like Architectures, for details see below.
>
> Chairs: please reserve a slot in IETF 85 session if possible.
>
> Regards,
>
> Behcet
>
> A new version of I-D, draft-sarikaya-dmm-cloud-mm-00.txt
> has been successfully submitted by Behcet Sarikaya and posted to the
> IETF repository.
>
> Filename:        draft-sarikaya-dmm-cloud-mm
> Revision:        00
> Title:           Mobility Management Protocols for Cloud-Like Architectures
> Creation date:   2012-10-15
> WG ID:           Individual Submission
> Number of pages: 11
> URL:
> http://www.ietf.org/internet-drafts/draft-sarikaya-dmm-cloud-mm-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-sarikaya-dmm-cloud-mm
> Htmlized:        http://tools.ietf.org/html/draft-sarikaya-dmm-cloud-mm-00
>
>
> Abstract:
>    Telecommunication networks are being virtualized and are moving into
>    the cloud networks.  This brings the need to redesign the mobility
>    protocols of Mobile and Proxy Mobile IPv6.  This document defines
>    mobility management protocols for virtualized networks.  Control and
>    data plane separation is achieved by separating Home Agent and Mobile
>    Access Gateway functionalities into the control and data planes.
>
>
>
>
> The IETF Secretariat
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: <[email-masked]>
Date: Sat, 17 Nov 2012 12:28:33 +0000

Hi Behcet, Hi all,

Regarding the cloud like architecture use case, the requirement that could be used for this purpose can be the following one:

"The DMM solution MAY have the ability to be applied in virtualized and/or cloud like archietctures."

Motivation:

Currently, there is a trend to implement more and more functions of a mobile communication network in software, e.g., for signal and protocol processing. This enables the use of cloud computing infrastructures as processing platforms for signal and protocol processing of mobile communication networks, in particular for current (4G) and future (5G) generation cellular networks. This can only be realized if, among others, efficient DMM solutions are supported by the cloud computing architectures.

Best regards,

Georgios

________________________________
Van: Behcet Sarikaya [[email-masked]]
Verzonden: vrijdag 16 november 2012 22:20
To: Karagiannis, G. (EWI)
Cc: [email-masked]
Onderwerp: Requirements on cmm

Hi Georgios,

Regards,

Behcet

---

From: jouni korhonen <[email-masked]>
Date: Sun, 18 Nov 2012 01:04:52 +0200

Hi,

I do not see a reason for this requirement. Give me an example how node/function virtualization would be visible e.g. at the IP mobility protocol level. Many vendors already today virtualize their elements (and call it cloud or something semantically equivalently foggy stuff) and that has not had any impact on the signaling protocols they use on the level of the infrastructure they virtualize.

- Jouni

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 19 Nov 2012 11:25:17 -0600

Hi all,

Here is the requirement I have in mind:

The DMM solution SHOULD support more than one cloud network belonging
to the same DMM domain.

Two points:

The above requirement does have protocol impact.

Second point: I also support Georgios' requirement as a base. We can
work on both and make it better.

Regards,

Behcet

On Sat, Nov 17, 2012 at 6:28 AM,  <[email-masked]> wrote:
> Hi Behcet, Hi all,
>
>
>
> Regarding the cloud like architecture use case, the requirement that could
> be used for this purpose can be the following one:
>
>
>
> Currently, there is a trend to implement more and more functions of a mobile
> communication network in software, e.g., for signal and protocol processing.
> This enables the use of cloud computing infrastructures as processing
> platforms for signal and protocol processing of mobile communication
> networks, in particular for current (4G) and future (5G) generation cellular
> networks. This can only be realized if, among others, efficient DMM
> solutions are supported by the cloud computing architectures.
>
>
>
> Best regards,
>
> Georgios
>
>> Currently, there is a trend to implement more and more functions of a
>> mobile communication network in software, e.g., for signal and protocol
>> processing. This enables the use of cloud computing infrastructures as
>> processing platforms for signal and protocol processing of mobile
>> communication networks, in particular for current (4G) and future (5G)
>> generation cellular networks.
>> This can of course only be realized if, among others, efficient mobility
>> management solutions are supported like the ones that are in line with what
>> DMM would like to specify.
>> I think therefore, that the DMM WG could also consider the distributed
>> mobility management support in cloud computing like architectures as a
>> possible use case.
>>
>> The draft mentions some limitation of the existing mobility management
>> solutions in cloud-like architectures. However, these limitations are not
>> clearly focussing on the requirements specified in
>> http://www.ietf.org/id/draft-ietf-dmm-requirements-02.txt.
>> Moreover, it might also be useful to show describe these limitations by
>> using as use as context a generic framework, like the one introduced in
>> http://www.ietf.org/id/draft-chan-dmm-framework-gap-analysis-05.txt and/or
>> Status:
>> http://datatracker.ietf.org/doc/draft-sarikaya-dmm-cloud-mm

---

From: Brian Haberman <[email-masked]>
Date: Mon, 19 Nov 2012 14:53:20 -0500

Behcet,

> The above requirement does have protocol impact.

Could you elaborate on what that impact would be?

It is unclear to me what the impact of using a cloud service would be. 
The IETF has not had to change other protocols in order to have them 
work within "the cloud".

Regards,
Brian

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 19 Nov 2012 14:41:49 -0600

Hi Brian,

On Mon, Nov 19, 2012 at 1:53 PM, Brian Haberman
<[email-masked]> wrote:
> It is unclear to me what the impact of using a cloud service would be. The
> IETF has not had to change other protocols in order to have them work within
> "the cloud".

I think it is early to say.

Cloud networks have been all Layer 2 based and because of that many
mobility issues do not surface. For example virtual machine mobility
is just change of Ethernet address and no IP layer changes are needed.

However, I think that the trend is towards Layer 3 based clouds and
also inter-cloud communication needs are increasing. For example there
are many people advocating the development of an IETF virtual machine
mobility protocol.

I think we need to look at DMM from this perspective,and see if we can
make our mobility protocols more suitable to the cloud.

That is the reason why I wrote
draft-sarikaya-dmm-cloud-mm.
With even the simplistic assumptions, my drafts shows that the cloud
does have some protocol implications on our protocols.

Regards,

Behcet

---

From: jouni korhonen <[email-masked]>
Date: Tue, 20 Nov 2012 10:09:14 +0200

Behcet,

> I think it is early to say.

I am confused. If you think it is too early to say, then how can you claim cloud has an impact? If there is something concrete you have in mind, just say it.

- Jouni

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 29 Nov 2012 14:23:40 -0600

I suggest rewording these tow requirements as follows:

Requirement 1.
"The DMM solution MAY have the ability to be applied in virtualized
architectures."

Requirement 2.

The DMM solution MAY have the ability support more than one virtual
networks in the same DMM domain.

Regards,

Behcet