Subject: [DMM] FPC version 09 - changes

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Tue, 7 Nov 2017 00:32:41 +0000

All,

**This is not a new version of FPC**  I am merely sending out the list of changes for the one sent out last week.

Version 09 is the result of work at IETF 99 and subsequent meetings.

Changes since the last version:

1.       No new features added (sorry) but just better support for

a.       indexing / access and data types

b.      use cases

c.       limiting the creativity of others, i.e. creating well known locations to extend the model

2.       Information Model

a.       Added notation to denote data types and associated attributes such as Name

                                                               i.      Shrinks document

                                                             ii.      Allows designers to understand data types, e.g. Set vs. List

b.      Settings Strategy

                                                               i.      Most properties are placed in structures noted as <Settings>

1.       Provides well known locations to place properties / extensions

2.       Allows for a deterministic search order for the Agent

3.       Used to complete or make concrete the Policies in question

c.       Full design review of the Topology tree

                                                               i.      Improved support for DPN selection information

1.       Reminder: FPC permits Agent AND/OR Client to select DPNs and even policy placement

                                                             ii.      Stronger support of Domain Concepts (which are used for slicing, dedicated cores, etc.)

d.      Policy simplified - much more like v03/v04

                                                               i.      Descriptors/Actions and Rules are largely the same

                                                             ii.      Rule-Definition is now a top level structure in Policy (it was buried in Policy)

                                                            iii.      Elimination of Policy Group

e.      Context is now Mobility-Context to be more emphatic about what it is

f.        Vports are now Configurable-Policy

                                                               i.      Reorganized to use DPN as key to speed up Client/Agent processing

                                                             ii.      Assigns Policies directly (no more Policy-Groups)

g.       Mobility-Context

                                                               i.      Allows for assignment of predefined Policy (in the policy tree) and then sub-assignment to a DPN

                                                             ii.      Dynamically built rules, e.g. those built during signaling that are unusable outside of the Mobility-Context, are embedded with DPN information

                                                            iii.      Settings at the Rule, DPN and Mobility-Context level provide a few locations for settings

3.       Messaging Model

a.       Cleaned up inconsistencies between headers and responses

b.      Reorganized based upon Information model updates

c.       Removed features no longer necessary due to other RFCs, e.g. use of PATCH frameworks eliminates needs for cloning

d.      Promoted one feature (Command bitsets) to mandatory as opposed to an optional feature (although it is an optional attribute).

4.       TODOs

a.       Clean up errors/omissions/etc

b.      Feedback from all

c.       Ensure we are good with Domains

d.      Examples, examples, examples validating the information model (they do NOT need to be in the document)

The document is much smaller.  This is due to 3a, 3c, 2a and 2d.

Lyle

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 7 Nov 2017 15:52:49 +0000

Thanks Lyle for the update.

From: dmm <[email-masked]<mailto:[email-masked]>> on behalf of "Bertz, Lyle T [CTO]" <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 6, 2017 at 4:32 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [DMM] FPC version 09 - changes

All,

b.      use cases

2.       Information Model

                                                               i.      Shrinks document

b.      Settings Strategy

g.       Mobility-Context

3.       Messaging Model

4.       TODOs

b.      Feedback from all

Lyle