Subject: [dns-dir] FW: WG Review: Audio/Video Transport Core Maintenence (avtcore)

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 12 Jan 2011 12:20:44 +0100

This is the first in a series of four messages announcing the review for
four IETF Working Groups. Note that these WGs are not completely new,
but rather the split of the current AVT (Audio/Video Transport) WG in
the RAI Area. 

Dan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
IESG Secretary
Sent: Tuesday, January 11, 2011 8:43 PM
To: [email-masked]
Subject: WG Review: Audio/Video Transport Core Maintenence (avtcore) 

A new IETF working group has been proposed in the Real-Time Applications
and Infrastructure Area.  The IESG has not made any determination as
yet.
The following draft charter was submitted, and is provided for
informational purposes only. Please send your comments to the IESG
mailing
list ([email-masked]) by Tuesday, January 18, 2011.               

Audio/Video Transport Core Maintenence (avtcore)
-------------------------------------------
Current Status: Proposed Working Group
Last modified: 2010-12-03

Chairs: TBD

Real-Time Applications and Infrastructure Area Directors:
  Gonzalo Camarillo <[email-masked]>
  Robert Sparks <[email-masked]>

Real-Time Applications and Infrastructure Area Advisor:
  Robert Sparks <[email-masked]>

Mailing Lists: TBD

Description of Working Group:

The Real-time Transport Protocol, RTP, along with its associated
profiles and payload formats provides for real-time transmission of
audio and video over unicast and multicast transports.  RTP itself has
been shepherded to Full Standard. Its associated profiles, extensions,
and payload formats are currently at various levels of standards
maturity. 

The AVTCORE working group is chartered to maintain the core RTP/RTCP
protocols and the AVP, SAVP, AVPF, and SAVPF profiles. The group will
provide architectural guidance for extending the protocols and
guidelines for their proper use. While other working groups may be
chartered to work on application-specific extensions to the protocols,
extensions that are generally applicable will be developed in AVTCORE.

The AVTCORE working group will coordinate closely with the Security Area
while working on maintenance and enhancements to the SRTP Profile.

In addition to the milestones called out below, the AVTCORE working
group's initial tasks will include completing any remaining work
identified in those drafts from the AVT working group already in IESG
Evaluation, with the exception of the Rapid Acquisition of Multicast RTP
sessions, which will complete in the AVTEXT working group.

Goals and Milestones:
Dec 2010  Submit Guideline for Choosing RTCP CNAME as Proposed Standard
Dec 2010  Submit use of AES-192 and AES-256 in Secure RTP for Proposed 
          Standard
Dec 2010  Submit Port Mapping Between Unicast and Multicast RTP Sessions

          for Proposed Standard
Dec 2010  Submit Real-Time Transport Control Protocol (RTCP) in Overlay 
          Multicast for Proposed Standard Feb 2011  Submit Monitoring
Architecture for RTP for Informational Feb 2011  Guidelines for the use
of Variable Bit Rate Audio with Secure 
          RTP as informational (or possibly BCP) Apr 2011  Submit in
band keying mechanism for SRTP draft for Proposed 
          Standard
Apr 2011  Submit Explicit Congestion Notification (ECN) for RTP over UDP

          for Proposed Standard
May 2011  RTCP indication for retransmission suppression as proposed 
          standard
Sep 2011  Encryption of Header Extensions in the Secure Real-Time 
          Transport Protocol (SRTP) for Proposed Standard

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 12 Jan 2011 15:57:51 +0100

Marshall,

Addressing all these questions seems to me valid - as the IESG will need
to make a decision at the next telechat and input is appreciated. You
may also want to read into the archives of AVT for the discussions that
led to the proposal to split the WG - as some of these questions may
have already been addressed and discussed.  

Dan

> From: Marshall Eubanks [mailto:[email-masked]] 
> Sent: Wednesday, January 12, 2011 3:54 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; IETF DNS Directorate; 
> [email-masked]; [email-masked]; YANG Doctors
> Subject: Re: [OPS-DIR] FW: WG Review: Audio/Video Transport 
> Core Maintenence (avtcore)
> 
> 
> On Jan 12, 2011, at 6:20 AM, Romascanu, Dan (Dan) wrote:
> 
> > This is the first in a series of four messages announcing 
> the review 
> > for four IETF Working Groups. Note that these WGs are not 
> completely 
> > new, but rather the split of the current AVT (Audio/Video 
> Transport) 
> > WG in the RAI Area.
> 
> Dear Dan;
> 
> In this case, what exactly is being reviewed :
> 
> The desirability of splitting AVT ?
> 
> The fault lines along which the split is being done ?
> 
> The detailed charters of each new group & the energy 
> available to do each of the pieces ?
> 
> In particular, 3 of the 4 seem like a fairly routine split of 
> AVT, while the fourth (XRBLOCK) seems like new work, and so 
> it seems to me should be evaluated differently.
> 
> Regards
> Marshall
> 
> 
> > 
> > Dan
> > 
> > 
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of IESG Secretary
> > A new IETF working group has been proposed in the Real-Time 
> > Applications and Infrastructure Area.  The IESG has not made any 
> > determination as yet.
> > Current Status: Proposed Working Group Last modified: 2010-12-03
> > 
> > Chairs: TBD
> > 
> >  Gonzalo Camarillo <[email-masked]>  Robert Sparks 
> > <[email-masked]>
> > 
> > The AVTCORE working group will coordinate closely with the Security 
> > Area while working on maintenance and enhancements to the 
> SRTP Profile.
> > 
> > Evaluation, with the exception of the Rapid Acquisition of 
> Multicast 
> > RTP sessions, which will complete in the AVTEXT working group.
> > 
> > Goals and Milestones:
> > Dec 2010  Submit Guideline for Choosing RTCP CNAME as Proposed 
> > Standard Dec 2010  Submit use of AES-192 and AES-256 in 
> Secure RTP for Proposed
> >          Standard
> > Architecture for RTP for Informational Feb 2011  Guidelines for the 
> > use of Variable Bit Rate Audio with Secure
> > Apr 2011  Submit Explicit Congestion Notification (ECN) for 
> RTP over 
> > UDP
> > 
> >          for Proposed Standard
> > _______________________________________________
> > OPS-DIR mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ops-dir
> > 
> 
>

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 12 Jan 2011 08:53:49 -0500

Dear Dan;

The detailed charters of each new group & the energy available to do each of the pieces ?

In particular, 3 of the 4 seem like a fairly routine split of AVT, while the fourth (XRBLOCK) seems
like new work, and so it seems to me should be evaluated differently.

Regards
Marshall