Subject: [dns-dir] Information on references

From: Patrik Fältström <[email-masked]>
Date: Mon, 15 Aug 2011 12:35:50 +0200

Hi,

I just notice that in the registry for DNS Resource Types you do not really have any reference section. Just a reference to "me" in this case of the URI resource record type.

Is that correct (that you do not have the definitions), or is it me that fails in my clicking - karma?

My personal view is that the list at IANA should have pointers to the actual definitions.

No, the URI spec was not done via the RFC process, but the faster(?) review on the IETF dnsext mailing list etc.

   Patrik

Begin forwarded message:

> From: Mykyta Yevstifeyev <[email-masked]>
> Date: 13 augusti 2011 12.53.47 CEST
> To: "Patrik Faltstrom (pfaltstr)" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [dnsext] RFC 6195, IANA and HINFO DNS RRs
> 
> 13.08.2011 13:48, Patrik Faltstrom (pfaltstr) wrote:
>> On 13 aug 2011, at 12:27, "Jim Reid"<[email-masked]>  wrote:
>> 
>>> Don't bother. HINFO is essentially dead. Pretty much nothing uses it. I doubt any software queries for HINFO records. Few zones, if any, publish them.
>> Instead, if new such things really are needed, use more modern mechanisms like NAPTR or URI rr types
> 
> Patrik,
> 
> I guess you refer to URI RR, which is registered as follows:
> 
>> URI          256 URI                                        [Faltstrom]
> 
> So you are indeed a right person to ask: where can I find the documentation for this RR?
> 
> Mykyta
> 
>> (together with definition of the service you are after).
>> 
>>    Patrik
>> 
>> 
> 
> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext

---

From: Thomas Narten <[email-masked]>
Date: Mon, 15 Aug 2011 08:21:12 -0400

> I just notice that in the registry for DNS Resource Types you do not
>  really have any reference section. Just a reference to "me" in this
>  case of the URI resource record type.

Most of RFCs, as they should..

>  that fails in my clicking - karma?

What is a better reference to insert here? IANA is always willing to
put in a proper reference... if it has one.

Most likely, IANA wasn't given a reference to point to when the expert
approved the assignment.

Thomas

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 15 Aug 2011 15:02:11 +0200

> put in a proper reference... if it has one.

The problem is that there is a "template" that is to be filled out by the applicant (in this case me). That is vetted on the mailing list, and finally approved.

> Most likely, IANA wasn't given a reference to point to when the expert

I think the problem might then be that the vetted and approved template, as it is not an RFC, is not in the IETF a stable document. And because of that IANA has nothing to reference.

I suggest IANA in this case should have a repository with "whatever document they where sent" when the approval was made. As a kitchen sink. Then reference that in parallel with the references that they have already now.

I.e. in this specific case, I must say I thought IANA did have the vetted and approved template for the RR Type on the IANA website. But then I understand the reason why IANA does not have it might be because we (IETF) has not asked IANA to store it (things that are basis for parameter allocations that are not RFCs).

   Patrik