Subject: Re: [dns-dir] draft-liman-tld-names-05, advice sought

From: Patrik Fältström <[email-masked]>
Date: Mon, 5 Sep 2011 12:09:55 -0400

On 11 aug 2011, at 15:52, Andrew Sullivan wrote:

> I think the document should be pursued, and I think it should go on as
> it currently does, on the quite correct grounds that whatever happens,
> it is always possible to open the door wider later.

One for me very big argument to have the limitation we have in the draft (yes, I did write the paragraph in question and submitted it to the authors) is:

1. I think it is GOOD to be conservative for at least one label in a domain name. The TLDs is the only one we can control

2. We do know for example _ and other non-hostnames will exists in many other labels than the TLDs

3. We can, as Andrew say, always open it up later if we really want to

4. For ICANN it is a good thing to lean against a strict(er) rule that IETF comes up with for _technical_ reasons

5. [together with 1] I do like the fact that the approval of code points that can be in something like the TLD is black and white and can be found with for example a lookup in a table.(*)

6. One might be able to say that "technically we can allow anything, because the *registry policy* can and should limit the characters possible in the labels, but...in this very case I think that is simply not really possible

7. Having a sensible *technical* discussion is very very hard as the people that really do know the details of those (weird) characters often are the same people that have inherently large interest to get them approved. I.e. the discussion of whether they should be included is based on a personal wish that they are included. And if the goal is to have them included, well, the discussion will not stop before they are.

   Patrik

(*) People that have followed the development of IDNA2008 do know that some code points that are specifically tricky are context dependent. Specifically is this true for the join control characters (i.e. whitespace that do not take any space at all).

---

From: Joe Abley <[email-masked]>
Date: Mon, 12 Sep 2011 08:01:54 -0700

Hi all,

Following up -- does the DNS Directorate have any guidance for the authors on how to proceed?

I've seen support from Andrew and Patrik, but otherwise just crickets.

If there's no desire to provide guidance, then it would be good at least to hear that.

Joe

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 29 Sep 2011 10:14:41 +0300

Let me expand a bit by adding Pete Resnick to the bunch of people that I think should say something here.

There is a similar discussion going on regarding risk for false positives when talking about IDN versions of TLDs which I think is spilling over to this.

And Pete is active in that discussion.

   Patrik

On 12 sep 2011, at 18:01, Joe Abley wrote:

> _______________________________________________
> dns-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-dir