Subject: Re: [dns-dir] Question about draft-cheshire-dnsext-special-names

From: Ralph Droms <[email-masked]>
Date: Sat, 10 Mar 2012 09:56:45 -0500

After thinking about this issue a little more, I recommend the last sentence be struck from the quoted text and IANA continue to respond to queries to the example names.  We don't want to encourage any dependence on NXDOMAIN behavior relative to the example names.

- Ralph

On Mar 10, 2012, at 8:10 AM 3/10/12, Ralph Droms wrote:

> IANA has a question about this text from section 5.5 or draft-cheshire-dnsext-special-names:
> 
>   1. Users SHOULD understand that example names are for use in
>      documentation only and SHOULD NOT be expected to work with actual
>      software on actual networks. Users SHOULD assume that queries for
>      example names will always return NXDOMAIN responses.
> 
> IANA currently arranges for a web page describing the example domains to be returned in response to queries to, e.g., www.example.com.  Therefore, at present, a query to www.example.com never returns NXDOMAIN; this means the last sentence quoted above, while technically not wrong, is at least pointless if not misleading.
> 
> So, should we:
> 
> a) ask IANA to stop responding to queries to the example domains; or,
> b) strike that last sentence from the document?
> 
> - Ralph
>

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 10 Mar 2012 10:23:58 -0600

I think that is the correct thing.

   Patrik

On 10 mar 2012, at 08:56, Ralph Droms wrote:

> _______________________________________________
> dns-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-dir
>

---

From: Peter Koch <[email-masked]>
Date: Sat, 10 Mar 2012 22:50:36 +0100

> After thinking about this issue a little more, I recommend the last sentence be struck from the quoted text and IANA continue to respond to queries to the example names.  We don't want to encourage…

Heavens, what is the status of this document?

-Peter

---

From: Ralph Droms <[email-masked]>
Date: Sat, 10 Mar 2012 17:14:48 -0500

> Heavens, what is the status of this document?

It has been through IETF last call and has been reviewed by the IESG.  There is one outstanding Discuss, which is a placeholder for a couple of IANA issues.

- Ralph