Subject: [dns-dir] Quick opinion on draft-rafiee-cga-tsig-00.txt

From: Ralph Droms <[email-masked]>
Date: Fri, 9 Nov 2012 10:20:06 -0500

I'd very much like to get someone's quick opinion on draft-rafiee-cga-tsig-00.txt: is it of any potential interest or not?  The author is new to the IETF and would like some assistance.  I'm trying to figure out whether and how she should be encouraged.

It's 10:15AM now; if someone could get back to me in an hour or so, I'd appreciate it. I'd like to give Hosnieh a face-to-face response before we leave Atlanta.

Finally, if you think it is of potential interest, would you be willing to mentor Hosnieh in progressing her document?

Thanks and I apologize for the short fuse...

- Ralph

---

From: Olafur Gudmundsson <[email-masked]>
Date: Fri, 09 Nov 2012 10:32:26 -0500

I talked to her last night and told her that what she is proposing is 
equivalent to client assigned key via TKEY
and asked why she does not want to use TKEY, as that will not require 
any changes on the server side.

Second question I asked is what is the usage case as the only update 
that could be authorized using this mechanism is the
reverse tree name associated with the address, the author seems to think 
that entries in the forward tree can be
updated.

In short the document needs
     to justify why TKEY is not used at all
    what is the usage case
     what can be authorized to be updated by the TSIG key configured.

Olafur

On 09/11/2012 10:20, Ralph Droms wrote:
> _______________________________________________
> dns-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-dir

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 9 Nov 2012 10:33:56 -0500

> I'd very much like to get someone's quick opinion on draft-rafiee-cga-tsig-00.txt: is it of any potential interest or not?  The author is new to the IETF and would like some assistance.  I'm trying…

She should be encouraged, I'm not actually sure that the proposal as
it stands is worth pursuing, but the basic ideas contain some building
blocks for possibly useful work.

Also, I'm not sure how we could have given her any more
encouragement.  I have actively sought her out, introduced her to
several people, and managed to get some feedback already to her.

DNSEXT, which was formerly the natural home for this, is not willing
to take it on just because we decided to shut down and are trying to
do that.  If the AD thinks that's an error, I'm willing to reconsider,
but we've been pretty bossy about it so far.

Moreover, I think she should be encouraged in general.  She's serious
and keen to do work.  I think that's _always_ a newcomer we want to
encourage!  In general, she's interested in security matters, and I'm
attemptint to identify things she might want to review.  I have reason
to suppose she's looking for work, also, so if anyone knows the sort
of junior protocol & security position appropriate to newly minted
degrees, it wouldn't hurt to tell her about it.  For those who don't
know, she's currently in Germany, so USian positions could be tricky.

> Finally, if you think it is of potential interest, would you be willing to mentor Hosnieh in progressing her document?

I've already been trying to do that, though I'd be happy for help.

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Ralph Droms <[email-masked]>
Date: Fri, 9 Nov 2012 10:38:03 -0500

> blocks for possibly useful work.

OK, thanks for that review.

> but we've been pretty bossy about it so far.

Nope, I'm not supporting anything new coming into the dnsext queue.

> I've already been trying to do that, though I'd be happy for help.

Excellent and thanks.  Do you mind if I suggest that she continue the conversation with you?

I imagine she may be not understanding the IETF process.  I'll try to find a few minutes to give her some additional insight.

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Fri, 9 Nov 2012 10:38:20 -0500

On Nov 9, 2012, at 10:32 AM 11/9/12, Olafur Gudmundsson wrote:

> 
> I talked to her last night and told her that what she is proposing is equivalent to client assigned key via TKEY
> and asked why she does not want to use TKEY, as that will not require any changes on the server side.
> 
> Second question I asked is what is the usage case as the only update that could be authorized using this mechanism is the
> reverse tree name associated with the address, the author seems to think that entries in the forward tree can be
> updated.
> 

Thanks, Olafur.

- Ralph

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 9 Nov 2012 10:42:11 -0500

> Excellent and thanks.  Do you mind if I suggest that she continue the conversation with you?

No, of course not.  I've tried in fact to encourage her to do that.

> I imagine she may be not understanding the IETF process.  I'll try to find a few minutes to give her some additional insight.

Yeah, emphasising how things work around here would be helpful.
Guiding her in how to get work done here has been tricky.  I've
pointed her at the Tao more than once, but I'm not totally sure she's
absorbed it.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Brian Haberman <[email-masked]>
Date: Fri, 09 Nov 2012 12:20:29 -0500

Hi Andrew,

> pointed her at the Tao more than once, but I'm not totally sure she's

I can confirm that she is struggling with the IETF process and that is 
probably causing most of her angst.  I appreciate you being willing to 
help her out.  Let me know if there is anything I can do to help.

Regards,
Brian