Subject: [dns-dir] Review requested : draft-ietf-geopriv-res-gw-lis-discovery

From: Brian Haberman <[email-masked]>
Date: Fri, 23 Aug 2013 10:21:11 -0400

All,
      Has anyone here reviewed this GEOPRIV document?

https://datatracker.ietf.org/doc/draft-ietf-geopriv-res-gw-lis-discovery/

While it has all sorts of caveats on possible issues with this use case 
for DNS, I would like to have it sanity-checked by a couple of DNS experts.

Volunteers?

Regards,
Brian

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 26 Aug 2013 12:43:04 +0200

On 23 aug 2013, at 16:21, Brian Haberman <[email-masked]> wrote:

> While it has all sorts of caveats on possible issues with this use case for DNS, I would like to have it sanity-checked by a couple of DNS experts.
> 
> Volunteers?

I have checked this document and it is kind of,...ok, "works" but I think there are a number of weaknesses:

1. It is very important DHCP method is used first (as is pointed out).

2. If DHCP is not populated, why would DNS be? Because DHCP is not available maybe?

3. Use of NAPTR with selector inside the RDATA is something I do not like...if they know the selector, I rather see use of URI resource record where one can query for the prefixed URI directly (but people do not know URI resource record exists).

4. For telephony "stuff" they already use NAPTR for all different kind of weird stuff, so they should possibly continue to use NAPTR.

5. It is important these records are signed with DNSSEC.

6. I am nervous over the privacy aspects, and any try to tie IP address to geo location is either wrong or interested to be used by the wrong parties or both...but I understand this might be needed in this case.

7. I still think DHCP is much better, to query in a L2 broadcast method for "the closest 'thing'", can not mdns be used instead ;-)

So, no errors per se...

   Patrik