Subject: Re: [dns-dir] Draft requesting reservation of special-use domain names

From: Ralph Droms <[email-masked]>
Date: Mon, 2 Dec 2013 14:42:01 -0500

On Nov 27, 2013, at 2:10 PM 11/27/13, Erik Nordmark <[email-masked]> wrote:

> On 11/27/13 9:29 AM, Olaf Kolkman wrote:
> 
>>> Thus from my reading of appendix G its status is quite clear. It
>>> doesn't say anything about future use of the suggested intranet labels.
>> 
>> 
>> But people who are not IETF close readers might have interpreted this
>> paragraph as being normative and an indication of ‘safe to use’.
> 
> Olaf,
> 
> I can see how a statement along the lines of
> 	don't use "localhost" - folks seem to be using "X" instead
> can be read as an endorsement of X as opposed to X being less bad than localhost.
> 
> Anyhow ...
> 
>> In any case the question is whether we should clarify. If we do we can
>> go two ways:
>> 1 Using these labels: your own dumb fault, you should have know better
>> 2 These labels are reserved for private use, because we have been
>> confusing, and because of wide public use suggested by various forms of
>> documentation. The will be banned for delegation from the root: beware
>> of collisions and undefined behavior.
>> 
>> I’d opt for writing such document and I’d opt for version 2.
> 
> In light of new gTLDs it does make sense to produce a clarification, and #2 makes sense to me.
> 
> Question is whether that document will be strictly limited to the names listed in RFC 6762 or open up the door to consider other names.

In my opinion, the list in RFC 6762 is strictly ad hoc, advisory and not necessarily backed up with data.

I think it's a good idea to submit a list of labels to be marked as "special use" and not delegated because they have been shown to be in widespread (hijacked) use and therefore likely to be problematic if delegated.  That list might or might not intersect the list in RFC 6762.

- Ralph

> 
>   Erik
> 
> 
> _______________________________________________
> dns-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-dir

---

From: Ralph Droms <[email-masked]>
Date: Mon, 2 Dec 2013 14:46:52 -0500

On Nov 28, 2013, at 5:45 AM 11/28/13, Patrik Fältström <[email-masked]> wrote:

> 
> On 28 nov 2013, at 10:46, Olaf Kolkman <[email-masked]> wrote:
> 
>> On 28 nov. 2013, at 01:57, Ralph Droms <[email-masked]> wrote:
>> 
>>> Is there some reason to think those names might be delegated from the root?  My understanding is that the review process for name delegation would identify such names as "not to be delegated" if there is significant use now, otherwise, they are safe to delegate. 
>> 
>> At this moment .corp and .home are ‘on-hold’ (indefinitely?).
>> 
>> There is also an SSAC recommendation to have some of these strings permanently reserved, and SSAC is looking towards the IETF (correct Patrik?)
> 
> A few details here:
> 
> 1. SSAC do not say exactly what strings are "high risk". .HOME and .CORP can be viewed as "easy", but what about ".MAIL" etc?

OK.  Presumably SSAC has data on which it has based its classification of the various strings?

> 
> 2. SSAC do say that "not delegate" is not enough, we do believe some strings should explicitly be for "private use". Which matches quite well what 6762 says.

OK.
> 
> 3. SSAC could have directly pointed at the Appendix G, if it was clear that that was normative, and so could ICANN. But what I heard from at least one person cc:ed is that that is _not_ normative.
> 
> Question: Can IESG/IAB make a decision on the appendix "due to widespread use, misunderstanding and unclear situations etc etc we do believe those strings should not be allocated as TLDs"?

I think it would be better to generate a list based on the data from SSAC.  The list in Appendix G could be used, but I don't know if the evidence supporting the strings on that list is sufficient to mark them as "special use".

> 
> Can IESG/IAB even say yes/no to such a question without an appeal?

I don't think an appeal would be needed.
> 
> Is an I-D and RFC needed that clarifies status of Appendix G?

An RFC is probably the right vehicle to make the designation.  That RFC doesn't need to be restricted to just the list in Appendix G.

> 
> I.e. I think some IETF action is needed. Having ICANN do "too much" instead of referring to IETF -- specifically if we go down the path of "defining some strings to be TLDs for private use" -- would be dangerous.
> 
> I think personally IETF is the body that should say not only what subset of IP address space RIRs can allocate things out of but also what subset of the available bitstring space ICANN can use. Which IETF has done with "hostname" definition (cough, cough,...) and IDN2008.
> 
> So, $10.000 question: What is the path forward for "allocation of some strings for private use"?
> 
> Do IETF need a formal question from ICANN? Would that really help?

Would it be useful to have a teleconf with the appropriate people from ICANN towork through the details?  I don't fully understand what ICANN is trying to achieve.

- Ralph
>   Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 2 Dec 2013 21:11:12 +0100

> Would it be useful to have a teleconf with the appropriate people from ICANN towork through the details?  I don't fully understand what ICANN is trying to achieve.

ICANN tries to understand whether they should say "no" to some applicants that have applied for strings that IETF, SSAC and others in the "technical community" (note the quotes) think should not be delegated.

My guess is that law suits will come, and the question is who they will target.

Note, for example, that .HOME was already in http://tools.ietf.org/html/draft-cheshire-dnsext-multicastdns-02 from June 2003, and still did not end up on the "prohibited for applications" in the ICANN Applicant Guide Book, a list that was created with input from the IETF.

Was that a mistake?

By whom?

Regarding data that you ask for, SSAC do not per se have data. We have access to the same report as everyone have, created by Lyman and gang at Interisle spring of 2013 that is based on the DITL data.

   Patrik

---

From: Brian Haberman <[email-masked]>
Date: Mon, 02 Dec 2013 18:09:23 -0500

Just to level set...

On 12/2/13 2:46 PM, Ralph Droms wrote:
>>>> Is there some reason to think those names might be delegated
>>>> from the root?  My understanding is that the review process for
>>>> name delegation would identify such names as "not to be
>>>> delegated" if there is significant use now, otherwise, they are
>>>> safe to delegate.
>>> 
>>> There is also an SSAC recommendation to have some of these
>>> strings permanently reserved, and SSAC is looking towards the
>>> IETF (correct Patrik?)
>> 
>> A few details here:
>> 
>> 1. SSAC do not say exactly what strings are "high risk". .HOME and
>> .CORP can be viewed as "easy", but what about ".MAIL" etc?
> 
>> 2. SSAC do say that "not delegate" is not enough, we do believe
>> some strings should explicitly be for "private use". Which matches
>> quite well what 6762 says.
> 
> OK.
>> 
>> 3. SSAC could have directly pointed at the Appendix G, if it was
>> clear that that was normative, and so could ICANN. But what I heard
>> from at least one person cc:ed is that that is _not_ normative.
>> 
>> Question: Can IESG/IAB make a decision on the appendix "due to
>> widespread use, misunderstanding and unclear situations etc etc we
>> do believe those strings should not be allocated as TLDs"?

Normally, an appendix is not normative unless it explicitly states that
it is so or contains a critical component of the RFC.  I think the use
of an appendix in this case is confusing and unwarranted.

The INT ADs can take an action item to address this issue as a part of
the special-use domain name question.

> 
> I think it would be better to generate a list based on the data from
> SSAC.  The list in Appendix G could be used, but I don't know if the
> evidence supporting the strings on that list is sufficient to mark
> them as "special use".
> 

I would be very interested in seeing a list from SSAC.

> An RFC is probably the right vehicle to make the designation.  That
> RFC doesn't need to be restricted to just the list in Appendix G.
> 

Correct, but that RFC may want to be tied to 6762 in some way (e.g.,
Updates).

>> 
>> I.e. I think some IETF action is needed. Having ICANN do "too much"
>> instead of referring to IETF -- specifically if we go down the path
>> of "defining some strings to be TLDs for private use" -- would be
>> dangerous.
>> 
>> I think personally IETF is the body that should say not only what
>> subset of IP address space RIRs can allocate things out of but also
>> what subset of the available bitstring space ICANN can use. Which
>> IETF has done with "hostname" definition (cough, cough,...) and
>> IDN2008.
>> 
> Would it be useful to have a teleconf with the appropriate people
> from ICANN towork through the details?  I don't fully understand what
> ICANN is trying to achieve.

Ted is in the process of discussing with the IAB how to liaise with
ICANN on this issue.

Regards,
Brian

---

From: Ralph Droms <[email-masked]>
Date: Mon, 2 Dec 2013 22:02:05 -0500

> of an appendix in this case is confusing and unwarranted.

By "use of an appendix", do you mean citing the appendix as support for marking the strings in the list as "do not delegate"?
> the special-use domain name question.

Is there more to the "special-use domain name question" than that list of strings?
> I would be very interested in seeing a list from SSAC.

Is the data from Interisle publicly available?

> Correct, but that RFC may want to be tied to 6762 in some way (e.g.,

Why would it update the RFC 6762?  Appendix G is non-normative.  Perhaps a note clarifying that Appendix 6762 is, indeed, non-normative and only advisory?

OK.

- Ralph

---

From: Brian Haberman <[email-masked]>
Date: Tue, 03 Dec 2013 07:53:44 -0500

On 12/2/13 10:02 PM, Ralph Droms wrote:
>>>>>> Is there some reason to think those names might be
>>>>>> delegated from the root?  My understanding is that the
>>>>>> review process for name delegation would identify such
>>>>>> names as "not to be delegated" if there is significant use
>>>>>> now, otherwise, they are safe to delegate.
>>>>> 
>>>>> strings permanently reserved, and SSAC is looking towards
>>>>> the IETF (correct Patrik?)
>>>> 
>>>> A few details here:
>>>> 
>>>> 1. SSAC do not say exactly what strings are "high risk". .HOME
>>>> and .CORP can be viewed as "easy", but what about ".MAIL" etc?
>>> 
>>>> 2. SSAC do say that "not delegate" is not enough, we do
>>>> believe some strings should explicitly be for "private use".
>>>> Which matches quite well what 6762 says.
>>> 
>>> OK.
>>>> 
>>>> 3. SSAC could have directly pointed at the Appendix G, if it
>>>> was clear that that was normative, and so could ICANN. But what
>>>> I heard from at least one person cc:ed is that that is _not_
>>>> normative.
>>>> 
>>>> widespread use, misunderstanding and unclear situations etc etc
>>>> we do believe those strings should not be allocated as TLDs"?
>> 
>> Normally, an appendix is not normative unless it explicitly states
>> that it is so or contains a critical component of the RFC.  I think
>> the use of an appendix in this case is confusing and unwarranted.
> 
> By "use of an appendix", do you mean citing the appendix as support
> for marking the strings in the list as "do not delegate"?

Correct.  To me, it seems like Appendix G is simply saying "don't
overload .local, but you may be able to use these strings for private
use".  Since there is no explicit statement that those suggested strings
should not be delegated, I don't see how the appendix could be viewed as
giving ICANN any direction.

>> 
>> The INT ADs can take an action item to address this issue as a part
>> of the special-use domain name question.
> 

Sure.  It seems that we need to figure out how we are going to
coordinate this request and any future requests with ICANN.

>> 
>> 
>>> 
>>> I think it would be better to generate a list based on the data
>>> from SSAC.  The list in Appendix G could be used, but I don't
>>> know if the evidence supporting the strings on that list is
>>> sufficient to mark them as "special use".
>>> 
>> 

I don't know.

>>> An RFC is probably the right vehicle to make the designation.
>>> That RFC doesn't need to be restricted to just the list in
>>> Appendix G.
>>> 
>> 
>> Correct, but that RFC may want to be tied to 6762 in some way
>> (e.g., Updates).
> 
> Why would it update the RFC 6762?  Appendix G is non-normative.
> Perhaps a note clarifying that Appendix 6762 is, indeed,
> non-normative and only advisory?
> 

Given that a few people are questioning the state of Appendix G, I could
see one way of clarifying that would be a short RFC that says the
appendix is advisory only.  To make sure future readers of 6762 see that
statement, an "Updates" tag would be useful.

>> 
>>>> 
>>>> I.e. I think some IETF action is needed. Having ICANN do "too
>>>> much" instead of referring to IETF -- specifically if we go
>>>> down the path of "defining some strings to be TLDs for private
>>>> use" -- would be dangerous.
>>>> 
>>>> I think personally IETF is the body that should say not only
>>>> what subset of IP address space RIRs can allocate things out of
>>>> but also what subset of the available bitstring space ICANN can
>>>> use. Which IETF has done with "hostname" definition (cough,
>>>> cough,...) and IDN2008.
>>>> 
>>> Would it be useful to have a teleconf with the appropriate
>>> people from ICANN towork through the details?  I don't fully
>>> understand what ICANN is trying to achieve.
>> 
>> Ted is in the process of discussing with the IAB how to liaise
>> with ICANN on this issue.
> 
> OK.

And we will see how that goes.

Brian

---

From: Ralph Droms <[email-masked]>
Date: Tue, 3 Dec 2013 10:11:21 -0500

> giving ICANN any direction.

I agree.  Nor does it give IETF any direction for designating those strings as "special use".

> coordinate this request and any future requests with ICANN.

OK, so we need to figure out the process - e.g., identifying some more strings to be designated as special use, publishing an RFC to request that designation in accordance with RFC 6761, (perhaps) updating RFC 6762 in that RFC - and document it for future re-use.

> statement, an "Updates" tag would be useful.

Agreed - a clarifying, informal update would be helpful.

> And we will see how that goes.

Let me know if I can help in any way...

- Ralph

---

From: Olafur Gudmundsson <[email-masked]>
Date: Tue, 3 Dec 2013 11:01:28 -0500

+1 
I can help writing something as well. 

	Olafur

---

From: Ralph Droms <[email-masked]>
Date: Fri, 13 Dec 2013 10:00:34 -0500

Lyman Chapin has written a draft requesting marking of the following labels in the "Special-Use Domain Names" registry.  I've attached a copy.  

Seems to me this document is a good start toward the RFC we discussed in this thread.  There are two details to discuss:

* .local is already in the registry, so I don't think Lyman's document needs to request that it be added; might want replace the request with text in section 3 acknowledging the existence of .local in the registry
* .home may be requested for a different special use by the homenet WG; I think the right thing to do is go ahead with reservation as "do not delegate" in this document and the homenet WG can update that status with a future document if needed

- Ralph

---

From: Ted Lemon <[email-masked]>
Date: Fri, 13 Dec 2013 10:15:37 -0500

Maybe Lyman should bring this up on dnsop?   It seems relevant to the discussion going on there.

---

From: Ralph Droms <[email-masked]>
Date: Fri, 13 Dec 2013 10:21:09 -0500

I thought we might want to discuss it here, first, based on the previous discussion about generating just such a document.

- Ralph

---

From: Ted Lemon <[email-masked]>
Date: Wed, 18 Dec 2013 13:41:02 -0500

On Dec 18, 2013, at 1:39 PM, Andrew Sullivan <[email-masked]> wrote:
> Can we take this to dnsop?

Yes, please.

---

From: Ralph Droms <[email-masked]>
Date: Wed, 18 Dec 2013 16:52:19 -0500

>> Can we take this to dnsop?

OK with me.  Lyman?

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Wed, 18 Dec 2013 16:56:31 -0500

On Dec 18, 2013, at 1:39 PM 12/18/13, Andrew Sullivan <[email-masked]> wrote:

> I've just had a request relayed to me from ICANN staff that this
> document please proceed.  They want .home and .corp, I believe, to
> start with.  There may be more.

The document lists several others.  Does ICANN want to reduce the list to just .home and .corp for now?

homenet WG may want a specific use for .home, as opposed to just "do not delegate because it's already widely (mis)used".  If so, there are at least two ways to proceed:

1) go ahead and request .home be marked "do not delegate" and let homenet request remarking later
2) wait for homenet to decide about marking .home before proceeding

As most of you know, the dnssd WG decided not to make any requests for special use TLDs at this point in time.

- Ralph

>  It seems to me it'd be easier to
> start with the ones we know, because if we get the issues hammered out
> for one list, adding another list will be a trivial second document.
> 
> A
> On Fri, Dec 13, 2013 at 10:21:09AM -0500, Ralph Droms wrote:
> -- 
> Andrew Sullivan
> [email-masked]

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 18 Dec 2013 13:39:21 -0500

start with.  There may be more.  It seems to me it'd be easier to

A

-- 
Andrew Sullivan
[email-masked]

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 18 Dec 2013 17:01:26 -0500

> The document lists several others.  Does ICANN want to reduce the list to just .home and .corp for now?

No idea, but I'd prefer an ICANN staff member to comment, ideally on a
list somewhere.  I think he had in mind that there _are_ more, but
wasn't sure which.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Lyman Chapin <[email-masked]>
Date: Wed, 18 Dec 2013 17:35:39 -0500

> list somewhere.  I think he had in mind that there _are_ more, but

Hi Andrew, sorry to be late to the discussion. Mark and I came up with the list of names in the draft based on the SSAC advisories (SAC 045 and SAC 062) and Interisle's name collision occurrence study. I think it would be unwise (to say the least) to recognize any advice from ICANN about which names should or should not be on that list, given their responsibility for the new gTLD program.

Mark is cleaning up the references, but except for that, the attached v8 is ready to go to dnsop -

- Lyman

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 20 Dec 2013 19:05:14 +0100

> The document lists several others.  Does ICANN want to reduce the list to just .home and .corp for now?

They very carefully want IETF to decide what should be there... :-P

   Patrik