Subject: [dnsext] any interest to move bname forward before dnsext closing down

From: "Jiankang YAO" <[email-masked]>
Date: Fri, 13 Jan 2012 09:18:12 +0800

Dear all,

  cname maps himself. dname maps his children. bname maps both himself and his children.
  I suggest bname as a general tool to map both himself and his children, not aiming at solving idn alias problem. IDN users may or may not choose it to solve their problem.
  I think that bname is a useful tool to map domain A to domain B.

  Is there any interest to move bname forward before dnsext closing down

Jiankang Yao

---

From: Olafur Gudmundsson <[email-masked]>
Date: Fri, 13 Jan 2012 10:33:58 -0500

On 14:59, Andrew Sullivan wrote:
> Dear colleagues,
>
> On Fri, Jan 13, 2012 at 09:18:12AM +0800, Jiankang YAO wrote:
>>
> Regardless of the interest, we can't do it in this working group.  Our
> charter said we would complete the study of aliasing before doing
> that, and we haven't completed it.

This is not true, our charter does not say that, our policy was to wait 
for aliasing study before proceeding.
We can at any time change our policy, if the WG ask us to do that.

> Even if we ignored that, our AD
> asked us to be ready to shut down in the spring, and there is zero
> hope that BNAME could be ready for publication by then, since it would
> be necessary to figure out how to make BNAME deployable given the fact
> of deployed DNSSEC and existing validators on the net (the draft as it
> stood at expiration had no answer for this -- it effectively said that
> all the DNSSEC infrastructure on the Internet had to be upgraded
> first).

This is true but to tone is more negative than I like so here is  reword:
Even if the WG decided to take up this work today, considering that we 
are closing down in about 3 months there is little chance that we can 
finalize the protocol spec and do interop testing in order to be able to 
advance this work. The reason we need interop testing is that this work 
requires most DNS resolvers and servers to be updated before
BNAME is useful on its own. We also need to make sure there are no
negative side effects of the deployment hacks to support early BNAME
deployment.

> Unless I missed it, I've never seen a suggestion on how that
> could be solved apart from "online signing", which doesn't seem to me
> to be a real answer.
>

Drop the above, too inflammatory.

> If there were a clear and careful needs analysis (and I believe the
> case could be made without talking about IDN -- website redirection is
> another example), and there were evidence of work being done, I'd

s/I'd/chairs can/

> argue to the AD that the WG was still labouring over this topic and

s/labouring/laboring/

> that it would complete the work.  But in fact, the aliasing
> requirements draft expired, and very little discussion of it took
> place prior to that expiry.

 >  I conclude that there may be interest in
> that work, but not in this working group, so we should stop pretending
> we're going to work on it.
>

Replace by:
We do not see much evidence of interest in this work in the WG,
unless there is interest there is no reason to make commitment to work
on this protocol extension.

	Olafur & Andrew

> Best regards,
> Andrew

---

From: Olafur Gudmundsson <[email-masked]>
Date: Fri, 13 Jan 2012 10:47:03 -0500

Sorry I sent this to the mailing list instead of to andrew.
Please ignore once, andrew and I agree on a statement we will post
an official answer.

This is totally my mistake.

	Olafur

On 13/01/2012 10:33, Olafur Gudmundsson wrote:
> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext
>
>
>

---

From: Eric Brunner-Williams <[email-masked]>
Date: Fri, 13 Jan 2012 11:40:41 -0500

I'm of the same view now as I was previously.

A general means to map X to Y is useful.

The aliasing issue is either orthogonal, or consumer domain specific.
In either case, it is not necessary, though it was by it self,
sufficient to motivate a nominally similar attempt.

So I am willing to work on bname.

Eric

---

From: Mark Andrews <[email-masked]>
Date: Sat, 14 Jan 2012 09:33:28 +1100

In message <[email-masked]>, Eric Brunner-Williams write
> So I am willing to work on bname.

As am I.
 
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Warren Kumari <[email-masked]>
Date: Fri, 13 Jan 2012 20:54:23 -0500

>> So I am willing to work on bname.

Hey! Me too!

W

---
Don't be impressed with unintelligible stuff said condescendingly .
    -- Radia Perlman.

Warren Kumari
[email-masked]

---

From: "Vaggelis Segredakis" <[email-masked]>
Date: Wed, 18 Jan 2012 12:52:20 +0200

Hi,

I am interested as well in this proposal. Happy to work for it.

Kind Regards,

Vaggelis Segredakis

-----------------------------------------------------------------------
Administrator of the .GR Top Level Domain
Institute of Computer Science
Foundation for Research and Technology - Hellas
Tel. +30-281-0391450
Fax +30-281-0391451
Email [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Warren Kumari
Sent: Saturday, January 14, 2012 3:54 AM
To: Mark Andrews
Cc: [email-masked]
Subject: Re: [dnsext] any interest to move bname forward before dnsext
closing down

Hey! Me too!

W

---

Warren Kumari
[email-masked]