Subject: Re: [dnsext] draft-ietf-dnsext-dnssec-algo-imp-status-01

From: RJ Atkinson <[email-masked]>
Date: Mon, 26 Mar 2012 18:29:20 -0400

On Monday, 26th March 2012, Scott Rose wrote, in part:
> If the group thinks any of the assigned implementation status
> for entries should be changed - please state so.
> 
> Personally, I'm thinking ECDSA might be moved to "Recommended..."
> since there are some advantages, but willing to leave it as is.

All,

I support the idea of moving ECDSA to "Recommended".

Most of us are likely to end up deploying ECDSA eventually,
we might as well encourage folks to support it sooner
rather than later.  An earlier start to implementation
enables earlier widespread interoperability, which in 
turn enables widespread deployment.  These things all
take time.  There is no value in delay.

* The financial sector already seems to be migrating 
  from RSA to EC for a wide range of things.  

* Separately, the published literature indicates that 
  MUCH shorter EC keys have strength equivalent to 
  MUCH longer RSA keys, so EC appears to scale better.[1][2]
  For example, [2] indicates that an ECC key size of
  163 bits has strength equivalent to an RSA key size
  of 1024 bits.

* Published literature also indicates that EC is less
  computationally expensive than RSA for equivalent-strength
  key sizes.  So EC is better for systems with smaller CPUs
  or that need to perform higher volumes of transactions.[3]

Yours,

Ran

REFERENCES:

[1] K. Lauter, "The Advantages of Elliptic Curve Cryptography for
    Wireless Security", IEEE Wireless Communications, Volume 11,
    Issue 1, IEEE, Piscataway, NJ, USA, February 2004.

[2] V. Gupta, et alia, "Performance Analysis of Elliptic Curve
    Cryptography for SSL", Proceedings of 1st ACM Workshop on
    Wireless Security, ACM, Atlanta, GA, September 2002.

[3] Nils Gura, et alia, "Comparing Elliptical Curve Cryptography
    and RSA on 8-bit CPUs", Proceedings of 6th International Workshop
    on Cryptographic Hardware and Embedded Systems '04, published in 
    Volume 3156, Lecture Notes in Computer Science, Springer-Verlag, 
    Berlin, DE, 2004.

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 26 Mar 2012 19:34:09 -0400

>From the very first days of DNSSEC, I've always thought the EC crypto,
with its more compact keys and signatures, was the way to go
eventually...

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Mon, Mar 26, 2012 at 6:29 PM, RJ Atkinson <[email-masked]> wrote:
> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext

---

From: Scott Rose <[email-masked]>
Date: Tue, 27 Mar 2012 12:31:40 -0400

Suits me - we have a push to use ECDSA for digital signing (by 2015 for DNSSEC), so I don't have a problem with it.  I just wanted WG consensus before making the change.

Scott