Subject: Re: [dnsext] draft-damick-dns-associated-names-record.txt-00

From: "Michael Sheldon" <[email-masked]>
Date: Thu, 02 Aug 2012 09:59:51 -0700

I'm trying to figure out what real-world problem this record solves that
could not be handled by SRV?

Michael Sheldon
Dev-DNS Services
GoDaddy.com

> -------- Original Message --------
> Subject: [dnsext] draft-damick-dns-associated-names-record.txt-00
> From: "Damick, Jeffrey" <[email-masked]>
> Date: Wed, August 01, 2012 7:05 am
> To: "[email-masked]"
> <[email-masked]>, "[email-masked]" <[email-masked]>
> 
> 
> A. Submission Date:  8/1/2012
> 
>    B. Submission Type:
>       [X] New RRTYPE
>       [ ] Modification to existing RRTYPE
>

---

From: Doug Barton <[email-masked]>
Date: Thu, 02 Aug 2012 10:09:10 -0700

+1

On 08/02/2012 09:59, Michael Sheldon wrote:
> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext
> 

-- 

    I am only one, but I am one.  I cannot do everything, but I can do
    something.  And I will not let what I cannot do interfere with what
    I can do.
			-- Edward Everett Hale, (1822 - 1909)

---

From: "Damick, Jeffrey" <[email-masked]>
Date: Thu, 2 Aug 2012 15:05:42 -0400

Well SRV implies the target has an A or AAAA target, whereas the AN record type proposed allows you specify the type associated with the group.  Also to me, the intent of SRV is more toward discovery of a service (its port, which one to choose, etc), and the AN's intent is toward grouping of domain names from a given point (name) as they relate to a particular service.  So while I suppose you could overload that record, I think that distorts and confuses the usage of SRV for clients since you may not actually contact the service listed.

-jeff

On 8/2/12 12:59 PM, "Michael Sheldon" <[email-masked]> wrote:

Michael Sheldon
Dev-DNS Services
GoDaddy.com