Subject: [dnsext] IXFR over UDP

From: "Michael Sheldon" <[email-masked]>
Date: Thu, 18 Oct 2012 13:47:00 -0700

RFC 1995 says that servers *may* respond to IXFR via UDP.

Are there any server implementations out there that actually do? BIND
apparently does not.

With EDNS0, it would seem that many IXFR responses would easily fit in a
UDP packet.

Michael Sheldon
Dev-DNS Services
GoDaddy.com

---

From: Matthijs Mekking <[email-masked]>
Date: Fri, 19 Oct 2012 10:05:37 +0200

NSD will try to do IXFR over TCP by default. You can configure to
allow UDP. In the zone settings of the configuration file, use:

	request-xfr: UDP <ip address> <key>

OpenDNSSEC 1.4 will try to do IXFR over UDP first.

Best regards,
  Matthijs

On 10/18/2012 10:47 PM, Michael Sheldon wrote:
> Are there any server implementations out there that actually do?
> BIND apparently does not.
> 
> With EDNS0, it would seem that many IXFR responses would easily fit
> in a UDP packet.
> 
> Michael Sheldon Dev-DNS Services GoDaddy.com
> 
> _______________________________________________ dnsext mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/dnsext
>