Subject: [dnsext] draft-rafiee-cga-tsig-00 - request for comments

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Wed, 3 Oct 2012 19:06:15 +0200

Hello,

I have submitted an RFC draft to the follow link: http://www.ietf.org/internet-drafts/draft-rafiee-cga-tsig-00.txt. Please take a look at it and share you comments so that I might improve it.

Thanks,

Hosnieh

Filename:            draft-rafiee-cga-tsig

Revision:              00

Title:                      Transaction SIGnature (TSIG) using CGA Algorithm in IPv6

Creation date:   2012-09-30

WG ID:                  Individual Submission

Number of pages: 13

URL:             http://www.ietf.org/internet-drafts/draft-rafiee-cga-tsig-00.txt

Status:          http://datatracker.ietf.org/doc/draft-rafiee-cga-tsig

Htmlized:        http://tools.ietf.org/html/draft-rafiee-cga-tsig-00

---

From: Mark Andrews <[email-masked]>
Date: Thu, 04 Oct 2012 16:45:17 +1000

Why are the CGA parameters not part of other data?  That field was
added to TSIG to hold stuff similar to CGA parameters.  By making
it a seperate field you break all existing TSIG parsers.  The
CGA parameters could just be defined to be the initial part
of other data.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Thu, 4 Oct 2012 09:02:12 +0200

Hello Mark,
Thank you for your comment. Yes can be, 
But the reason is  the TSIG parsers need to be adapted with this new algorithm and it is not different whether to put it in Other DATA or after Other DATA field. Because Other Data has variable length too like the CGA-TSIG DATA.
If I missed something please advise.
Thank you.
Hosnieh

-----Original Message-----
From: Mark Andrews [mailto:[email-masked]] 
Sent: Thursday, October 04, 2012 8:45 AM
To: Rafiee, Hosnieh
Cc: [email-masked]
Subject: Re: [dnsext] draft-rafiee-cga-tsig-00 - request for comments

Why are the CGA parameters not part of other data?  That field was added to TSIG to hold stuff similar to CGA parameters.  By making it a seperate field you break all existing TSIG parsers.  The CGA parameters could just be defined to be the initial part of other data.

---

From: Mark Andrews <[email-masked]>
Date: Thu, 04 Oct 2012 17:15:20 +1000

In message <[email-masked]>, "Rafiee, Hosnieh" writes:
> Hello Mark,
> Thank you for your comment. Yes can be,=20
> But the reason is  the TSIG parsers need to be adapted with this new algori=
> thm and it is not different whether to put it in Other DATA or after Other =
> DATA field. Because Other Data has variable length too like the CGA-TSIG DA=
> TA.

It is different.  Examine the behaviour of CGA-TSIG client talking
to a non CGA-TSIG aware server.  The response to using a unknown
algorithm should be BADKEY not FORMERR because the server couldn't
parse the TSIG record.

Mark

> From: Mark Andrews [mailto:[email-masked]]=20
> Why are the CGA parameters not part of other data?  That field was added to=
>  TSIG to hold stuff similar to CGA parameters.  By making it a seperate fie=
> ld you break all existing TSIG parsers.  The CGA parameters could just be d=
> efined to be the initial part of other data.
> 
> --
> Mark Andrews, ISC

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Thu, 4 Oct 2012 09:27:49 +0200

Thank you,
I will change it and move the whole CGA-TSIG DATA inside the Other DATA.

-----Original Message-----
From: Mark Andrews [mailto:[email-masked]] 
Sent: Thursday, October 04, 2012 9:15 AM
To: Rafiee, Hosnieh
Cc: [email-masked]
Subject: Re: [dnsext] draft-rafiee-cga-tsig-00 - request for comments

In message <[email-masked]>, "Rafiee, Hosnieh" writes:
> Hello Mark,
> Thank you for your comment. Yes can be,=20 But the reason is  the TSIG 
> parsers need to be adapted with this new algori= thm and it is not 
> different whether to put it in Other DATA or after Other = DATA field. 
> Because Other Data has variable length too like the CGA-TSIG DA= TA.

It is different.  Examine the behaviour of CGA-TSIG client talking to a non CGA-TSIG aware server.  The response to using a unknown algorithm should be BADKEY not FORMERR because the server couldn't parse the TSIG record.

Mark

> added to=  TSIG to hold stuff similar to CGA parameters.  By making it 
> a seperate fie= ld you break all existing TSIG parsers.  The CGA 
> parameters could just be d= efined to be the initial part of other data.
> 
> --
> Mark Andrews, ISC

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Thu, 4 Oct 2012 20:38:21 +0200

Thank you,

-----Original Message-----
From: Mark Andrews [mailto:[email-masked]] 
Sent: Thursday, October 04, 2012 9:15 AM
To: Rafiee, Hosnieh
Cc: [email-masked]
Subject: Re: [dnsext] draft-rafiee-cga-tsig-00 - request for comments

Mark