Subject: [dnssd] A reminder of existing (personal) dnssd drafts

From: Tim Chown <[email-masked]>
Date: Fri, 8 Nov 2013 18:30:58 +0000

Hi,

The tools data tracker list the five dnssd related drafts:
http://datatracker.ietf.org/wg/dnssd/

In today’s meeting we will focus on the requirements draft
http://datatracker.ietf.org/doc/draft-lynn-dnssd-requirements/
We will be asking the WG whether it wishes to adopt the draft after the requirements discussion.

Andrew Sullivan will also be talking (no slides) about the use of labels with DNS SD.

The drafts draft-bhandari-dnssd-mdns-gateway-00 and draft-vanderstok-dnssd-building-requirements-00 are also very useful for our initial steer; we should ensure their requirements are included in the main requirements document.

Tim

---

From: Kerry Lynn <[email-masked]>
Date: Fri, 8 Nov 2013 12:04:56 -0800

On Fri, Nov 8, 2013 at 10:30 AM, Tim Chown <[email-masked]> wrote:

> The drafts draft-bhandari-dnssd-mdns-gateway-00<http://datatracker.ietf.org/doc/draft-bhandari-dnssd-mdns-gateway/>
>  and draft-vanderstok-dnssd-building-requirements-00<http://datatracker.ietf.org/doc/draft-vanderstok-dnssd-building-requirements/> are
> also very useful for our initial steer; we should ensure their requirements
> are included in the main requirements document.
>
> Add to this list
http://tools.ietf.org/html/draft-stenberg-homenet-dnssdext-hybrid-proxy-ospf-00
,
which is currently in homenet but arguably belongs in dnssd.

-K-

> Tim
>
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>
>

---

From: Tim Chown <[email-masked]>
Date: Sat, 9 Nov 2013 00:44:10 +0000

On 8 Nov 2013, at 20:04, Kerry Lynn <[email-masked]> wrote:

> Add to this list http://tools.ietf.org/html/draft-stenberg-homenet-dnssdext-hybrid-proxy-ospf-00,

Thanks Kerry. It would be interesting to hear from Markus what his plans for this are.

The use of OSPF may make it rather homenet specific, if homenet adopts OSPF.

Tim

---

From: Markus Stenberg <[email-masked]>
Date: Fri, 8 Nov 2013 18:52:34 -0800

> The use of OSPF may make it rather homenet specific, if homenet adopts OSPF.

I see it as the homenet solution. Because if you do non-zeroconf case, it’s much, much more elegant just to do normal DNS-based DNS-SD +- hybrid proxy to cover mdns links as extra, without going to all the trouble of using OSPF for it.

(Authenticated) DNS-update {b,lb} PTRs + NS for per-link sub-domain == win, and as long as you have centralized authority somewhere for naming (=name server), I don’t really see the point for my solution. Of course, in case of homenet, where I try to avoid having a god box, I see the value of effectively generating zone file fragments from shared OSPF state.

As I said to Tim, the next time I’m updating my draft, I am likely to make it homenet- only (and I shall do that if and only if I either update it in some way, or homenet converges on OSPF).

Cheers,

-Markus