Subject: [dnssd] dnssd WG meeting logistics, London

From: Ralph Droms <[email-masked]>
Date: Sun, 9 Feb 2014 12:44:59 -0500

The dnssd WG will meet on Monday, March 3 at 1300 UTC in the Sovereign room.

The I-D submission cut-off is Friday, February 14 at 23:59 UTC.

Tim and I need to submit the draft WG agenda by Monday, February 17, 23:59 UTC.  As requested in earlier e-mail, please send requests for agenda slots to us by Friday, February 14, 17:00 EST.

Finally, as a reminder, Early Bird registration and payment cut-off is Friday, February 21 at UTC 23:59.

- Tim and Ralph

---

From: Douglas Otis <[email-masked]>
Date: Tue, 11 Feb 2014 11:39:31 -0800

> Finally, as a reminder, Early Bird registration and payment cut-off is Friday, February 21 at UTC 23:59.

Dear Ralph,

In review of products marketed at solving the problem of accessing devices beyond the reach of mDNS, these typically involve extending the MAC Bridge by using VLAN technology.  These products also filter extended services.  It seems one of the work products this group might consider is to standardized filtering inputs, perhaps based on an RBridge compatible TLV structure.

While establishing a trust anchor by using a smartphone or cloud service is interesting, the simplicity of mDNS has been a major reason for its success.  Signed trust requires a difficult and complex secure distribution of keys.  Using plain DNS to extend mDNS is rather perilous as well.  It is fairly common to find DNS settings in CPE routers maliciously modified, where unplugging or resetting them erases evidence.  DNSSec is not well established in CPE devices where doing so requires processing pre-existing keys and signatures where initial distribution is not even an issue.

A desirable feature of mDNS is its limited range.  Use of RBridge or VLAN is able to overcome mDNS limitations. Due to its relative simplicity, it seems possible to include RBridge or VLAN protocol in affected products as a means to retain safe automatic configurations.  Perhaps the WG could request someone from the Trill WG to speak (their WG meets Friday). It also seems this protocol offers a good solution in homenet situations as well.

If you like, I could spend a few minutes reviewing issues raised in the draft-otis-dnssd-mdns-xlink. 

Regards,
Douglas Otis