Subject: [dnssd] LF comments on a new document

From: "Aggarwal, Ashutosh" <[email-masked]>
Date: Wed, 9 Jul 2014 21:02:46 +0000

Dear members,

I have submitted a new draft document proposing an optimization to the DNS-SD query mechanism to make it more scalable. I have been in discussions with Dave Thaler during the formulation of the draft and would like to request for comments from the community.

Abstract:
DNS-SD allows a client to find a list of named instances of a service
 name over a particular transport within a domain of interest using
 standard DNS queries.  As the number of potential responders
 increases, DNS-SD based discovery doesn't scale well.  To mitigate
 the scaling issues, schemes to narrow down the search context would
 be needed.  The document proposes to include key/value pairs in the
 form of a DNS TXT record along with the service name in the DNS query
 to assist with the discovery process.  The DNS TXT record can be
 placed in the additional section of the query without requiring any
 changes to the structure of DNS messages.

Link to the document:
http://datatracker.ietf.org/doc/draft-aggarwal-dnssd-optimize-query/

Thanks,
Ashutosh

---

From: "Guangqing Deng" <[email-masked]>
Date: Tue, 15 Jul 2014 10:57:10 +0800

Since the number of so called key/values may be very large and not all of them contain rich information for narrowing down search context, it seems that we should further specify which key/values are mandatory and which are just optional.

Guangqing Deng
CNNIC 
 
From: Aggarwal, Ashutosh
Date: 2014-07-10 05:02
To: [email-masked]
CC: Resnick, Pete
Subject: [dnssd] LF comments on a new document
Dear members,

Abstract:
 
Link to the document:
 
Thanks,
Ashutosh

---

From: "Aggarwal, Ashutosh" <[email-masked]>
Date: Tue, 15 Jul 2014 20:00:24 +0000

Thanks for your comment. Yes, the specification of keys (mandatory and optional) should be within the service protocol specification. As far as DNS-SD is concerned, TXT records should abide by the size limitations as specified in the RFC 6763. The proposed contribution (in section 3) suggests how multiple keys within a TXT record and multiple TXT records should be interpreted logically.

Ashutosh

From: Guangqing Deng [mailto:[email-masked]]
Sent: Monday, July 14, 2014 7:57 PM
To: Aggarwal, Ashutosh
Cc: dnssd
Subject: Re: [dnssd] LF comments on a new document

________________________________
Guangqing Deng
CNNIC

From: Aggarwal, Ashutosh<mailto:[email-masked]>
Date: 2014-07-10 05:02
To: [email-masked]<mailto:[email-masked]>
CC: Resnick, Pete<mailto:[email-masked]>
Subject: [dnssd] LF comments on a new document
Dear members,

Abstract:

Link to the document:

Thanks,
Ashutosh