Subject: [dnssd] multicast over wireless links

From: RJ Atkinson <[email-masked]>
Date: Thu, 24 Jul 2014 14:23:59 -0400

Ted,

  When IP multicasting originated, wired Ethernet was a shared
medium using CSMA/CD.  A single IP/Ethernet frame would reach
all nodes on that IP subnet.  I still remember vampire taps 
and the big yellow Coax cable in my office from back then.

  In the 1990s, switched Ethernet became commonplace and 
(as deployed) the wire to the desktop was not a shared
medium, but instead was a solo link back to the Ethernet
switch.  This meant that the IP/Ethernet frame did not 
automatically get seen by all nodes on that Ethernet 
(bridged) link.  The IETF didn't drop IP multicasting, 
or discourage use of IP multicasting.  Instead, Ethernet 
switch vendors made various optimisations inside their 
Ethernet switch products (e.g. IGMP snooping) to make 
IP multicasting work well over wired switched Ethernet.  
IETF folks were involved in helping the Ethernet vendors 
understand some implementation options for those optimisations 
in those Ethernet products.

  The situation today with 802.11 is entirely analogous
to that previous situation with wired Ethernet moving
from shared CSMA/CD to switched dedicated links, and the
IETF community should have the same response -- don't drop 
the use of IP multicasting, don't discourage use of 
IP multicasting -- instead engage with others so that a 
link-specific optimisation can be put into use only for 
-- and only within -- those link-specific vendor devices 
(e.g., wireless access point, 802.11 radio, or whatever 
term one prefers).

Yours,

Ran

---

From: Robert Cragie <[email-masked]>
Date: Thu, 24 Jul 2014 19:33:38 +0100

But as Alf said earlier, there are other wireless technologies which are 
not well suited to IP multicast traffic. 802.15.4-based mesh networks 
are a very good example and there is certainly a use case for DNS-SD in 
these type of networks.

Robert

On 24/07/2014 7:23 PM, RJ Atkinson wrote:
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 24 Jul 2014 14:43:54 -0400

On Jul 24, 2014, at 2:33 PM, Robert Cragie <[email-masked]> wrote:
> But as Alf said earlier, there are other wireless technologies which are not well suited to IP multicast traffic. 802.15.4-based mesh networks are a very good example and there is certainly a use case for DNS-SD in these type of networks.

Broadcast is a good idea when the information being distributed is needed by all receivers, and when receivers' connections are persistent.   But newcomers to the network don't have the information until the next broadcast, or have incomplete information until the next broadcast, or have to trigger a new broadcast.

In practice, in my experience, what this means is that multicast winds up producing much more traffic than would a non-multicast solution.   So that's why I suggest that it's better to rely heavily on multicast only in environments where multicast really is cheaper than unicast.

(Of course, clearly DNSSD will use multicast to some extent; the question is how much.)

---

From: Robert Cragie <[email-masked]>
Date: Thu, 24 Jul 2014 20:55:29 +0100

+1. Of course 802.15.4-based mesh networks have to cope with multicast 
traffic but its use should be carefully considered.

Robert