Subject: Re: [dnssd] I-D Action: draft-rafiee-dnssd-mdns-threatmodel-03.txt

From: Hosnieh Rafiee <[email-masked]>
Date: Mon, 1 Jun 2015 07:18:05 +0000

All,

I have submitted a new version of threat model.

Your review is highly appreciated.
Thanks,
Best,
Hosnieh

> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : Multicast DNS (mDNS) Threat Model and
> Security Consideration
>         Author          : Hosnieh Rafiee
> 	Filename        : draft-rafiee-dnssd-mdns-threatmodel-03.txt
> 	Pages           : 12
> 	Date            : 2015-05-30
> 
> Abstract:
>    This document describes threats only specific to extending multicast
>    DNS (mDNS) across layer 3.
> 
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-rafiee-dnssd-mdns-threatmodel/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-rafiee-dnssd-mdns-threatmodel-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-rafiee-dnssd-mdns-threatmodel-
> 03
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Douglas Otis <[email-masked]>
Date: Tue, 02 Jun 2015 19:40:54 -0700

> > https://tools.ietf.org/html/draft-rafiee-dnssd-mdns-threatmodel-03
Dear Hosnieh,

This review misses a concern called out in the CERT notice
for dnssd at

https://www.kb.cert.org/vuls/id/550620

See Section 1 of
https://tools.ietf.org/html/draft-otis-dnssd-mdns-xlink-06

The threat model also overlooks data leakage beyond a local
link and DNS amplification concerns resulting from the
browse-ability offered by resource structures as explained
in the introduction and the CERT notice.

Appendix A gives an example of data leakage exploited in
Appendix B.

A mitigation practice to overcome these risks remains
unclear unless some means is made available to limit results.

Regards,
Douglas Otis