Subject: [dnssd] Summary of WG meeting

From: Tim Chown <[email-masked]>
Date: Tue, 12 Apr 2016 13:51:17 +0100

Hi,

Ralph and I produced a very brief summary of the WG meeting outcomes for the int-area Wiki, which are copied below.

Thanks to everyone for their contributions for the meeting. Hopefully we can progress the two drafts for the DNS Push work promptly, and in the meantime get an updated hybrid proxy draft to the IESG.

Best wishes,
Tim

dnssd WG, Monday afternoon session 2, 3:50PM

* Chairs’ Introduction

* Discussion: WGLC of Hybrid Unicast/Multicast DNS-Based Service Discovery - draft-ietf-dnssd-hybrid-03

Several WG members supplied input during the WG last call.  Stuart Cheshire responded to that input.  He will edit draft-ietf-dnssd-hybrid-03 according to that input and publish rev-04.  The chairs will review -04 to ensure all comments have been appropriately addressed and submit the revised draft to the IESG for publication.
 
* Discussion: Next Steps for DNS Push Notifications - draft-ietf-dnssd-push-06

There was input during discussion that this document actually specifies two different behaviours: DNS-over-TCP and DNS updates.  The authors will split draft-ietf-dnssd-push-06 into two documents, one for each behaviour.

* Discussion: WGLC of On Interoperation of Labels between DNS and Other Resolution Systems - draft-ietf-dnssd-mdns-dns-interop-02

There was only one set of (editorial level) comments from Dave Thaler about this document during the WG last call. Because the document has been thoroughly reviewed by the WG during an earlier WG last call, the chairs have agreed that Dave and Andrew will work together to update the draft which will then be submitted to the IESG for publiciation.

* Discussion: -03 version of Scalable DNS-SD (SSD) Threats - draft-otis-dnssd-scalable-dns-sd-threats-03

Because discussion of the first two agenda items was prioritised, and there also being ongoing review and discussion of this document on the WG mailing list, the presentation was taken off the agenda.

* Discussion: New draft: Privacy Extensions for DNS-SD	- draft-huitema-dnssd-privacy-00

The WG appreciates this contribution and encourages further work on the document, even if there is no specific solution proposed as yet. The AD confirmed that privacy issues are implicitly within our charter.

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 12 Apr 2016 23:45:29 -0400

> On Apr 12, 2016, at 8:51 AM, Tim Chown <[email-masked]> wrote:
> 

To be more specific, after talking with Ray Bellis and Sara Dickinson, Stuart realized that the Push draft was doing both Push updates and session management (with the Termination message).

This, in combination with the excessive EDNS0 keepalive messages in both directions made it obvious that it would be better to separate out the session management into a more general DNS over TCP session extension draft. We are going to work with Ray and Sara on this.

The Push draft will mostly remain the same, but will lose the Termination message and the EDNS0 keepalives will get morphed into the session version and only need to be sent at the beginning of the session or when the keepalive timeout changes. This will simplify the protocol while providing session management over TCP for other DNS uses.

Tom

---

From: Tim Wicinski <[email-masked]>
Date: Tue, 12 Apr 2016 23:52:36 -0400

I spoke with Ray and Susan after your conversation, and I felt this was 
a more generalized way to approach this problem.  Also, as DNSOP 
co-chair, the work should come from there, but the chairs will work with 
DNSOP on this.

tim

On 4/12/16 11:45 PM, Tom Pusateri wrote:
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 13 Apr 2016 00:01:23 -0400

On Apr 12, 2016, at 11:52 PM, Tim Wicinski <[email-masked]> wrote:
> 
> 
> I spoke with Ray and Susan after your conversation, and I felt this was a more generalized way to approach this problem.  Also, as DNSOP co-chair, the work should come from there, but the chairs will work with DNSOP on this.
> 
> tim
> 

Yes, I should have mentioned that it was DNSOP work. And also I forgot to include Allison Mankin as part of the discussion.

Thanks,
Tom

---

From: Tim Chown <[email-masked]>
Date: Thu, 14 Apr 2016 10:09:18 +0000

> On 13 Apr 2016, at 04:52, Tim Wicinski <[email-masked]> wrote:
> 
> 

Thanks Tim.

>From off-list emails it looks like a draft will appear fairly soon, which dnssd WG participants will also be encouraged to comment on.

Best wishes,
Tim