Subject: [dnssd] dnssd WG status / tasks with IETF96 looming

From: Tim Chown <[email-masked]>
Date: Mon, 27 Jun 2016 15:11:04 +0000

Hi,

Ralph and I had a chat at the end of last week to review where we are on dnssd WG items. We will be nudging people offline accordingly.

The formal list of drafts can be found at https://tools.ietf.org/wg/dnssd/.

1) Hybrid proxy draft
https://tools.ietf.org/html/draft-ietf-dnssd-hybrid-03
Updates were agreed at IETF95; Stuart to apply, check WG is happy all comments resolved, then push to IESG

2) Label intro draft
https://tools.ietf.org/html/draft-ietf-dnssd-mdns-dns-interop-02
Dave Thaler to talk to Andrew Sullivan about editorial (non semantic) updates, then push to IESG.

So we expect those two drafts to advance to the IESG before/during IETF96.

3) DNS push draft
To be split into two parts
a) session signalling draft
    Ray Bellis, Sara Dickinson, Allison Mankin have been working with Stuart and Tom - draft expected by IETF96 cutoff, to be submitted to dnsop WG
b) DNS Push-specific part
    https://tools.ietf.org/html/draft-ietf-dnssd-push-07
    Update to come, removing the session signalling part, before IETF96.

4) mDNS/DNS-SD privacy draft
https://tools.ietf.org/html/draft-huitema-dnssd-privacy-01
Draft has been updated with new author since IETF95, stepping into solution space. Slot already agreed for IETF96, and list discussion happening

There are also two new drafts that we hope we’ll have at least a -00 strawman for in advance of Berlin:

5) A new I-D on recommendations for using the hybrid proxy, especially in a campus-type environment. What are the practical deployment considerations?
   Authors are welcome!

6) A new I-D on DNS Update and mdns/hybrid proxy coexistence
   Ted Lemon volunteered to do a -00 in Buenos Aires; it would be useful to have some text before IETF96

There are some other open questions that we may wish to discuss in Berlin, but the above topics are the priority.
Those questions include:
- Does draft-ietf-homenet-hybrid-proxy-zeroconf-02 need updating in light of the publication of RFC 7788?
- Do we have open source hybrid proxy implementations that could be tested by university campus network operators?
- What user interface considerations exist?
- Do we need to revisit draft-aggarwal-dnssd-optimize-query-00?
- How do we take the threats draft forward? (draft-otis-dnssd-scalable-dns-sd-threats-03)
- Anything else we missed?

Comments welcome!

Tim and Ralph

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 27 Jun 2016 21:30:49 -0400

> Dave Thaler to talk to Andrew Sullivan about editorial (non semantic) updates, then push to IESG.

I asked about text on the list weeks ago, and heard nothing.  Shall I
go ahead with most of Dave's edits, do what I think best on the topics
I asked about, and then send it to you?

A

-- 
Andrew Sullivan
Dyn
[email-masked]

---

From: Tim Chown <[email-masked]>
Date: Tue, 28 Jun 2016 10:07:19 +0000

Hi Andrew,

> On 28 Jun 2016, at 02:30, Andrew Sullivan <[email-masked]> wrote:
> 

Yes, please. I’ve copied Dave explicitly above; obviously we’d like to get his feedback on your changes, as well as comments from anyone else in the WG who would care to do a final review.

Ralph and I will discuss a shepherd for the document (volunteers welcome).
 
Tim