Subject: Re: [dnssd] [ietf-privacy] Fwd: draft-huitema-dnssd-privacy-01.txt

From: S Moonesamy <[email-masked]>
Date: Tue, 05 Jul 2016 22:32:42 -0700

Hi Christian,
At 11:51 23-06-2016, Christian Huitema wrote:
>Section 3 describes an initial design that was then abandoned. I guess that
>in the next revision we could just remove that section entirely.
>
>On the other hand, the proposal was indeed to use different obfuscated names
>at different locations.

Ok.

>The private discovery service relies on pre-existing pairings. The pairing
>solutions are only drafted in very vague terms in the draft. I really wonder
>whether we should go define a complete pairing protocol. Is that in-charter
>for DNS-SD? What about competing with existing solutions over Bluetooth,
>Wi-Fi, and certainly many more?

I'll leave the in-charter question to the WG Chairs. :-)  I assume 
that the last question in similar to what is in Section 5.2.  I 
haven't looked at the existing solutions to provide a useful answer.

Regards,
S. Moonesamy

---

From: Tim Chown <[email-masked]>
Date: Wed, 13 Jul 2016 15:38:09 +0000

Hi,

> On 6 Jul 2016, at 06:32, S Moonesamy <[email-masked]> wrote:
> 
> Hi Christian,
> I'll leave the in-charter question to the WG Chairs. :-)  I assume that the last question in similar to what is in Section 5.2.  I haven't looked at the existing solutions to provide a useful answer.

I may have said this already, but we’ll discuss this at the dnssd WG session next Wednesday.  Our AD has explicitly said that privacy considerations are in scope (and should be in all WGs :) but we will need to have the conversation with the WG and the AD about the best place to proceed with the work, and about getting critical mass to ensure it completes (I’d assume Christian and Daniel would welcome all help…).

Best wishes,
Tim