Subject: [dnssd] Call for WG Adoption: draft-huitema-dnssd-privacy-01

From: Tim Chown <[email-masked]>
Date: Mon, 25 Jul 2016 14:16:27 +0000

Hi,

At the meeting in Berlin, there was a positive reaction to the "Privacy Extensions for DNS-SD” draft, https://tools.ietf.org/html/draft-huitema-dnssd-privacy-01.

While only a small number of people had read it in detail, those who had read it expressed a desire for the WG to adopt the draft.

This email therefore begins a two-week formal dnssd mail list call for adoption of the draft by the WG. Please send any comments, for or against, to the dnssd WG list. If you indicated support in the meeting, feel free to reaffirm this, and add any comments.

The call ends on Monday 8th August.

The document status in the data tracker can be found at https://datatracker.ietf.org/doc/draft-huitema-dnssd-privacy/.

Note that the WG in which the specifics of the pairing protocol will be developed will be reviewed by our AD. On the one had it is a generic mechanism that may be better defined in a security WG, on the other we should have a critical mass of people to get the work done here, if the draft is adopted.

Tim

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jul 2016 10:28:35 +0200

What is the status of the pairing piece of this work?  None of this
can work without addressing that portion.  The document contains some
ideas, but these are quite nebulous and certainly not sufficient to
deploy an interoperable solution for this.

(I'm generally supportive of this work, but I want to make sure that
everyone understands the scope and magnitude of the work involved
here.)

On 25 July 2016 at 16:16, Tim Chown <[email-masked]> wrote:
> Hi,
>
> At the meeting in Berlin, there was a positive reaction to the "Privacy
> Extensions for DNS-SD” draft,
> https://tools.ietf.org/html/draft-huitema-dnssd-privacy-01.
>
> While only a small number of people had read it in detail, those who had
> read it expressed a desire for the WG to adopt the draft.
>
> This email therefore begins a two-week formal dnssd mail list call for
> adoption of the draft by the WG. Please send any comments, for or against,
> to the dnssd WG list. If you indicated support in the meeting, feel free to
> reaffirm this, and add any comments.
>
> The document status in the data tracker can be found at
> https://datatracker.ietf.org/doc/draft-huitema-dnssd-privacy/.
>
> Note that the WG in which the specifics of the pairing protocol will be
> developed will be reviewed by our AD. On the one had it is a generic
> mechanism that may be better defined in a security WG, on the other we
> should have a critical mass of people to get the work done here, if the
> draft is adopted.
>
> Tim
>
>
>
>
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>

---

From: Tim Chown <[email-masked]>
Date: Tue, 26 Jul 2016 09:34:31 +0000

Hi,

> On 26 Jul 2016, at 09:28, Martin Thomson <[email-masked]> wrote:
> 

Indeed, it is in its infancy. The -00 was pretty much just a problem statement, and the -01 took the first steps into solution space. 

Note that an I-D yes not have to be close to its final shape to be adopted by the WG, indeed you can vote to adopt even if there are parts you currently disagree with, but believe it is important work for the WG.

I’m expecting that we’ll get a view from our AD (Terry) on whether the pairing work is to be done in dnssd or elsewhere by the time the call for adoption period completes, and that, alongside other comments about the magnitude of the work and whether sufficient critical mass exists to execute it, will inform Ralph and I to make a decision. The (limited) views in the room in Berlin were very positive, but your points are well made.

Tim

---

From: Daniel Kaiser <[email-masked]>
Date: Tue, 26 Jul 2016 11:50:43 +0200

We started working on a new document on pairing.
A reference to this new pairing document will be substituted for
the pairing part in the privacy document.

Further, we will remove the part on the simple design from the
privacy document making it more concise.

---

From: Tim Chown <[email-masked]>
Date: Tue, 26 Jul 2016 09:56:19 +0000

Hi Daniel,

On 26 Jul 2016, at 10:50, Daniel Kaiser <[email-masked]<mailto:[email-masked]>> wrote:

I don’t think a strong view was expressed either way in Berlin as to whether the work should be in one document or two. But if our AD does recommend taking the pairing work to a different WG, then abstracting the work to a separate doc will of course be useful.

The adoption call for the main document will still need to take into account that the pairing work needs to be done.

Tim

On 25 July 2016 at 16:16, Tim Chown <[email-masked]><mailto:[email-masked]> wrote:

Hi,

Tim

_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

---

From: Daniel Kaiser <[email-masked]>
Date: Tue, 26 Jul 2016 14:49:44 +0200

Hi Tim,

we could write a 00 draft on pairing which might help
the AD and the WG to decide whether pairing should be

1) integrated in the existing privacy draft,
2) addressed in a separate draft within the dnssd group, or
3) addressed in another working group.

As there is consensus that we should address pairing,
I will definitely continue working on that :).

"The adoption call for the main document will still need to take into account that the pairing work needs to be done."

Is there something I should do?

kind regards
Daniel

---

From: Tim Chown <[email-masked]>
Date: Tue, 26 Jul 2016 12:55:15 +0000

Hi Daniel,

I’ve popped an email directly to Terry to ask about the pairing work.

At the moment, keep working on it; it shouldn’t be a big deal to merge/split drafts if/when necessary :)  Do feel free to ask open questions you have to the WG list, so they can give opinions and advice.

Tim

On 26 Jul 2016, at 13:49, Daniel Kaiser <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tim,

kind regards
Daniel

Hi Daniel,

On 26 Jul 2016, at 10:50, Daniel Kaiser <[email-masked]<mailto:[email-masked]><mailto:[email-masked]><mailto:[email-masked]>> wrote:

Tim

On 25 July 2016 at 16:16, Tim Chown <[email-masked]><mailto:[email-masked]><mailto:[email-masked]><mailto:[email-masked]> wrote:

Hi,

Tim

_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]><mailto:[email-masked]><mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]><mailto:[email-masked]><mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]><mailto:[email-masked]><mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

---

From: Dave Thaler <[email-masked]>
Date: Tue, 26 Jul 2016 14:41:13 +0000

Just reaffirmining what I said at the mic.

I support adopting this draft, while the pairing portion I would prefer be in a separate
draft in a different group (e.g. intarea with joint review by saag), since the pairing part
should not be specific to dnssd.

Dave

> -----Original Message-----
> From: dnssd [mailto:[email-masked]] On Behalf Of Martin Thomson
> Sent: Tuesday, July 26, 2016 1:29 AM
> To: Tim Chown <[email-masked]>
> Cc: [email-masked]; Terry Manderson <[email-masked]>
> Subject: Re: [dnssd] Call for WG Adoption: draft-huitema-dnssd-privacy-01
> 
> What is the status of the pairing piece of this work?  None of this can work
> without addressing that portion.  The document contains some ideas, but
> these are quite nebulous and certainly not sufficient to deploy an
> interoperable solution for this.
> 
> (I'm generally supportive of this work, but I want to make sure that everyone
> understands the scope and magnitude of the work involved
> here.)
> 
> > At the meeting in Berlin, there was a positive reaction to the
> > "Privacy Extensions for DNS-SD” draft,
> > While only a small number of people had read it in detail, those who
> > had read it expressed a desire for the WG to adopt the draft.
> >
> > adoption of the draft by the WG. Please send any comments, for or
> > against, to the dnssd WG list. If you indicated support in the
> > meeting, feel free to reaffirm this, and add any comments.
> >
> > Note that the WG in which the specifics of the pairing protocol will
> > be developed will be reviewed by our AD. On the one had it is a
> > generic mechanism that may be better defined in a security WG, on the
> > other we should have a critical mass of people to get the work done
> > here, if the draft is adopted.
> >
> > Tim
> >
> >
> >
> >

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 31 Jul 2016 15:18:17 -0400

I support adoption , and I'd like to second Dave's point on the pairing. 

From my high tech gadget

> On Jul 26, 2016, at 10:41, Dave Thaler <[email-masked]> wrote:
>

---

From: Ted Lemon <[email-masked]>
Date: Sun, 31 Jul 2016 15:26:38 -0400

I also support adoption of this work. I don't have a problem with putting
pairing in a separate document, but let's not get to caught up in process.
We need to do the work where there are people who want to do the work.

On Jul 31, 2016 3:18 PM, "Tim Wicinski" <[email-masked]> wrote:

> everyone