Subject: [dnssd] Setting device friendly names

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 20 Jul 2016 13:22:06 +0000

In my experience, many devices already support mechanisms for friendly name acquisition. Many devices, including PCs, ask for names during setup. Others support UPnP friendly name service. Others have UIs to allow naming. What I really want (as a user) is for the device to have the same name in all contexts. So if it's been named, through whatever means, use that name. Which to me says we don't need a new standard for remote naming that all devices must support. 
Barbara

---

From: Ted Lemon <[email-masked]>
Date: Wed, 20 Jul 2016 15:31:27 +0200

Can you talk more about this UPnP thing?   Bear in mind that UPnP is not a
standard, AFAIK, although its follow-on, PCP, is.   I don't know that PCP
has this feature.

The fact that some devices have UIs that users may or may not be able to
find does not mean that there needn't be a standard way to do it.   Maybe
we don't need it, but if we don't, that's not the reason.

On Wed, Jul 20, 2016 at 3:22 PM, STARK, BARBARA H <[email-masked]> wrote:

> In my experience, many devices already support mechanisms for friendly
> name acquisition. Many devices, including PCs, ask for names during setup.
> Others support UPnP friendly name service. Others have UIs to allow naming.
> What I really want (as a user) is for the device to have the same name in
> all contexts. So if it's been named, through whatever means, use that name.
> Which to me says we don't need a new standard for remote naming that all
> devices must support.
> Barbara
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 20 Jul 2016 15:38:06 +0000

+1

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On 2016-07-20, at 7:22 AM, STARK, BARBARA H <[email-masked]> wrote:
>

---

From: Dave Thaler <[email-masked]>
Date: Wed, 20 Jul 2016 16:44:32 +0000

I wasn’t aware of this before either so I just did a web search…

http://www.upnp.org/download/upnp_vendor_implementation_guide_jan2001.htm
is what I found, which discusses it in somewhat easy to read terms.

https://openconnectivity.org/upnp/specifications says UPnP is a standard, and
I found what I think is the friendlyname referred to, in the “Basic Device:1” spec.

Dave

From: dnssd [mailto:[email-masked]] On Behalf Of Ted Lemon
Sent: Wednesday, July 20, 2016 3:31 PM
To: STARK, BARBARA H <[email-masked]>
Cc: [email-masked]
Subject: Re: [dnssd] Setting device friendly names

Can you talk more about this UPnP thing?   Bear in mind that UPnP is not a standard, AFAIK, although its follow-on, PCP, is.   I don't know that PCP has this feature.

The fact that some devices have UIs that users may or may not be able to find does not mean that there needn't be a standard way to do it.   Maybe we don't need it, but if we don't, that's not the reason.

On Wed, Jul 20, 2016 at 3:22 PM, STARK, BARBARA H <[email-masked]<mailto:[email-masked]>> wrote:
In my experience, many devices already support mechanisms for friendly name acquisition. Many devices, including PCs, ask for names during setup. Others support UPnP friendly name service. Others have UIs to allow naming. What I really want (as a user) is for the device to have the same name in all contexts. So if it's been named, through whatever means, use that name. Which to me says we don't need a new standard for remote naming that all devices must support.
Barbara
_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

---

From: Markus Stenberg <[email-masked]>
Date: Wed, 20 Jul 2016 18:51:02 +0200

Pcp is just a firewall hole plugging protocol. Upnp as a whole is much more than that. The service discovery part of it is somewhat analogous to mdns on drugs. 

Udp? Check. Http + xml? If you must. Multiple urls in small udp packets? ...

-Markus

(on the road, via iPhone)

---

From: Stuart Cheshire <[email-masked]>
Date: Wed, 20 Jul 2016 09:56:28 -0700

On 20 Jul 2016, at 06:22, STARK, BARBARA H <[email-masked]> wrote:

> In my experience, many devices already support mechanisms for friendly name acquisition. Many devices, including PCs, ask for names during setup. Others support UPnP friendly name service.

For the benefit of those of us less familiar with this, can you send some screen shots showing the process of setting a device’s name using this UPnP friendly name service?

Stuart Cheshire

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 21 Jul 2016 09:54:16 +0000

UPnP SSDP announcements include a friendly name in the SSDP header. To me, this is comparable to the instance name in DNS-SD / mDNS. And comparable to a NetBIOS name.

When I ask my router for a list of hosts on the network, and when I ask my BluRay player to show me a list of content sources (UPnP), the lists use the same names for devices (because these devices use the same name across protocols). This is a good thing. I haven't checked whether printers have the same name in a host list and a list of printers (DNS-SD), but I would definitely want that to be true. My iPhone also has the same name when appearing in host lists and UPnP lists.

And now there is a suggestion for a device name to be used in site-wide, flat DNS.

We must not confuse users by having different names for a device used in different protocols.

Devices must not allow the name to be trivially changed, once set. That too creates confusion. Preferably, whatever method was used to first set a device name (by a user) should also be the way to change it (allowing another method must have very stringent authentication/authorization in place to make sure the change is allowed).

There are some devices that don't have an easy way to set a device name (by the user). Yes, it would be fine to recommend something for those. But accept that those device manufacturers may choose to ignore that recommendation and either use a different method or just go with a default name. This must not break site-wide, flat DNS. We must not build a dependency on the ability of the user to name devices.

And don't expect devices that do already have a naming mechanism to support a different naming mechanism. I named my laptop when I first set it up. My laptop advertises various services into my home network, and it always appears with that name. I do not want my laptop to change its name because some message came along telling it to. My personal requirement for my laptop is that it MUST NOT allow its name to be changed by a remote message.

About UPnP naming... The key point I was trying to make is that the UPnP architecture has a "friendly name" that must be included in SSDP advertising. Yes, there is also a UPnP Service defined that allows for remotely changing the friendly name. https://openconnectivity.org/upnp/specifications/friendlyinfoupdate1. But this service was only published in 2014 (long, long after the UPnP Device Architecture required "friendly name" in SSDP advertisements), it is not widely implemented (not mandatory to implement), and it can be implemented in a manner that requires authentication/authorization to allow invocation of the "SetFriendlyName()" action. The reason this service isn't seen as particularly necessary is because devices tend to already have some sort of device name (default or user defined through a UI) that UPnP can use.
FWIW, UPnP is an ISO/IEC standard.

On Jul 20, 2016, at 3:32 PM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 21 Jul 2016 10:04:17 +0000

Most UPnP devices use a device name they find laying around elsewhere in the OS config or firmware. I know that implementations of the UPnP friendly name service exist, but don't have examples on hand of either a device with the service or a control point that can make use of the service. 
Barbara

> On Jul 20, 2016, at 6:56 PM, Stuart Cheshire <[email-masked]> wrote:
>

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 21 Jul 2016 03:31:04 -0700

> UPnP SSDP announcements include a friendly name in the SSDP header. To me, this is comparable to the instance name in DNS-SD / mDNS. And comparable to a NetBIOS name.

Yes. I don’t know any service discovery protocol that *doesn’t* have “friendly names”.

The question was about a ubiquitous protocol for *setting* the “friendly name” that’s universally supported on (virtually) all devices.

> When I ask my router for a list of hosts on the network, and when I ask my BluRay player to show me a list of content sources (UPnP), the lists use the same names for devices (because these devices use the same name across protocols).

If one computer shares two USB printers on the network, do both shared printers have to appear with the same name (the same as the name of the computer that’s sharing them)? Restricting services to one-instance-per-host is quite limiting.

<https://tools.ietf.org/html/rfc6760#section-3.3> Address Services, Not Hardware

> Yes, there is also a UPnP Service defined that allows for remotely changing the friendly name. https://openconnectivity.org/upnp/specifications/friendlyinfoupdate1. But this service was only published in 2014 (long, long after the UPnP Device Architecture required "friendly name" in SSDP advertisements), it is not widely implemented (not mandatory to implement)

Do you personally own *any* device that supports this? I know the “standard” exists. My question was how many products actually implement it. The world is full of so-called “official standards” that no real-world products implement.

> FWIW, UPnP is an ISO/IEC standard.

Yes, a great example: OSI networking.

Stuart Cheshire

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Jul 2016 12:51:49 +0200

I think the point Barbara is making about consistency is right, and that we
may be in violent agreement. :)

In general there are devices that you'd like to be able to configure using
the network, and devices that you definitely do not want configured by the
network.

On Jul 21, 2016 12:31, "Stuart Cheshire" <[email-masked]> wrote:

> > UPnP SSDP announcements include a friendly name in the SSDP header. To
> me, this is comparable to the instance name in DNS-SD / mDNS. And
> comparable to a NetBIOS name.
>
> The question was about a ubiquitous protocol for *setting* the “friendly
> name” that’s universally supported on (virtually) all devices.
>
> > When I ask my router for a list of hosts on the network, and when I ask
> my BluRay player to show me a list of content sources (UPnP), the lists use
> the same names for devices (because these devices use the same name across
> protocols).
>
> If one computer shares two USB printers on the network, do both shared
> printers have to appear with the same name (the same as the name of the
> computer that’s sharing them)? Restricting services to
> one-instance-per-host is quite limiting.
>
> > Yes, there is also a UPnP Service defined that allows for remotely
> changing the friendly name.
> https://openconnectivity.org/upnp/specifications/friendlyinfoupdate1. But
> this service was only published in 2014 (long, long after the UPnP Device
> Architecture required "friendly name" in SSDP advertisements), it is not
> widely implemented (not mandatory to implement)
>
> Do you personally own *any* device that supports this? I know the
> “standard” exists. My question was how many products actually implement it.
> The world is full of so-called “official standards” that no real-world
> products implement.
>

---

From: Alf Watt <[email-masked]>
Date: Thu, 21 Jul 2016 06:10:27 -0700

Don't forget, good ol DHCPv4 provides option 12 for setting host names by the server: 

https://tools.ietf.org/html/rfc2132

Support will depend on the client respecting the option, which at least some Linux distributions don't seem to out of the box.

The option wasn't included (even for the more common case of the client requesting a name from the server) in DHCPv6, which suggests using DDNS for allowing the host to update the name after auto-configuration. 

http://www.ietf.org/rfc/rfc3315.txt

Best,
Alf

> On Jul 21, 2016, at 3:51 AM, Ted Lemon <[email-masked]> wrote:
> 
> I think the point Barbara is making about consistency is right, and that we may be in violent agreement. :)
> 
> In general there are devices that you'd like to be able to configure using the network, and devices that you definitely do not want configured by the network.
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Jul 2016 15:13:46 +0200

I have never seen a host that would accept an unauthenticated hostname
update from a DHCP server.

On Thu, Jul 21, 2016 at 3:10 PM, Alf Watt <[email-masked]> wrote:

> Support will depend on the client respecting the option, which at least
> some Linux distributions don't seem to out of the box.
>
> The option wasn't included (even for the more common case of the client
> requesting a name from the server) in DHCPv6, which suggests using DDNS for
> allowing the host to update the name after auto-configuration.
>
>> https://openconnectivity.org/upnp/specifications/friendlyinfoupdate1.
>> But this service was only published in 2014 (long, long after the UPnP
>> Device Architecture required "friendly name" in SSDP advertisements), it is
>> not widely implemented (not mandatory to implement)
>>

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 21 Jul 2016 13:22:05 +0000

+1
Thx. You said that so much better than I did. :)
And even where network configuration is desirable, a one-size-fits all ubiquitous solution is  not the right answer. We should not design an architecture with such a dependency.
Barbara

On Jul 21, 2016, at 12:51 PM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

On Jul 21, 2016 12:31, "Stuart Cheshire" <[email-masked]<mailto:[email-masked]>> wrote:

Stuart Cheshire

---

From: Alf Watt <[email-masked]>
Date: Thu, 21 Jul 2016 06:48:09 -0700

Not have I, which seems suggestive: the feature has at least two proposed methods (UPnP and DHCPv4) and neither has been widely implemented in clients.

It appears that clients which the IT staff doesn't already control do not want the network to be able to choose their name. I expect for the usability reasons already discussed: if the name is changed the user will have to learn the new name somehow.

One other common method of host name configuration which hasn't come up is configuration profiles, which can automate away having (or allowing) the user to set the host name (or have one generated for them in setup). 

Best,
Alf

> On Jul 21, 2016, at 6:13 AM, Ted Lemon <[email-masked]> wrote:
> 
> I have never seen a host that would accept an unauthenticated hostname update from a DHCP server.
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Jul 2016 15:50:32 +0200

Right, the security model for having "the network" change the device's name
is wrong.   That doesn't mean it's not a problem that needs to be solved.
It may indeed be that there is no point in trying to address it in homenet;
I would certainly agree that it's not a high priority.   The main reason
it's of interest at all is for resolving name collisions.

In that sense, we _do_ have a way of making the device change its name--we
just don't get the opportunity to suggest a new name for it.

On Thu, Jul 21, 2016 at 3:48 PM, Alf Watt <[email-masked]> wrote:

> Not have I, which seems suggestive: the feature has at least two proposed
> methods (UPnP and DHCPv4) and neither has been widely implemented in
> clients.
>
> It appears that clients which the IT staff doesn't already control do not
> want the network to be able to choose their name. I expect for the
> usability reasons already discussed: if the name is changed the user will
> have to learn the new name somehow.
>
> One other common method of host name configuration which hasn't come up is
> configuration profiles, which can automate away having (or allowing) the
> user to set the host name (or have one generated for them in setup).
>
> Best,
> Alf
>
>> In general there are devices that you'd like to be able to configure
>> using the network, and devices that you definitely do not want configured
>> by the network.
>>
>>> > When I ask my router for a list of hosts on the network, and when I
>>> ask my BluRay player to show me a list of content sources (UPnP), the lists
>>> use the same names for devices (because these devices use the same name
>>> across protocols).
>>>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Jul 2016 15:51:20 +0200

One option, by the way, would be to simply pop up some kind of warning if a
two devices come on the network with the same name, and leave it to the
user to fix it (or not).

On Thu, Jul 21, 2016 at 3:50 PM, Ted Lemon <[email-masked]> wrote:

> Right, the security model for having "the network" change the device's
> name is wrong.   That doesn't mean it's not a problem that needs to be
> solved.   It may indeed be that there is no point in trying to address it
> in homenet; I would certainly agree that it's not a high priority.   The
> main reason it's of interest at all is for resolving name collisions.
>
>> One other common method of host name configuration which hasn't come up
>> is configuration profiles, which can automate away having (or allowing) the
>>>> > UPnP SSDP announcements include a friendly name in the SSDP header.
>>>> To me, this is comparable to the instance name in DNS-SD / mDNS. And
>>>> The question was about a ubiquitous protocol for *setting* the
>>>> “friendly name” that’s universally supported on (virtually) all devices.
>>>>

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 21 Jul 2016 08:34:33 -0700

> And even where network configuration is desirable, a one-size-fits all ubiquitous solution is not the right answer. We should not design an architecture with such a dependency. 

Sorry, I’m getting confused by this discussion.

The discussion in the meeting was that pretty much all network devices (apart from my SMA solar inverters) can have their name set today over the network, but not using a one-size-fits-all ubiquitous solution. It’s ad hoc. Many devices have their name set via web UI. Some devices have their name set via some proprietary app. Others have their name set using some non-web protocol like Apple’s HomeKit. Some have their name set via physical controls on the device itself. The assertion in the meeting was that this is no good and we need a one-size-fits-all ubiquitous solution. UPnP was offered as that one-size-fits-all ubiquitous solution. Now we’re saying that a one-size-fits-all ubiquitous solution is *not* the right answer.

I’m confused. It sounds like we’re back to saying what we have already today is just fine (apart from my SMA solar inverters -- I need to find out how to file a bug report for that).

Stuart Cheshire

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Jul 2016 18:06:13 +0200

Hm.   That's not what I'm saying.  The point Barbara made that I agree with
and restated was that the device should report the same name no matter who
asks or how.   IOW, we can't just change its name in the homenet naming
infrastructure: it needs to know and accept the new name.

In some cases, we don't want to trust the network infrastructure to set our
name--e.g., it used to bug the hell out of me when my Mac would take its
name from the PTR record and wind up with something nonsensical;
fortunately my Chromebook doesn't do this, nor does my Android phone.

For these cases, the only alternative we have at present is a UI on the
device, or on a web page provided by the device.   It might be nice to have
a trustworthy mechanism for doing this, but we don't have a security
architecture that would support that.

However, for other devices, being able to assign the name using the network
infrastructure is perfectly fine.   I think the main distinction is
"infrastructure/IoT devices" versus personal devices that roam with the
user.

On Thu, Jul 21, 2016 at 5:34 PM, Stuart Cheshire <[email-masked]> wrote:

> > And even where network configuration is desirable, a one-size-fits all
> ubiquitous solution is not the right answer. We should not design an
> architecture with such a dependency.
> > Barbara
>
> The discussion in the meeting was that pretty much all network devices
> (apart from my SMA solar inverters) can have their name set today over the
> network, but not using a one-size-fits-all ubiquitous solution. It’s ad
> hoc. Many devices have their name set via web UI. Some devices have their
> name set via some proprietary app. Others have their name set using some
> non-web protocol like Apple’s HomeKit. Some have their name set via
> physical controls on the device itself. The assertion in the meeting was
> that this is no good and we need a one-size-fits-all ubiquitous solution.
> UPnP was offered as that one-size-fits-all ubiquitous solution. Now we’re
> saying that a one-size-fits-all ubiquitous solution is *not* the right
> answer.
>
> I’m confused. It sounds like we’re back to saying what we have already
> today is just fine (apart from my SMA solar inverters -- I need to find out
> how to file a bug report for that).
>
> Stuart Cheshire
>
>

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 21 Jul 2016 10:07:45 -0700

On 21 Jul 2016, at 09:06, Ted Lemon <[email-masked]> wrote:

> Hm.   That's not what I'm saying.  The point Barbara made that I agree with and restated was that the device should report the same name no matter who asks or how.

For the most part, this is universally true today. Of all the devices I’ve seen that support both UPnP and Bonjour DNS-SD/mDNS, virtually have a single place in the web UI to set the name, which is then used for both discovery protocols.

I have seen a few some rare exceptions where they allow you to set two different names if you want, but I’ve never seen any case where the user didn’t set them both to the same thing.

Stuart Cheshire

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Jul 2016 19:24:05 +0200

Right, the issue would be if we changed it in the database operated by the
homenet, and didn't tell the host.

On Thu, Jul 21, 2016 at 7:07 PM, Stuart Cheshire <[email-masked]> wrote:

> > Hm.   That's not what I'm saying.  The point Barbara made that I agree
> with and restated was that the device should report the same name no matter
> who asks or how.
>
> For the most part, this is universally true today. Of all the devices I’ve
> seen that support both UPnP and Bonjour DNS-SD/mDNS, virtually have a
> single place in the web UI to set the name, which is then used for both
> discovery protocols.
>
> I have seen a few some rare exceptions where they allow you to set two
> different names if you want, but I’ve never seen any case where the user
> didn’t set them both to the same thing.
>
> Stuart Cheshire
>
>

---

From: "Christian Huitema" <[email-masked]>
Date: Sun, 24 Jul 2016 11:02:26 +0200

On Thursday, July 21, 2016 7:24 PM, Ted Lemon wrote:

> Right, the issue would be if we changed it in the database operated by 
> the homenet, and didn't tell the host.
>
> On Thu, Jul 21, 2016 at 7:07 PM, Stuart Cheshire <mailto:[email-masked]> wrote:
>> On 21 Jul 2016, at 09:06, Ted Lemon <mailto:[email-masked]> wrote:
>>

Please let's not forget the privacy issues for mobile devices. There is an intarea draft about that, "hostname practices considered harmful." In short, volunteering a name to the network allows tracking; volunteering a user friendly name like "Ted Lemon's laptop" allows for even better tracking.

For DHCP, the "privacy" recommendation is to not volunteer a name at all to the DHCP server, or to use a one-time random name. 

Now, I can understand that these one-time random names should be more user friendly than "F78AC123", maybe using something like "correct-horse-battery-staple" in the tradition of https://www.xkcd.com/936/. 

-- Christian Huitema

---

From: "Christian Huitema" <[email-masked]>
Date: Sun, 24 Jul 2016 11:02:26 +0200

-- Christian Huitema

---

From: Ted Lemon <[email-masked]>
Date: Sun, 24 Jul 2016 12:14:38 +0200

Yes. There are two separate problems here: how to name services that are
being advertised, for which presumably we do not want privacy, and how to
deal with devices whose identification should be private, but with which
there might still be a need to rendezvous.

The reason I was so enthusiastic about your presentation in dnssd is that
it very nicely solves this second  problem.  But we still have the first
problem.

On Jul 24, 2016 11:02 AM, "Christian Huitema" <[email-masked]> wrote:

> >> For the most part, this is universally true today. Of all the devices
> I’ve seen that support both UPnP and Bonjour DNS-SD/mDNS, virtually have a
> Please let's not forget the privacy issues for mobile devices. There is an
> intarea draft about that, "hostname practices considered harmful." In
> short, volunteering a name to the network allows tracking; volunteering a
> user friendly name like "Ted Lemon's laptop" allows for even better
> tracking.
>
> For DHCP, the "privacy" recommendation is to not volunteer a name at all
> to the DHCP server, or to use a one-time random name.
>
> Now, I can understand that these one-time random names should be more user
> friendly than "F78AC123", maybe using something like
> "correct-horse-battery-staple" in the tradition of
> https://www.xkcd.com/936/.
>
> -- Christian Huitema
>
>
>
>

---

From: Tim Chown <[email-masked]>
Date: Mon, 25 Jul 2016 19:36:55 +0000

Hi,

On 24 Jul 2016, at 11:14, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

Yes. There are two separate problems here: how to name services that are being advertised, for which presumably we do not want privacy, and how to deal with devices whose identification should be private, but with which there might still be a need to rendezvous.

The reason I was so enthusiastic about your presentation in dnssd is that it very nicely solves this second  problem.  But we still have the first problem.

Indeed :)

Well, the hosts have names, and those are coupled with service information, where the service names are well-known. For example, I see "Living Room Apple TV._airplay._tcp.local.” advertised while sat here in my lounge, for a device with name living-room-apple-tv.local, and the airplay service for screen sharing.

As an example of default names that are far from ideal in a “coffee shop” environment, an iPhone will have default name like freds-iphone.local, an iPad will have sarahs-ipad.local. A 30-minute harvest of multicast DNS in a recent event harvested me the names (first, or full) of over half of the attendees.

I note my employer very thoughtfully gave my Mac a name of the form JNTXX0012345. That’s obfuscated in a sense, but also quite likely to be a globally unique name, and one I could therefore be tracked by.  So as Christian says we definitely want privacy support when we expose names via service discovery protocols.

On name clashes, my own Mac is simply “Tims-MacBook-Pro”, which is a more friendly name, but I’ve been at meetings big enough before that such friendly names will clash, and thus my device then appears on the network as Tims-MacBook-Pro-2”.  That’s not the network renaming me, it’s my own host picking a new name. But if we flatten a multi-link homenet, we will need this capability unless we embed link names, which as we discussed at the meeting is not desirable. Ted suggested some ideas on this front.

How you change the name will depend on the device; it might be via a GUI, command line, or web interface. Seeking a new common standard for this seems, well, optimistic. But I’d expect to be able to change my device’s name whenever I chose, if I had appropriate privileges on it, and then DNS-SD protocols would propagate the change. So I’d disagree with an assertion that devices must not allow the name to be trivially changed, once set.

I think the requirements will become clearer once Ted and whoever offers to help can formulate a -00 of what I think we’re now calling the “flat homenet” model.

Tim

On Jul 24, 2016 11:02 AM, "Christian Huitema" <[email-masked]<mailto:[email-masked]>> wrote:
On Thursday, July 21, 2016 7:24 PM, Ted Lemon wrote:

> On Thu, Jul 21, 2016 at 7:07 PM, Stuart Cheshire <mailto:[email-masked]<mailto:[email-masked]>> wrote:
>> On 21 Jul 2016, at 09:06, Ted Lemon <mailto:[email-masked]<mailto:[email-masked]>> wrote:
>>

-- Christian Huitema

---

From: william manning <[email-masked]>
Date: Thu, 28 Jul 2016 04:27:22 -0700

i've been in this neighborhood before.  Not sure there exists a clearly
defined meaning for "friendly".  That said, there exists a canonical name.
Others (governments, DNS admins, DHCP, UPnP, et.al.) are external, third
parties and often set their own rules as to the "name" of an entity in
their own context.  Thirdly, a name often consists of several facets or
attributes.  The construct that was used for the Client Based Naming system
was tripart;  a) a string of unicode labels,  b) a cryptographic
certificate for the string of unicode labels,  and  c) a locality reference
where the string and the certificate were first bound.
All non-canonical names were derived from one or more facets or fragments
of facets of the canonical name.  A shorter name most of the time,