Subject: [dnssd] DNS-SD Discovery Proxy

From: Tom Pusateri <[email-masked]>
Date: Wed, 16 Nov 2016 20:57:02 -0500

So you are proposing calling it the DNS Service Discovery Discovery Proxy (DNS-SD Discovery Proxy)?

or are you prosing calling it the DNS Service Discovery Proxy (DNS-SD Proxy)?

Thanks,
Tom

---

From: Tim Chown <[email-masked]>
Date: Thu, 17 Nov 2016 05:28:09 +0000

Hi Tom,

> On 17 Nov 2016, at 01:57, Tom Pusateri <[email-masked]> wrote:
> 

I had assumed the former.

And subsequently a DNS-SD Advertisement Proxy.

But comments welcome.

Tim

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 17 Nov 2016 12:51:26 -0500

> On Nov 17, 2016, at 12:28 AM, Tim Chown <[email-masked]> wrote:
> 
> Hi Tom,
> 

My preference would be to choose another adjective. “Service Discovery” is the umbrella under which the technologies are rooted. Having one of those technologies be a Discovery Proxy is unnecessarily confusing.

Locater Proxy?
Identity Proxy?
Observation Proxy?
Exploration Proxy?

Or any number of other words not being Discovery Discovery. :)

Tom

---

From: Tim Chown <[email-masked]>
Date: Fri, 18 Nov 2016 01:13:58 +0000

> On 17 Nov 2016, at 17:51, Tom Pusateri <[email-masked]> wrote:
> 
> 

I suspect most people say “DNS-SD” rather than expanding it, in conversation and in documents, so wouldn’t generally speak or read those words.

Hopefully as IETF winds down we’ll get some other comments on this.  We certainly have strong (unanimous in the room) consensus to rename from Hybrid.

Tim

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 18 Nov 2016 01:50:20 +0000

> I suspect most people say “DNS-SD” rather than expanding it, in conversation
> and in documents, so wouldn’t generally speak or read those words.
> 
> Hopefully as IETF winds down we’ll get some other comments on this.  We
> certainly have strong (unanimous in the room) consensus to rename from
> Hybrid.

I'd really, really like to see "Discovery Proxy" kept in the name (DNS-SD Discovery Proxy). I'm working on a project in another organization that is defining a "Discovery Proxy" in its context, which synchs extremely closely with what this thingie here is doing in the context of DNS-SD. It makes it so much easier when people use the same terms to describe the same functionality independent of where it was invented. That really improves overall industry understanding of the concept.
Barbara

---

From: David Farmer <[email-masked]>
Date: Thu, 17 Nov 2016 20:20:27 -0600

On Thu, Nov 17, 2016 at 7:50 PM, STARK, BARBARA H <[email-masked]> wrote:

> I'd really, really like to see "Discovery Proxy" kept in the name (DNS-SD
> Discovery Proxy). I'm working on a project in another organization that is
> defining a "Discovery Proxy" in its context, which synchs extremely closely
> with what this thingie here is doing in the context of DNS-SD. It makes it
> so much easier when people use the same terms to describe the same
> functionality independent of where it was invented. That really improves
> overall industry understanding of the concept.
> Barbara

+1

Informally; DNS-SD Discovery Proxy
Formally; Discovery Proxy for DNS-Based Service Discovery

But yes, DNS-Based Service Discovery Discovery Proxy is ugly, so just don't
use that order of the words.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Tim Chown <[email-masked]>
Date: Tue, 22 Nov 2016 13:50:13 +0000

Hi,

> On 18 Nov 2016, at 02:20, David Farmer <[email-masked]> wrote:
> 
> But yes, DNS-Based Service Discovery Discovery Proxy is ugly, so just don't use that order of the words.

OK, I think we’ve confirmed consensus on the term DNS-SD Discovery Proxy.

Stuart, please do submit a final -06 using this name.

Best wishes,
Tim