Subject: Re: [dnssd] When does MDNS/DNS-SD use IPv6?

From: Hagen Paul Pfeifer <[email-masked]>
Date: Thu, 19 Jan 2017 11:24:13 +0100

Am 19.01.2017 09:29 schrieb Erik Kline <[email-masked]>:

On networks with even moderate numbers of hosts it can be quite a lot

of traffic.  This is frequently a concern for battery impact (to those

devices that are primarily battery powered).  (We see bug reports

about this stuff.

Ack, from a power consumption point of view it is beneficial if the time span between both transmitted packets are as short as possible to wake the CPU one time and not two. So reducing C state transitions into C0 and friends.

---

From: "Christian Huitema" <[email-masked]>
Date: Thu, 19 Jan 2017 21:19:15 -0800

On Thursday, January 19, 2017 2:24 AM, Paul Pfeifer wrote:

> Am 19.01.2017 09:29 schrieb Erik Kline <mailto:[email-masked]>:
>
> Ack, from a power consumption point of view it is beneficial if the time span between both 
> transmitted packets are as short as possible to wake the CPU one time and not two. So 
> reducing C state transitions into C0 and friends.

If we believe that modern platforms all do IPv6 & IPv4, then the optimization for the common case would be something like "try IPv6 first; collect results; after a short timer, repeat query on IPv4, filling the list of known answers with what was learned over IPv6; collect results; on subsequent timers, alternate repeat on IPv6 and IPv4, with the list of known answers collecting everything received so far through either v4 or v6." That would reduce overhead, while still allowing for some IPv6 only or IPv4 only hosts.

-- Christian Huitema