Subject: Re: [dnssd] When does MDNS/DNS-SD use IPv6?

From: Hagen Paul Pfeifer <[email-masked]>
Date: Thu, 19 Jan 2017 09:16:35 +0100

Am 19.01.2017 02:13 schrieb Christian Huitema <[email-masked]>:

> The Apple open source mDNSResponder implementation sends both queries in parallel.

OK. But if we all nodes do that and if all nodes publish their records on both IPv4 and IPv6, there is going to be a fair amount of duplicate traffic. More on potential fixes later in this message.

Fair amount of what? DNS, OK, but considering all traffic it is probably neglicable. As always: it is a compromise between implementation complexity, already deployed software, new extensions, new bugs and other factors. And hoping that in a not so far future IPv6 only networks exists.

Hagen

---

From: Erik Kline <[email-masked]>
Date: Thu, 19 Jan 2017 17:29:16 +0900

On 19 January 2017 at 17:16, Hagen Paul Pfeifer <[email-masked]> wrote:
> OK. But if we all nodes do that and if all nodes publish their records on
> both IPv4 and IPv6, there is going to be a fair amount of duplicate traffic.
> More on potential fixes later in this message.
>
>
> Fair amount of what? DNS, OK, but considering all traffic it is probably
> neglicable. As always: it is a compromise between implementation complexity,
> already deployed software, new extensions, new bugs and other factors. And
> hoping that in a not so far future IPv6 only networks exists.

On networks with even moderate numbers of hosts it can be quite a lot
of traffic.  This is frequently a concern for battery impact (to those
devices that are primarily battery powered).  (We see bug reports
about this stuff.)