Subject: [dnssd] Alexey Melnikov's No Objection on draft-ietf-dnssd-hybrid-07: (with COMMENT)

From: Alexey Melnikov <[email-masked]>
Date: Wed, 29 Nov 2017 09:58:23 -0800

Alexey Melnikov has entered the following ballot position for
draft-ietf-dnssd-hybrid-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dnssd-hybrid/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This is a well written document. I have a few clarifying questions which I
think will improve the document.

In 5.3:

   To accomodate this difference in allowable characters, a Discovery
   Proxy SHOULD support having two separate subdomains delegated to it
   for each link it serves, one whose name is allowed to contain
   arbitrary Net-Unicode text [RFC5198], and a second more constrained
   subdomain whose name is restricted to contain only letters, digits,
   and hyphens, to be used for host name records (names of 'A' and

Am I correct that Punicode encoded A-Labels are still valid here? It would be
good to say so.

   'AAAA' address records).

5.5.4.  No Text Encoding Translation

   A Discovery Proxy does no translation between text encodings.
   Specifically, a Discovery Proxy does no translation between Punycode

Punycode needs an Informative reference.

   and UTF-8,

---

From: Dave Thaler <[email-masked]>
Date: Wed, 29 Nov 2017 19:51:41 +0000

>Punycode needs an Informative reference.

Indeed, and the grammatical use of Punycode in this sentence is actually wrong.
"Punycode is an Algorithm, Not a Name or Adjective" (https://tools.ietf.org/html/rfc5890#section-2.3.4)

The informative reference would be RFC 3492 but the text should be something closer to
"a Discovery Proxy does no translation between Punycode-encoded strings and UTF-8 strings", or
probably more correctly "a Discovery Proxy does no translation between A-labels and U-labels".

Dave