Subject: [dnssd] DNSSD at WWDC

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2019 09:26:03 -0400

Since we’ve been talking about interest in DNSSD, it might be worth mentioning that yesterday evening there was a presentation at WWDC on improvements that have been done to Bonjour in the new release of the software that was announced on Monday.   You can see the presentation here:

https://developer.apple.com/videos/play/wwdc2019/713/

It will refuse to play it on Chrome, but you can download it with the link here: https://devstreaming-cdn.apple.com/videos/wwdc/2019/713b310k72bjpcmz6xn/713/713_sd_advances_in_networking_part_2.mp4?dl=1 <https://devstreaming-cdn.apple.com/videos/wwdc/2019/713b310k72bjpcmz6xn/713/713_sd_advances_in_networking_part_2.mp4?dl=1>

The whole presentation is really good stuff, but the part that is of particular interest to the WG would be from about 1:00 to about 3:00, where Erik (whom many of you probably know) describes the new feature.   The new feature is an implementation of the work we’ve done here, including DNS Push and the DNS Discovery Proxy.   This is really cool stuff.

The code for the Discovery Proxy, along with instructions for how to install it, is here:

https://github.com/IETF-Hackathon/mDNSResponder/blob/master/README.md <https://github.com/IETF-Hackathon/mDNSResponder/blob/master/README.md>

Fair warning: the developer seed is a seed, use it at your own risk.

---

From: David Schinazi <[email-masked]>
Date: Sat, 8 Jun 2019 10:20:15 +0200

For the record it plays fine for me on Chrome (on a Mac).

Congratulations to everyone at Apple for a great talk, I'm excited to see
the working group's work ship to billions of devices.

On Fri, Jun 7, 2019 at 3:26 PM Ted Lemon <[email-masked]> wrote:

> Since we’ve been talking about interest in DNSSD, it might be worth
> mentioning that yesterday evening there was a presentation at WWDC on
> improvements that have been done to Bonjour in the new release of the
> software that was announced on Monday.   You can see the presentation here:
>
> It will refuse to play it on Chrome, but you can download it with the link
> here:
> https://devstreaming-cdn.apple.com/videos/wwdc/2019/713b310k72bjpcmz6xn/713/713_sd_advances_in_networking_part_2.mp4?dl=1
>
> The whole presentation is really good stuff, but the part that is of
> particular interest to the WG would be from about 1:00 to about 3:00, where
> Erik (whom many of you probably know) describes the new feature.   The new
> feature is an implementation of the work we’ve done here, including DNS
> Push and the DNS Discovery Proxy.   This is really cool stuff.
>
> https://github.com/IETF-Hackathon/mDNSResponder/blob/master/README.md
> <https://github.com/IETF-Hackathon/mDNSResponder/blob/master/README..md>
>
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>