Subject: Re: [dnssd] WG participation (or lack there of)

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2019 19:11:20 -0400

On May 31, 2019, at 8:33 PM, Olafur Gudmundsson <[email-masked]> wrote:
> I think you are right and with only 2 people interested in the work it is time to close the WG 

It is a concern to me that the number of people who are interested in this and paying attention to the mailing list and replying seems low, but at the same time work is going on to deploy our work in the industry.   All of the major O.S. vendors support it.   One option would be to go forward with the remaining work as ISE documents, with the potential that the IETF might want to update them later.

I would be curious to know your opinion on this: do you feel that you would rather that this stuff not be documented, or are you concerned that there aren’t enough people here doing review?

---

From: Daniel KAISER <[email-masked]>
Date: Tue, 11 Jun 2019 17:13:40 +0200

Regarding the privacy aspects of (m)DNS-SD:
I still think it would be beneficial to finalize a document on a 
privacy-extension,
and I still want to work on that.

I agree, the lack of feedback within the group is a problem;
we have come up with quite a few different proposals and there is no 
clear "favorite".
Also, I see the problem that we try to solve too many use cases with a 
single specification
(p2p mobile devices, classical  DNS server, printer, ...).

For P2P applications like the tic-tac-toe example from the WWDC talks,
the PSK could be extracted from the TLS connection and be used to derive 
a secret for obfuscating the
service related information for the (next) discovery process.
The interface matches the one from our proposal for a DNS-SD/mDNS based 
manually authenticated
device pairing protocol.
We could either go in the TLS/ESNI direction or stick with our older 
proposals and seamlessly
integrate a privacy extension into mDNS-SD / Bonjour.

Listening to the great talks by Apple I wonder if Apple is interested in 
working with us on
a specification that would fit Apple's use cases of Bonjour.

If someone is interested, I would be happy to collaborate.
(However, as I work at a University and the projects I am involved in 
currently are not directly related
to (m)DNS-SD, the time I can spend on this topic is limited until I find 
a matching project.)

Kind regards,
Daniel

On 6/8/19 1:11 AM, Ted Lemon wrote:
> On May 31, 2019, at 8:33 PM, Olafur Gudmundsson <[email-masked] 
> <mailto:[email-masked]>> wrote:
> It is a concern to me that the number of people who are interested in 
> this and paying attention to the mailing list and /replying/ seems 
> low, but at the same time work is going on to deploy our work in the 
> industry.   All of the major O.S. vendors support it.   One option 
> would be to go forward with the remaining work as ISE documents, with 
> the potential that the IETF might want to update them later.
>
> I would be curious to know your opinion on this: do you feel that you 
> would rather that this stuff not be documented, or are you concerned 
> that there aren’t enough people here doing review?
>
>
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd

-- 

Dr. Daniel Kaiser
Research Associate
SnT- Interdisciplinary Centre for Security, Reliability and Trust

University of Luxembourg
Maison du Nombre (MNO)
6, avenue de la Fonte
L-4364 Esch-sur-Alzette
Office: E02 0225-010

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Jun 2019 11:19:33 -0400

Thanks, Daniel.   IIRC, some folks at Apple have been involved in working on the spec.   I think part of the radio silence that you’re hearing is that the Apple product cycle is such that the period from March to June is actually a very busy time, and so there just aren’t cycles for IETF between the spring and summer meetings.

> On Jun 11, 2019, at 11:13 AM, Daniel KAISER <[email-masked]> wrote:
> 
> I still think it would be beneficial to finalize a document on a privacy-extension,
> we have come up with quite a few different proposals and there is no clear "favorite".
> Also, I see the problem that we try to solve too many use cases with a single specification
> the PSK could be extracted from the TLS connection and be used to derive a secret for obfuscating the
> The interface matches the one from our proposal for a DNS-SD/mDNS based manually authenticated
> device pairing protocol.
> We could either go in the TLS/ESNI direction or stick with our older proposals and seamlessly
> Listening to the great talks by Apple I wonder if Apple is interested in working with us on
> (However, as I work at a University and the projects I am involved in currently are not directly related
> to (m)DNS-SD, the time I can spend on this topic is limited until I find a matching project.)
> 
> Kind regards,
> Daniel
> 
> 
> 
>> On May 31, 2019, at 8:33 PM, Olafur Gudmundsson <[email-masked] <mailto:[email-masked]>> wrote:
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/dnssd <https://www.ietf.org/mailman/listinfo/dnssd>
> 
> -- 
> 
> Dr. Daniel Kaiser
> Research Associate

---

From: Daniel KAISER <[email-masked]>
Date: Tue, 11 Jun 2019 20:25:58 +0200

On 6/11/19 5:19 PM, Ted Lemon wrote:
> Thanks, Daniel.   IIRC, some folks at Apple have been involved in working on the spec. 
Sorry, I forgot Bob Bradley is with Apple.
I will ask him and Christian Christian Huitema for a phone conference.
Imho, orally discussing our various approaches while taking Apple's use
cases into consideration
might help progressing and unifying the drafts.
(Most likely, I will not be able to attend the next IETF meeting.)
>   I think part of the radio silence that you’re hearing is that the Apple product cycle is such that the period from March to June is actually a very busy time, and so there just aren’t cycles for IETF between the spring and summer meetings.
>

University of Luxembourg
Maison du Nombre (MNO)
6, avenue de la Fonte
L-4364 Esch-sur-Alzette
Office: E02 0225-010

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Jun 2019 14:32:10 -0400

> (Most likely, I will not be able to attend the next IETF meeting.)

Unfortunate.  Maybe we can arrange an online meeting during one of the breakout session periods.