Subject: [domainrep] JSON vs. XML

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 17 Feb 2012 12:05:40 -0800

With respect to the JSON vs. XML question for REPUTE, the same debate is currently raging over on the WEIRDS list.  We can possibly learn from the argument happening over there in terms of resolving that question in this context.

-MSK

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 17 Feb 2012 15:09:15 -0800

On 2/17/2012 12:05 PM, Murray S. Kucherawy wrote:
> With respect to the JSON vs. XML question for REPUTE, the same debate is
> currently raging over on the WEIRDS list.  We can possibly learn from the
> argument happening over there in terms of resolving that question in this context.

I thought the discussion in our group was pretty rationale and thorough. 
Perhaps /they/ should learn from /us/?

Or do they have some additional insights?

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 17 Feb 2012 15:13:55 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Dave CROCKER
> Sent: Friday, February 17, 2012 3:09 PM
> To: [email-masked]
> Subject: Re: [domainrep] JSON vs. XML
> 

It's certainly the case that we might learn how NOT to solve this problem for repute.  :-)

But I was just suggesting that someone over there might think of some angle we over here hadn't considered yet.

---

From: Douglas Otis <[email-masked]>
Date: Fri, 17 Feb 2012 15:25:44 -0800

> But I was just suggesting that someone over there might think of some angle we over here hadn't considered yet.
Dear Murray,

JSON offers more efficient data encapsulation important for DNS or CoRE 
related applications.  Our own internal processing uses similar 
inversion of the name space so string sorting will group domains 
according to name hierarchy.  XML lacks these important advantages.

Regards,
Douglas Otis

---

From: "John Levine" <[email-masked]>
Date: 18 Feb 2012 01:33:46 -0000

>I thought the discussion in our group was pretty rational and thorough. 

I got the insight that the people who want to build something that
works and ship it think that JSON is fine, while the ones who want to
have endless meetings to debate data dictionaries and multiple open
ended data formats think that XML is essential.

Or did you mean something else?

R's,
John