Subject: Re: [domainrep] rDNS identifiers

From: Andreas Schulze <[email-masked]>
Date: Wed, 18 Jul 2012 20:42:36 +0200

Am 29.06.2012 12:37 schrieb Jacob R Rideout:
> Has anyone on the list considered the use of the IPv4 (or v6) PTR rDNS
> value as an identifier? Or more strictly, a fully qualified domain name, that also
> resolves to the queried IP address.

Hi,

MTX is (not very common) but much stricter.
see http://www.chaosreigns.com/mtx/

It's like a distributed selfmade whitelisting/reputation.

Consider I have an IP-Address 192.0.2.1 assigned to my mailserver. I like to send mail.
The receiver usually will reverse lookup that IP.
1.2.0.192.in-addr.arpa. PTR -> outbound-mailer.example.org.
That's all.

Next the receiver *may* doublecheck the name resolv too.
I personaly don't expect that the name resolv to 192.0.2.1.
If I would force that on my MX I would lose too much legit mail.
So the doublecheck is not practical for most people. So normal "dnscheck" ends with "sender has any rDNS".

But I as a sender could do more. I could state that I *do* have control over the dns zone
my PTR points to. That's usual if I own ip space. It's unusual for a dialup.

I can provide an A record 1.2.0.192.mtx.outbound-mailer.example.org. = 127.0.0.1
If the receiver ask for that record he knows that
 - I control the rdns zone
 - I control the forward zone
 - I really spend my time to setup such records.
The receiver may notice my much greater interest that my mails are delivered.

In fact that is a nice scheme to intoduce someone as a mailsender.
without having reputation history.
It definitly drops sender how do not control rDNS.

It does not pervent abusers to setup such records. But that ips could be blocked.
That's a decision every receiver could meet for himself. (or use a central blacklist)

Andreas

---

From: Steve Allam <[email-masked]>
Date: Thu, 19 Jul 2012 11:34:01 +0100

Are there any numbers on the take-up of MTX?

Regards,

Steve

On 18/07/2012 19:42, Andreas Schulze wrote:
> _______________________________________________
> domainrep mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/domainrep

---

From: "Andreas Schulze" <[email-masked]>
Date: Thu, 19 Jul 2012 14:02:10 +0200

Steve,

> Are there any numbers on the take-up of MTX?
I'm aware of two peaple using it: darxus and me.

I talked about MTX last year in a german mailserver conference but got no questions or feedback.
The is a SA plugin available which I use at our enterprise class mx.

Andreas

---

From: "Andreas Schulze" <[email-masked]>
Date: Mon, 23 Jul 2012 07:46:59 +0200

Steve,

> I'm aware of two peaple using it: darxus and me.

I asked at the sa mailinglist for mtx.
got 2 responses. It's not very popular ...

Andreas