Subject: [Dots] Proof-of-concept for the DOTS protocol

From: "Sandra Escandor-O'Keefe" <[email-masked]>
Date: Fri, 3 Mar 2017 15:09:04 -0330

Hello,

I've been looking over the DOTS protocol documentation, and have been
looking for a way to contribute to this project. I've created a small PoC
for it, so that I could understand the protocol better. As the PoC project
is in its early stages, I'd like to receive some feedback and suggestions.

So far, the PoC currently performs heartbeat processing, and I'm currently
working on implementing mitigation request handling. The project can be
found at: https://github.com/sescandor/DOTS

Thanks for your feedback, and if there's another way that I could also
contribute, let me know.

-- 

*Sandra Escandor-O'Keefe* | Security Engineer
fastly.com | @fastly <https://twitter.com/fastly> | LinkedIn
<http://www.linkedin.com/company/fastly>

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 10 Mar 2017 19:04:44 +0000

Hello Sandra!

Running code is great feedback for the working group.  Thanks for doing this work and sharing it with us.

To clarify:
** the code appears to be implementing draft-teague-dots-protocol-02, correct?
** are there any early lessons learned that would inform the draft specification/WG?

Again, thanks for sharing!
Roman

From: Dots [mailto:[email-masked]] On Behalf Of Sandra Escandor-O'Keefe
Sent: Friday, March 3, 2017 1:39 PM
To: [email-masked]
Subject: [Dots] Proof-of-concept for the DOTS protocol

Hello,

I've been looking over the DOTS protocol documentation, and have been looking for a way to contribute to this project. I've created a small PoC for it, so that I could understand the protocol better. As the PoC project is in its early stages, I'd like to receive some feedback and suggestions.

So far, the PoC currently performs heartbeat processing, and I'm currently working on implementing mitigation request handling. The project can be found at: https://github.com/sescandor/DOTS

Thanks for your feedback, and if there's another way that I could also contribute, let me know.

--

[http://www.fastly.com/img/sig.png]
Sandra Escandor-O'Keefe | Security Engineer
fastly.com<http://fastly.com/> | @fastly<https://twitter.com/fastly> | LinkedIn<http://www.linkedin.com/company/fastly>