Subject: Re: [Dots] My review of draft-ietf-dots-use-cases

From: Daniel Migault <[email-masked]>
Date: Thu, 27 Apr 2017 13:40:58 +0000

Hi,

Please see the figure added by Kaname to the current repo [1].

Please note that the repo to consider is the one associated to the WG, that is dotswg/dots-use-cases [1]

Yours,
Daniel

https://github.com/dotswg/dots-use-cases/pull/1/commits/e8e75ff1940b136afeb81d47e0a7d6aea20028ad

From: kaname nishizuka [mailto:[email-masked]]
Sent: Wednesday, April 26, 2017 11:32 PM
To: Daniel Migault <[email-masked]>; Teague, Nik <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: My review of draft-ietf-dots-use-cases

Hi Daniel,

I made a pull request of "adding a figure for the orchetsrator use case."
https://github.com/mglt/draft-ietf-dots-use-cases/pull/4/files

The proposed figure is like this (I hope your editor aligns the figure properly)
           +----------+
           | network  |C
           | adminis  |<-+
           | trator   |  |
           +----------+  |
                         |                       (internal)
           +----------+  | S+--------------+     +-----------+
           |telemetry/|  +->|              |C   S| DDoS      |+
           |monitoring|<--->| Orchestrator |<--->| mitigation||
           |systems   |C   S|              |<-+  | systems   ||
           +----------+     +--------------+C |  +-----------+|
                                              |    +----------+
                                              |
                                              |  (external)
                                              |  +-----------+
                                              | S| DDoS      |
                                              +->| mitigation|
                                                 | systems   |
                                                 +-----------+
           * C is for DOTS client functionality
           * S is for DOTS server functionality

   Figure 1: DDoS Orchestration

Please see if the figure is fitting to the text of the dots relation in DDoS Orchstration section.
If you are OK with this change, please merge it.
By the way, this figure is truly abstraction of our DDoS mitigation service, although it is not using dots protocols yet.

regards,
Kaname
On 2017/04/25 4:55, Daniel Migault wrote:
Hi Med,
Thanks for your comments. I have updated the document [1] with your comment. Feel free to let me know if you I have not addressed them appropriately.

We committed in Chicago to have the document ready before next meeting. I believe we are close to finalizing the document. I suggest the following planning: collecting comments by Friday  April 28 so we make the document ready for WGLC next week.

Things we need to clarify before publishing version05:
 - 1) Is the Home network use case described in the document better fit a inter-domain use case or an intra-domain use case. The reason I considered it rather a intra-domain is that I am considering that the ISP has an advantage of having the detection within a CPE, and in the use case we considered that the CPE is partly administrated by the ISP. The reason it might also be considered as an inter-domain use case is that the Home network may also ask the ISP to perform the DDoS mitigation.

I think it worth being discussed, I am fine having the use case in the inter-domain as well.

- 2 ) add a figure for the orchetsrator use case.

[1] https://github.com/dotswg/dots-use-cases/pull/1/commits/e7926b46640fb673e992d51598400caea22eb1e1

On Thu, Apr 6, 2017 at 8:17 AM, Teague, Nik <[email-masked]<mailto:[email-masked]>> wrote:

On 06/04/2017, 09:52, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Daniel, all,

Attached my review of this version of the use case draft, fwiw.

Cheers,
Med
Thanks! – your review is much appreciated.

-Nik

---

From: kaname nishizuka <[email-masked]>
Date: Fri, 28 Apr 2017 16:45:39 +0900

Thank you for correcting the target repository :)

thank you,
Kaname

On 2017/04/27 22:40, Daniel Migault wrote:
> *From:*kaname nishizuka [mailto:[email-masked]]
> *Sent:* Wednesday, April 26, 2017 11:32 PM
> *To:* Daniel Migault <[email-masked]>; Teague, Nik <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; [email-masked]
> *Subject:* Re: My review of draft-ietf-dots-use-cases
>
> Hi Daniel,
>
>     On Thu, Apr 6, 2017 at 8:17 AM, Teague, Nik <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>         On 06/04/2017, 09:52, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Hi Daniel, all,
>
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots